Cannot use LeakSmart valve with ST app

I am new to ST, but have successfully paired our existing switches, outlets, etc with the ST hub. I have a LeakSmart water shut off valve that worked with IRIS in the past. I reset the valve to factory settings and paired it with the ST hub, and I can see it in the app and on the web login. When I tap on the water valve on the app it says: “Cannot connect to device. Check device and try again” Does anyone have any suggestions on how to make this valve work from the app?

Did you use a custom device handler to connect it? Have you tried installing the SmartThings Classic app to see if it works?

I’m not sure of how to do a custom device handler. I’m pretty sure I am using the ST Classic app. When I click on “About SmartThings” on the app it says:
Version 1.6.31-255

1.16.31 is the new SmartThings app.
2.17.1 is the Classic app.

I know the numbers are crazy with the apps. :slight_smile:

Try installing the Classic app and login as New to SmartThings and see if the valve works there.

I installed the classic app. Same issue. It finds the water valve, but it just says “please wait” next to the device. Any other suggestions?

FIXED! On the api website it showed the valve as a “thing”. I went to edit and changed it to a Zigbee valve and it works perfectly now. Thanks for your help.