Cannot register SmartThings Station EP-P9500TBEGUS

Using the SmartThings app, I am unable to register SmartThings Station EP-P9500TBEGUS, using any combination of 5G or 2.4G, restarting the SmattThings app or not, and VPN off or VPN on. This is the consistent error message I receive:

“Something went wrong. SmartThings Station couldn’t connect to SmartThings. If you’re using a 5G AP (access point), try again with a 2.4G AP. Error code: 86-002.”

I need a little guidance, please.

1 Like

iOS or Android? which brand phone and version of OS?

tagging @Automated_House

1 Like

what color is the hub status LED and is it solid or flashing?

Android v13, Samsung Galaxy 20 FE 5G, One UI v5.1

The hub status was flashing red, blue, green

Any resolution on this? I’m having the same issue and not having any luck.

Ditto, having the same problem

can you provide more details:

  • is there a message displayed in the app?
  • iOS or Android and version of the app?
  • led color displayed on front of hub and solid or blinking?

“Something went wrong, There was a problem connecting to the device”
Error Code 04-151

Android SmartThings app ( on a pixel 7
Led color cycles through red green and blue until I get to this point and then flashes blue only until it fails.

I wish you the best of luck. I’ve been here since May, and I believe this error has them stumped.

1 Like

Just bought a SmartThings Station. Same problem. The Samsung SmartThings support page doesn’t even mention the SmartThings Station, just the old hub model. There is no indication I can find anywhere of what error code 04-151 means.

I’ve also run into error 04-151. The Smartthings app fails to connect to the station repeatedly.

Tested phones: Pixel 4a 5G on Android 14 (UP1A.231105.001), iPhone 6s

I’ve tried:

  • connecting via nearby devices
  • connecting via the QR code
  • switching to a standalone 2.4 Ghz wifi network
  • toggling phone Bluetooth
  • switching to a completely different local network
  • device reset
  • power reset

No difference in outcome or further connecting to the station. This is a very frustrating user experience

Having the same issue here. Just got off the phone with a Samsung support agent, who is sending it to their “escalation team.” Has anyone else contacted Samsung directly about this?

I had the same problem trying to Register the SmartThings Station I got for Christmas using my Pixel 6a phone running Android 14 and Android app I got Error 04-151.

So, I decided to pull out an old Motorola Phone running Android 9, and Android App and it installed and registered the Station with no problems.

The Firmware was only 46.x so I used the “Update Firmware Button” on the hub’s information page and it updated to 50.010 which is current for the Station.

I was also able to change the WiFi network using the hub’s settings page.

having the same problem

I have the exact same problem, Error Code 86-002 when trying to register the device to my account. I am using Android version 9 with SmartThings version I have been working with support for over a month now. It has been escalated to the engineering team but there has been no solution.

have you tried installing an older version of the ST app?

Yes, I tried version that Paul mentioned worked. It did not work for me. Same problem.

is that the only version you tried? any older versions?

I just tried version, but same problem. I figure any older versions probably don’t support the smartthings station.
I did get a log dump and see the following in it just before it fails. I don’t know if it is relevant or not.
[Onboarding] StdkCloudModelCore.Failed to post getDeviceId - no device Id

1 Like