Cannot re-add SmartThings Hub v2 (STH-ETH-250) to my account

Hi, I have been having trouble trying to add devices to my SmartThings Hub v2 and today decided to remove everything and factory reset my hub to try to start from scratch to see if that would help. After factory resetting the Hub, I attempted to go through the process of adding it through the app:
Tap the + → Add device → By brand → SmartThings → Smart Home Hub → SmartThings Hub (STH-ETH)
I also tried through the Samsung Brand (Samsung → Smart Home Hub → SmartThings Hub 2015 (STH-ETH & Others) and get the same results as below
This takes me to a screen that says “Select a location and room for your Wi-Fi/Hub.” There is box for Location and Room. The location dropdown is empty. When I tap it, it only shows “+ Add new location” as an option, despite the fact that I have a location on my account already. Tapping Add new location anyway brings me to a screen to add a location. When I type in a new name and hit Done, it spins for a moment and then flashes between the previous screen and a fresh add new location screen. The location gets added to my account, but never shows up in the list on the “Select a location and room for your Wi-Fi/Hub.” page. At this point the app is mostly stuck in a loop trying to go to the Add new location screen.
I tried calling SmartThings support, but of course they are closed today. Trying to Google the problem has not yielded any results either. I found this post from 2-3 years ago:

with no resolution mentioned.
I have tried clearing the app data and relogging in with no change in the behavior. I also tried clearing the app data, uninstalling the app, and reinstalling with no difference. I have the latest Android app version from the Google Play store. I allowed all permissions after clearing data. I cannot even get to the point to try talking to the hub, so I assume it is a problem with the app and not the hub. Is there any other way to try adding the hub? I cleared everything out from and it says to use the app to add a hub. Any help would be appreciated. Thanks!

1 Like

Only thing I can suggest is to contact ST support. Several users have reported the same issue after resetting their hubs recently.

But it is an opportunity to remind others reading this thread to NOT reset their hubs when Edge Drivers do not work or not able to pair devices. Ask in the forum first in case it is a known issue that can be easily resolved.

Only thought is to download an older version of the android app in case it is an app related issue. I don’t know.

I wanted to reset my hub for multiple reasons in addition to not being able to add devices, one being that it was not listed in the app anywhere. I think I hid it at one point trying to declutter my list of devices, but it was no where to be found in the app.

I am not exactly sure what I did, but I noticed after hitting back on the Add new location screen a few times, it stayed on the previous page and the Next button was no longer inactive (despite the Location and Room fields not showing set). I tapped the Next button and it continued on and was able to get my hub added. No problems after that. Now to see about excluding and re-adding my devices…

1 Like

I am on a similar boat.

My main ST wifi is working but I try to add the secondary one and it gets stuck on 43%.

Now all of a sudden the Main hub is showing offline.


After like 20 times of clicking cancel to the new location, I was finally able to click next. Thanks for the advice. Didn’t think I just had to brute it lol.

1 Like

This EXACT thing is happening to me right now

Hello, I have the same problem, I reseted my Network, and now I Cann’t add more Hubs, every time that I add a new Hub they Stuck on 43%, I use iPhone.
Any Idea to help?

I have this exact same issue, app is talking to the cloud (can rename location) both phone and hub (v2) have active internet. BUT app is not picking up location (have tried cancelling lots of time with no joy) did anyone find a proper solution?

1 Like

Had the same issue of the hub getting stuck at 43%
It finally worked after I reset the hub while it was connected to ethernet cable that has internet connectivity.

I unplugged the power cable, kept ethernet cable connected then hit the reset button and reconnected the power while doing so untill it reset

Having this issue right now. Still no headway on it?

Report the issue to ST support.

Seems not. I’ve got the problem too on three accounts on three devices and three Locations. Seems to have been a problem since at least early June.

I hope I never have to discover the protocol for getting the ball rolling. The mobile app is completely useless for contacting SmartThings support in the UK so you definitely have to use e-mail, I know that. You need to craft a decent first message for the rare occasions the automatic scripts don’t prevent it being read properly. However it won’t actually be seen until you send a second message confirming your account e-mail even though you’ve done that in your first one. Then you have to send a third message which says the same as the first one and this time it should actually get read properly and the support bod is actually allowed to answer it properly. Something like that?

I just can’t understand how this isn’t a known issue after two months.

It turns out that it is and that it should be fixed in version 1.8.5 of the app that is currently rolling out.

It is ? Has it landed with you yet Graham?

I’m just seeing it on one now. Fiona from UK Support is awfully convincing so I took her word that it was on its way.

1 Like