Cannot Install Smartthings App on Samsung Galaxy S8+

I uninstalled the classic app (which was working great) and installed the latest release. It worked ok for a while but soon locked up on the home screen. I uninstalled the new app and tried to reinstall the new app. It will not get past the main screen. Neither will the classic. Neither will accept my email in the login screen.

Anyone have any suggestions?

try selecting New to SmartThings when logging in, then use your Samsung account.

1 Like

Thx 4 reply…

I tried that… I get nowhere there either

Try clearing your mobile browser cache for any data for SmartThings/Samsung

I tried that… I don’t get any responce with the “New” prompt

Not using browser… using App… But thanks for suggestion… I have gone into the App settings and cleared all data and cache. Still will not move past the email prompt when setting up app

Are you signed into a Samsung account? Settings --> Accounts --> Samsung account?

With an S8+, you should sign into your Samsung account at the device level and then when you tap “I’m a new user” in the Classic app, you will be prompted to use your Samsung account.

Yes, I have signed into my Samsung Account, left the account open while logging into the app…

Same thing… it will not move off the “Email” prompt… The “New User” option will not even continue to the “Email” prompt

Thx all

Just curious, but do you see a SmartThings account on your phone along with a Samsung account? If so, what happens when you remove the SmartThings account and try starting up the app again? It should prompt you for your email again, but this time recreate the ST account. Perhaps something got corrupted earlier?

OK fellows I found the solution

I had to wipe the partition cache in the phone OS set up… This was done by first powering off the phone, then pressing the Bixby key, the volume up key, and the power on key simultaneously. Use the volume down key to cursor down to the “Wipe Cache Partition”, Accept the warning and then exit. Everything is working fine now…

Thanks for all the effort

1 Like

Wow, how did you figure that out?

Just brilliant I guess… JK!
Called Samsung technical support and was lucky enough to get a rep who supported the Samsung phones before she moved to the Smartthings support.

Lucky me…

1 Like

I think you mean “Wipe Cache Partition”, not “Delete partition cashe”.

Correct… My bad

Post corrected… Thanks

At my age close is outstanding…lol

Didn’t work for me :unamused:

Had to wipe PlayStore app data, this fixed it.