Cannot instal SmartThings Find within SmartThings App

I have a Samsung Galaxy Fold 4 and recently bought a SmartTag.
I already had the SmartThings app on my phone, but to use the map search I need the “Find” add on.

Whatever I do, I can not install this Find add on.
When I try to install it I get an error “There is a network- or server error. Try again.

I checked “”, but there are no known issues at the Samsung side.
I deleted the app cache, tried again without succes.
I deleted all app data.
I deleted and reconnected all devices that use geo tracking
I rebooted the phone
I reinstalled the complete software
Tried on both WiFi and Cellular connection

Nothing works. Every time I receive the same error.
I am situated in the Netherlands, but as far as I know this serivce has to work here.
I also tried the online tracking website “”, that works just fine.

Does anybody have a suggestion what is wrong?

had exactly the same problem with Smarttag+ and S22 Ultra

Solved in the following way:
Go to Life-tab in Smartthings app → in the right upper corner press on 3 points icon → press Delete → delete Find
Then go to Life-tab again and press on “+” → Add Find

Hope it will help