Cannot get sonos to work


#1

I have tried everything I have read about playing the station first in the sonos app, when I choose play this track, no available options appears. I want it to play a station on my pandora. Can this be done?


(Micheal ) #3

I am sure you have tried this, but had a similar problem and playing a song, then pressing the ‘refresh’ button within SmartThings app got me the list for the other apps to see.


(HousePanel Author) #4

I have had unsatisfying success with getting Sonos to play reliably from the ST apps. It sometimes starts and then stops. Other times it repeats and plays on top of itself. And yet other times it does nothing. Every once in a while it works as expected, but that is the exception rather than the norm for me. The only thing that works reliably for me is resuming a song that was started in the iPhone app.


(Bhagopian) #5

My sonos’ are also up and down. I have a motion sensor that when its sees motion turns in the morning it turns on kitchen light 50% and plays weather report through sonos. Light always works, sonos… well lets just say I should have brought a rain coat to work yesterday but have not got the weather in 2 weeks! Before that worked for a month and then down. I have reset hub, reset sonos, sometimes good sometimes bad. Music will pay through sonos app. Never had it work right through ST, especially if playing music, ST chimes in with announcement, sonos will not resume.


(HousePanel Author) #6

Yup - that mirrors my experience as well. I gave up and I only use the Sonos app now. I guess that is why it is still in the ST Labs section…


(Bhagopian) #7

Ha! I did not realize until your post that sonos was in the labs section! I am ok with it now, it is just growing pains!


(Paul Peters) #8

I don’t see a refresh option in the smartthings app.


(Paul Peters) #9

Never mind found the refresh at the sonos thing. Did not work. I got it to work a few weeks ago but all of a sudden it quit working and don’t know how to get it back. I want a Sirius station to play when I leave the house for my dog. I also want to turn on a switch for a camera. None of that works now after working for about a week. Not sure what happened.