Cannot Create a Device Profile

I am trying to integrate a IoT project using a Raspberry Pi with the smart things platform, I am getting through this process with the pi using the “rip-st-device” repo in git. however when every time I try to create a device profile I get the following error "There was a problem submitting the device profile.

Something went wrong with the Dossier service

Hi @jcajuste Welcome to SmartThings Community

If you change the name, does the issue still happen?, if the answer is yes, Do you have the same problem using the SmartThings CLI?

If you can share the requestId it can help to track what happens, it must be on the browser logs

Hi @AlejandroPadilla, thank you for reaching out. changing the name still give me the same issue and I have yet to install and try the CLI but will install it and try. additionally, the request ID for the last request I just tried is “911EE0730DE948BC95E235FA918BCE5D”

@jcajuste I checked the request and saw the name that you used, I tested to create a device with that name and I got the same error, I added an extra character and I was able to create a device profile without problems, so it is probably that the name is used internally and that is the reason of the problem.

Also, a recommendation is to check the device profiles that you have with this command smartthings deviceprofiles and see if the name is not already in used for other device profile.

@AlejandroPadilla I am realizing that I am getting this error prior to the “name must be unique” one.
the RequestID: “4A06AF7490934D7EAF6FB370D4B22168”

additionally, I was able to check and see all the device profiles through the CLI, however every profile that is showing gave me that same error when I tried to create it and showed no indication of actually being created.
Screenshot 2024-03-04 at 3.37.38 PM

So, every time the profile is created (by workspace) the error appears, but is the device actually created?

Did you get the same error using the CLI? smartthings deviceprofiles:create

when the error appears the device is never actually indicated to be created, however I see the new device profile name when searching smartthings deviceprofiles on CLI.

I was able to create a new deviceprofile on the CLI which provided all the profile details when complete. is there a way to check the other deviceprofile details so that I can properly create a ‘device_info.json’ and ‘onboarding_config.json’ file. for reference I am using this repo “rpi-st-device/python at main · toddaustin07/rpi-st-device · GitHub” to set up my rpi.

also, how will I be able able to test this connection and set up to view this device on smartthings UI?

I’m not familiar with the repository sorry, but what exactly do you mean by this?

You can see the information of you device using this command smartthings deviceprofiles {id} -j or if you want to make a copy of the fille smartthings deviceprofile deviceprofile {id} -j -o local_file.json.

I am working to connect my rpi project to the smartThings through cloud connect so that messages that are being sent to the rpi through MQTT can also be sent to smartthings. The end goal would be being able to see the message notification from the rpi on the smartThings App.

also, when trying out the command to view the details I got the same error for the device profile created from both the CLI and the Developer UI.

You have to supply the UUID of the device profile or the order list number to specify which profile to display, not the profile name. So this:

smartthings deviceprofiles 3395686d-XXXX-XXXX-XXXX-fd53e728c86d -j


 smartthings deviceprofiles 1 -j

You can see both the UUIDs and the ordered list values like this:

bep@debian12:~$ smartthings deviceprofiles
 #  Name                Status       Id                                   
 1  schlage-be469-test  DEVELOPMENT  3395686d-XXXX-XXXX-XXXX-fd53e728c86d 
1 Like

Thank you @h0ckeysk8er that completely went over my head at first.

having the device profile .json configurations is definitely a big step.

is there a similar way to also creating an onboarding json file through the CLI?

I’m not sure what you are referring to as “an onboarding json file”.

@h0ckeysk8er when initially trying to do this through the Developer UI the 3 steps under Develop where what I needed to complete to the connection. Even in the git repo I am using as an example they call on to that file to confirm and complete the connection.

I also can not download it though the Developer UI unless I deploy a test first which also can not be done unless I create a new device profile on the Developer UI. since I have resorted to creating the device profile through the CLI, I am wondering if there is command steps to complete the UI process through the CLI?

@jcajuste Unfortunately at the moment the CLI can’t do it, I recommend you do the following

1- Go to Device profile manager that is on the workspace and verify the name of your device profiles created to avoid duplicating it.
2- On the Logs I see that you tried to create a device profile only with the capability healthCheck this can generate problems, so I recommend that you add more capabilities
3- Try to create a very unique name to see if that is the real problem or not

I was testing today to create different profiles on the workspace for some direct-connected projects and only was able to replicate the issue when I used a name already used for another device profile.