Can’t login as can’t press verify button

Upgraded iPhone. Wanted me to log back in to the ST app.

Get the text code, but the “verify” button is unpressable.

Tried numerous things, restarting, uninstalling app etc but nothing.

Anyone help, this is on an iPhone, official ST app, on iOS 15.

1 Like

There have been some issues reported with iOS15. Not sure if that is one of them but search here for those posts. I’m on Android so no experience with that OS.

try logging into https://account.smartthings.com in safari

+1 on this issue, can verify and log in in browsers but not the new app on iOS 15.

I have experienced the issue previously but this was before iOS 15. For the life of me, I can’t remember what I did to resolve the issue. It did take several minutes before I got the verify button to work.

Some things to try:

  • type in the code instead of copy/paste
  • try using cellular only or wifi only
  • my favorite, turn off bold text in settings > display and brightness

For some reason, in my foggy memory, I believe it was typing in the code manually that eventually worked instead of clicking on the code from SMS and letting it get pasted into the field by iOS.

Just when you think the miserable iOS app can’t get any worse…

Type in the code instead of pasting. Worked for me.

I had this same issue and typing in the code didn’t work. Eventually I used a backup code which worked properly.