[BROKEN] NST Manager v5.0 (Does Not Work Anymore)

@tonesto7, Great work here! I just got ST working with Nest had a question.
I have 2 NESTs in my home. When I walk by the unit lights up, sensing motion.
Is there a way to tap into this event, and use it to trigger an automation or something?

Motion from the thermostats (and Protects) is not exposed in the Nest API so it can’t be utilized in NST Manager/SmartThings.

Thanks for the reply. Got to admit it would be cool!


We are all dreaming of the day :crossed_fingers:

Thanks. It happens on all my devices (phones and tablets). I can’t uninstall it either. I opened a ticket with ST to uninstall it for me. This is the second time I’ve tried to uninstall it and can’t and it is pretty frustrating. I was able to get rid of the error by reloading everything from the repository but still worry why I can’t uninstall it.

One thing I’m not quite sure about is that when I click on a Nest Protect in my ST app, it says: “Reminder: HTML Content is Available in SmartApp.” Yes, I see that content in NST Manager, but from the screenshots at the top of the post it seems liks I should see some of that content in the ST app as well. Am I doing something wrong?

The last couple of updates (starting with 5.4 i think) have removed and recreated the vThermostats that are associated with automations. Is this expected? Don’t remember it doing that before?

It’s kind of a pain because other apps depending on the vThermostat device stop working until you re-add them to the other apps (ex. WebCore, ActionTiles, InfluxLogger).

Action Tiles is probably the biggest pain because you have to add it to the ST app and then go into the AT tileset and re-add it there too.

I’m struggling to understand this issue for a few reasons:

  1. We didn’t make any changes to the way that vTstats and managed
  2. If the device was in use in any other smart apps, routines, etc. then NST won’t be able to remove it.
  3. Refer to item 2. because we have an issue on the platform when users try to remove the app/devices it won’t let them because they are used elsewhere.

I don’t understand it either. I update via Community Installer if that makes a difference.

After the update, I have to go into NST manager and re-save the automations for the vThermostats to show back up in the device list and then go into each ST app and re-add them.

I guess I can try and screen capture next time an update is pushed.

@Nezmo To resolve this issue, open NST Manager and go into manage/view devices. Deselect all your cams, then click Next and then Save. Once they are removed from your device list, go back and add them back. This appears to resolve the issue where you can’t open the cam devices.

I will continue to try and duplicate this.

1 Like

@tonesto7 how do we get the nest devices to work in Samsung Connect, if possible?

I have changes pending to get the thermostat to show in the new app

namespace: “tonesto7”, author: “Anthony S.”, vid: “SmartThings-smartthings-Z-Wave_Thermostat”)

1 Like


I have a slight issue with influx logging that I didn’t seem to have in earlier versions of your SmartApp.

Indoor humidity isn’t logging and longer. I am not sure why but, here is the query from the database.

SELECT mean(“value”) AS “mean_value” FROM “SmartThings”.“autogen”.“humidity” WHERE time > now() - 6h AND “deviceName”=‘Nest Thermostat’ GROUP BY time(:interval:) FILL(null)

Your query is syntactically correct but returned no results

I have definitely logged indoor humidity with influxdb. Not sure why it stopped.

Any ideas?

Thanks. I’ll give that a try. This is not the same as deleting a device in ST right? I’m trying to understand if this would affect automations that I have set around some of my Nest devices.

Unfortunately it does remove the device from ST. But you only need to remove the cams

1 Like

It would definitely appear that indoor humidity is NOT getting logged on IDE logging. So, this isn’t just a database issue. I’ve also noticed that humidity isn’t logged in “Recently” in the app as well. Glad this isn’t just an influxdb issue.

@Tony_B - Humidity is still being logged for me:

What are you using to ship to Influx - InfluxDBLogger? If so, you might want to check that app’s settings to make sure that the Nest Tstat humidity sensor is checked. I’ve had an issue with the last couple releases that has forced me to go into other apps and re-add the Nest devices after a NST mgr update.

Thanks! That solved the issue! I forgot that a recent release completely replaced all my nests and I had to add things like that. Completely forgot about that.

Which release recreated all of your Nest devices?

Thanks for confirming that it was a release issue. Glad it wasn’t just me.