[BROKEN] NST Manager v5.0 (Does Not Work Anymore)

read my comment directly above this and it will correct your issue for a little while…

I should turn home /away assist off?

If you are using NST to set home/away absolutely…

I just did still Showing this : :57:35 PM: error | NST Manager (v5.4.0) | nestCmdResponse error - (Status: 429 - blocked) - [ErrorLink: https://developer.nest.com/documentation/cloud/error-messages#blocked]

d3501bbd-1e24-43fc-b94a-1685706be595 1:57:35 PM: error | NST Manager (v5.4.0) |
The (nestCmdResponse 0 (devices/thermostats{target_temperature_f:70})) CMD sent to the API has failed.

Your going to have to wait… sometime nest blocks rate-limited requests for up to 1 hour

this is bad but , this problem still happening over some hours , I have problems to set up the thermostat timer , and with swich to turn ac off.

maybe the automation you are using is sending to many commands…

What i should do?

I should do something about this? ContactBook is NOT Enabled on your SmartThings Account

The device handler code for the cameras are the latest (5.3.8). I am running the latest on all.

Have something i can change to fix this?

any idea?to fix this?

I need more details than contact book not enabled. Where are you seeing this?
I just pushed out 5.4.1 to remove the only mention of the contactbook from a log output when sending notification

I’m still seeing this with 5.4.1.

Note, I have six cameras. This only happens when trying to open the first camera device in my list (my only Nest Cam Outdoor although I’m sure that’s not relevant). The other five are fine. It’s not the first camera device I click (say I picked the third in my list - it’s literally only a problem on the first camera in the list). This is repeatable and happens on my iPhone and iPad.


I update now looks is working fine

Now is working everything ok tks

i think i talked to early : warn || NST Manager (v5.4.1) | Command Matches last in queue 0 - Replacing

debug Nest Thermostat - Living Room (v5.3.6) | whoSetEcoMode is (Not in Eco Mode) | Original State: (Not in Eco Mode)

d3501bbd-1e24-43fc-b94a-1685706be595 1:47:44 PM: info ||| NST Manager (v5.4.1) | schedNextWorkQ RUNIN │ RATE LIMITING ON queue: 0 │ schedTime: 61 │ recentSendCmd: 0 │ last seconds: 318 │ cmdDelay: 1 │ allowAsync: true | runInActive: true | Api Limited: false

d3501bbd-1e24-43fc-b94a-1685706be595 1:47:44 PM: info ||| NST Manager (v5.4.1) | Adding Cmd to Queue 0 (qsize: 1): azViYI1t7nLnqoKrdYBS-Fai3VqCG0rG, devices/thermostats, hvac_mode, off, azViYI1t7nLnqoKrdYBS-Fai3VqCG0rG

d3501bbd-1e24-43fc-b94a-1685706be595 1:47:44 PM: info ||| NST Manager (v5.4.1) | sendNestApiCmd azViYI1t7nLnqoKrdYBS-Fai3VqCG0rG, devices/thermostats, hvac_mode, off,

I have 2 Nest Protects. Today, I noticed that if I open either device in the ST classic app, I get an error message underneath the top tile (the one that shows CLEAR - BATTERY: OK):

“error”:true, “type”:“groovy.lang.MissingMethodException”,“message”:“An unexpected error occurred.”}

I’ve trying updating the smart app (I’m on 5.4.1 now) and tried removing and readding the Nest Protect with no effect. I tried uninstalling NST Manager and reinstalling but I’m unable to uninstall it. Probably a year or so ago, I had to have ST support remove it for me (I’ve opened a ticket to have them remove it again) and I’m wondering if something is messed up in my profile.

you might try forcing a restart of you classic smartapp on your phone.

Otherwise check IDE logs.