[BROKEN] NST Manager v5.0 (Does Not Work Anymore)

I reset everything up due to the nest Developer account issue but now my automation wont work I keep getting temp not separated by 3. My set points are 69 and 72 I have tried spreading them more and it does the same error. Any help please…

So one of two things are happening here:

  1. Nest is now actively blocking Auth/API requests from SmartThings
  2. SmartThings OAuth flow is broken

I can click my thermostat in the device list and then change temp it will show up on my thermostat

Hmmm…@TonyFlesher above mentioned that after he removed everything and started over, it’s working for him. I would think if Nest is actively blocking requests, it would be an all or nothing deal, right?

It sounds more likely a ST platform issue if anything. I just got home and my routine didn’t trigger either. Here we go again.

I removed and reinstalled after I did the Developer thing and it works except it will not automate due the error I posted above.

Just out of curiosity, did you use the Community Installer app to update NST Manager?

not me I update via github

Ok looks like that was coincidence because the Community Installer app wiped out the Nest Tokens. Sounds like there is another issue going on here…

I just want to report that although I did have to re-enter my Nest Login Credentials in NST Manager last week, after doing that, everything has been working fine, and I don’t see any error messages complaining that my Nest Token or Client ID/secret are unavailable or missing.

For what it’s worth, I switched from the beta to the master repository early last week, now running v5.3.3 (Jan 28th) release.

1 Like

Thanks for the update Keith.

Did you already have a Nest Developer Account created when you re entered your credentials (your Settings already contained id and secret)?

We are working with several people offline right now and just trying to isolate different scenarios with the issues that have cropped up with tokens being revoked.

I am on the beta

1 Like

Yes, I created the Nest Dev Account and set up my token / Client ID / secret last December.


Thanks guys.

yes thanks. I’m struggling to find the cause of this revocation of tokens.
I am working on at least fixing the remote diag stuff locking users out of the app as a start.


FYI: The revocation of the token affected everyone who was using a previously generated token through NST Manager and also those who have their own independent Nest Developer account / token.

I believe this caused most, if not all, to have to re-authenticate between Nest and NST Manager. If you already applied your Nest Developer id and secret to Settings, it should have been as simple as logging back into Nest and done. For those that had a NST Manager generated token, you should have just needed to create a Nest Developer Account and apply those to the Settings, Update and then authenticate between Nest and NST Manager again.

We are trying to isolate who did what and at the same time, those of you who used the new installer or updated using GitHub or transitioned from beta to master or manually updated, etc.

So when reporting new issues, if you can all specifically state what the original issue you encountered was. Then explain what it is you attempted to do and from where and what method, and then if there is a new issue created because of what you attempted to do, what the new issue / behavior is.

This will help us when trying to troubleshoot what the heck is going on over the last week.

Thanks all.

I had a token generated by the NST Manager app. I am getting:

I have NOT yet tried to set-up a dev account. I’m waiting for the dust to settle.

Hey Nezmo. You should proceed with creating a Nest Developer Account. You will not be operational until you take the product id and product secret that gets generated in your Nest Developer account and then copy and paste that into Settings in NST Manager in IDE. This is standard operating procedure :slight_smile: Yours is straight forward.

1 Like

I had the same thing @Nezmo - I just followed the wiki and created a Nest developer account, everything went very smoothly and I’m good to go now!

Thanks @tonesto7 @WB70


Kinda thought so.

PITA but here goes.


1 Like

Hehe I hear ya. But it just takes about 15 minutes. More copying and pasting of the descriptions of the permissions more than anything. Once you have done this though, it’s your own personal token that you can always use.