[BROKEN] NST Manager v5.0 (Does Not Work Anymore)

everything was working so well… we need a developers account now to use this app?

If you read the wiki, there’s an explanation as to why it’s needed. It’s always been recommended to have your own account since the burden was on the development team to acquire tokens.

1 Like

I guess so. I’ve been using this since the beginning with no problems really. I’m hoping there’s just something up with the IDE and I can get my new ID and secret entered soon.

Glad I checked here - thanks for the info.

One question - does anyone else a spinning icon when clicking into their thermostat? It’s in the middle of the page and I have to scroll up to see my Nest Thermostat info. I’m not sure if my pihole is blocking something the device is trying to grab. Thanks.

@tonesto7 @E_Sch
Im able to hit update on any other of my smartapps and they update fine. NST manager gives me the 403 error with or without my new developer info. Im unable to access the app to turn these notifications off. Any ideas? Thx

Just wanted to share my latest creation :slight_smile:


Hi, new to replying on this forum, so hopefully I’m replying in the right place. I’ve been using tonesto7’s Nest integration for quite a while now, and have updated a few times. But I just updated and I can’t get it working anymore. I think I may have also accidentally lost the original client ID & secret I’ve been using since day one by going in the apps settings in the ST app. Anyway, I deleted everything and reinstalled, this time using GIT integration. I believe I followed the instructions correctly from the wiki, but like a few others, when I try to enter my new, unique client ID & secret from Nest into Nest Manager’s settings field of the Edit SmartApp page in the IDE, it keeps saying “Access to graph.api.smartthings.com was denied”, “You don’t have authorization to view this page.”, “HTTP ERROR 403”. And, of course, when I try to install the SmartApp from the ST app, it won’t let me, complaining that the client ID & secret are missing. I tried browsing around the forum but I haven’t found any suggestions that I haven’t already tried.

Thanks. That fixed the second screen. I ‘fixed’ the other problems by resetting the stored data and starting again (so probably a user error then :)). All working fine now.

Looks like something happened to the API yesterday, as my Nest Protects are no longer getting updated data. They say online, but the updates are usually very often. The Smart App gave me the warning about the API not authorized, so something on Nest’s end?

i’m not sure who’s at fault i’m just tired of all of the issues lately with ST.
I’m also very irritated by Nest at the moment.

I almost just smashed my 1st-Gen Protect. When it decided there was smoke in my Dining room while my wife was receiving a phone call that her very close friend from work passed away unexpectedly last night.
I unplugged it and it wouldn’t shut off i stuck it in front of a fan and it eventually stopped.

I think my problem might be ST related (as opposed to Nest.) When I reinstalled everything in the IDE, and first tried to enable OAuth, I got a similar error. After trying a few times it finally worked, but no matter how many times I try entering my client ID & secret, I just get the error (although I haven’t retried since last night.)

@tonesto7, I hear you about your frustration with Nest. Before I started using your SmartApp, I tried using Nest’s native geofencing, etc., and their direct integration with Life360 (which used to work.) It all broke with an update, and I was e-mailing with their senior tech support for months and they never resolved the issues. From some other Googling I did, one has to wonder if their Engineering team really cares about their existing products. Seems these days like they’re more interested in creating new products to sell rather than keeping their existing products working correctly.

And sorry to hear about your wife’s friend. Please give your wife my condolence.

I am having problems since last night with the integration also. The dev key stopped working (I had never set up my own and when I went into nst manager it said I needed to have a dev key). Today I went through the setup process, but am getting api errors in the logs and nst manager seems to not be working.

As an update, somehow the Smart App got logged out of the Nest account. Once I went into the app and entered the information again, all the Protects came back online :slight_smile:

I think that might have been the first thing that happened to me, too. But when I tried to log back in (before deleting all the Nest stuff from the ST App and IDE and reinstalling) I couldn’t get it to log me back in. I had two pass authentication (or whatever it is called) enabled, and when trying to log in from the ST app it kept getting an error. So I turned two pass authentication off and tried with just my username and password, and it still wouldn’t work. So then I deleted and reinstalled everything (at least I installed everything in the IDE), but when I tried to install Nest Manager from the MarketPlace in the ST app, it wouldn’t let me because the client ID & secret weren’t configured. And that’s because I keep getting the error when trying to enter these in the settings of the Nest Manager SmartApp in the IDE. I’m still stuck.

I’m having the same issue as well. Has there been a fix yet? When I go to “Works with Nest” it no longer shows the the NST Manager is connected. Do we need to Delete and Re-Install or is there an easier fix for this? Or should I just sit tight until there’s a new update released?

I went through this last night. I did not delete anything. I followed the rules for creating a Nest Developer Account and entered the secret and product ID into the nst manager in IDE. I opened my Nst Manager in the St app, it prompted me to login to my Nest account and everything worked again. Here are the instructions for creating a Nest Developer account:

I went through this process this morning, and all appeared to work, but the devices are not updating nor providing control of my thermostat. Is the integration to the thermostat working for you?

Yes, everything is working for me.


@tonesto7 , Is this what you recommend doing or will there be an update pushed out?

I just wanted to jump in here with a “me too” post. My Nest thermostat is not updating in Webcore, the “lastconnection” value is “Thu Feb 08 17:28:58 CST 2018”, over 17 hours ago.