[BETA v0515] Hampton Bay Zigbee Ceiling Fan/Light Controller

fan
dth_hvac

(Brock) #470

That’s interesting. Speed #4 still works in ST for me, for now. I was going to go digging in the wiring in the canopy but it was a miracle I fit it up in there the first time and I since everything works in ST (and worked w/ the handheld remote before I messed w/ the 2 wall switches) I doubt that’s the problem. I’ll keep a watch on this thread and report anything I find out.


(Super Mouse Dv) #471

I have an odd issue I have 3 of these controllers (2 installed waiting on an 8 ft ladder for the last one) well the one furthest away keeps cloning the light. so right now I have 3 light controls and none work but when delete them the last one left works fine. What could be causing this … Now I do have 2 Zigbee repeater plugs between the fan and the Hub. Any ideas… Thanks
AND FYI my other one (Closest to the hub)does not clone itself.

Hal


(bionicDan) #472

Love this functionality! Got things hooked up a couple of days ago but running into trouble similar to others.

All using the handheld remote, I experience the following issues intermittently:

  • If I switch to speed 4 with the light off, I hear a click.
  • If I switch to speed 4 with the light on, I hear a click and the light turns off.
  • Then if I try to turn on the light, it flashes on, then clicks and turns off, or sometimes it clicks quickly and doesn’t flash at all. Try toggling the light enough times and it finally stays on.

I haven’t had a chance to really dive into this and try to determine results in all cases, but I’m happy to perform more tests if it would be helpful. Just lemme know. It feels to me like when I switch to certain fan/light modes with the remote, something (in the controller hardware itself or KOF Zigbee Fan Controller) notices the mode change and reacts with a follow-up (undesired) attempt to change the mode…


(Jim) #473

I installed the receiver, have the fan and light working, installed the custom device handlers, disconnected the ST hub for 30 minutes and then reconnected it, but I still can’t get this to pop up when I go to Add a Thing. Am I missing a step or something? Total noob here.


(MarkTr) #474

The receiver may have timed out of pairing mode. If it hasn’t paired yet, flip the switch/breaker off and back on and immediately look for it in ST. Are you using the Classic or new app? It probably won’t work in the new app.


(Kavvy) #475

Has anyone else had an issue with power outages (storms)? This is the only device that hasnt accepted commands via ST or Alexa. It still shows connected as a device, but it wont respond. When I send command through Alexa to turn the light off, she says “OK” and in the app recent activity for the light, it shows up, but the light doesnt change.

Short of getting into the canopy to disconnect the device and reconnect, what should I troubleshoot?


(Steve Jackson) #476

I have had this same issue twice on one of my controllers. The controller that uses a repeater to get to the hub.

The first time I was able to get the controller working by turning off the breaker a couple times.

Last week power cycling the breaker didn’t work. I found that the controller had dropped off the network. I turned the breaker off/on and then immediately had ST look for a new device. It took a little while but eventually found the fan. The only thing is I ended up with 2 child light devices. They both work and I haven’t tried deleting the new one yet.

I am using the classic app.


(Kavvy) #477

Thanks, @oldcomputerwiz. Ill give that a try tonight. Its so annoying to walk across the room to turn the light on with the remote. #firstworldproblems


(Steve Jackson) #478

You are welcome and I hope it works for you. At least I know now that I’m not the only one that is seeing this behavior.

I spent the better part of an hour trying to reset the fan controller before I figured out it dropped off the network. I even went as far as wiring in a wall switch because it wouldn’t reset with the breaker. I never did see the blinking light indicating the controller reset. I guess something must have caused the controller to reset on its own when Peace River either disconnected or reconnected the power lines they were working on. Based on my observations, it looks like the controller will not reset if it is already reset.


(Kavvy) #479

Thats my concern though. The app shows the device (the light, not the fan) receiving the commands. My ASSumption would be if it dropped off the network, it wouldnt receive them.

Ill give it a shot, and report back.


(Steve Jackson) #480

IDK. This is the ONLY device in my home that gives me any issues. If the controller continues to “go bonkers” with each power failure, I’ll probably seriously look into how I can pull the 2nd circuit so that my light and fan are powered separately and install Z-Wave switches.


#481

Losing function

I just bought one of these and had trouble pairing. My hub is on the main floor and the fan is essentially directly above on the second floor. I brought my ADT/ST hub closer to the steps and was able to pair and operate through the app. But when I moved the hub I lost all function. I had my wife hold the hub and take small steps backwards until I could find the exact distance I lost connection. It was approx 1 foot from where the hub is usually mounted.

I thought there was interference from my Ecobee, so I turned it off but that didn’t fix it.

I read on this blog that I’ll probably need a repeater, so I got a Sylvania plug. I added it without issue and it works perfectly well. I then reset the hub through the IDE to repair the mesh so that I would bounce the signal off it to the fan. This did not work either. I reset the fan multiple times without any resolution. Every time I move the hub closer upstairs I can pair the fan and get it to work, but I always lose it.

I don’t have any other ZHA devices except two IKEA bulbs. I know that they don’t function well as repeaters, but thought with help from the ZHA plug it was worth a shot. I can’t figure out what to do next. The antenna is not in the casing, I have a solid repeater, and I have ruled out direct interference. I don’t see the rationale for buying another repeater, so I’m hesitant to do so without having some idea what’s going on.

I think that it just maybe crappy tech, but I’m hoping someone may have other suggestions. Thank you


(Steve Jackson) #482

You have to remove the batteries and unplug your hub for 20-30 minutes to rebuild the ZigBee mesh.

To make sure the bulbs don’t act as repeaters you may want to remove them while setting up the fan controller.

Not sure if this will help but worth a shot.


#483

I read that you can reboot through the IDE via “View Utilities->Reboot Hub”, and that will rebuild the Zigbee network. Is that not accurate?

Also, I have tried multiple times without the IKEA bulb as well.


(Mark) #484

@oldcomputerwiz is right. The hub has to remain unpowered for several minutes for zigbee devices to realize they’ve lost contact and go into mesh healing mode. Also the mesh rebuilding can take hours after that to complete, so you may not see immediate results.


(Steve Jackson) #485

It’s obvious that the fan isn’t using the repeater to pair for some reason. I would probably reset the fan. Rebuild the mesh. Wait 24 hours and then add the fan see if it will use your repeater.

I used a peanut plug I bought from Amazon and many others have used the gen 2 Iris plug as repeaters.


#486

Hours to complete. Wow, I didn’t realize it would take so long. Z Wave repair seems so much more responsive. I was able to repeat a signal out to my garage in a few minutes.

I’ll give it a shot, and let you and anybody else who may be facing similar issues know how it went. Thanks


#487

Oldcomperwiz’s remark on the repeater not working made me think about the repeater I bought. I bought a Sylvania smart plug on Amazon, because the Q&A section addressed whether it was or not. The person who answered it though was not the manufacturer or seller, so I wrote Sylvania and they confirmed that it was not a repeater.

I’ve read on many forums that devices that are hard wired or plugged in act as repeaters, but in this case it is not true. I bought a Peanut plug, rebooted the hub, and added the fan remote. Now the ST app operates the fan and light like a charm.

It kind of sucks that I had to use a repeater, because I don’t really need one in the bedroom. However, I was able to buy the Hampton Bay Zigbee device for only $20. For anyone in Minneapolis/St Paul that would like to get one, I bought mine at MN Home Outlet in Woodbury. There were two left when I got mine.


Sylvania Smart Plug— is it a repeater?
(MarkTr) #488

Shortly after you posted this, someone commented in another thread that they are using a Sylvania plug as a repeater…turns out there are two versions of the plug, and only one of them repeats. Thanks Sylvania.


(Steve Jackson) #489

Glad I was able to help. I added the peanut plug too even though I didn’t need it for anything else and I had to pay $50 for controller. Great find at $20.