[BETA v0515] Hampton Bay Zigbee Ceiling Fan/Light Controller

fan
dth_hvac

(Bryan Gaynor) #449

Which SmartThings app do you use, Classic or the new one (previously called Connect)?

The newer app does not seem to recognize any devices that leverage custom device handlers. I certainly hope this isn’t Samsung’s new approach. Meanwhile, try the Classic app.


(Randy Taylor) #450

That was great advice. Using the classic app works fine.
I hope Samsung will correct this issue in the current app. It would be a shame if they didn’t support custom device handlers.

Thanks for your help.


(Super Mouse Dv) #451

Just got 3 of these… (Will get a 2 more soon) installed one so far and Loving it. My fan now runs faster than it ever has. (WEIRD) still working out the bugs. but its nice to see when anything is on. Nearly every switch is
a smart things Switch… Hope to do some liquid crystal stuff in the near future.


(Allen Ratcliff) #453

Just installed 4 of these. They all paired and worked properly when first tested. But now, within an hour, they’ve all stopped responding completely to SmartThings commands. Any suggestions?

FWIW, everything else on my SmartThings hub is working.

Update: It seems like they’re interfering with one another. I have a centralized hub. Moving in one direction in my home, I have an office fan and then beyond that, a guest room fan. Seems like I can pair and have either 1 of them working, but not both at the same time. Neither of the fans are on … I’m simply trying to control the light at the moment. The moment I get the guest room fan/light set up, my office one stops responding.

Could this still be some sort of issue a repeater could magically clear up?


(Perry Cole) #454

I can not get this fan to pair with smarthings hub. Have powered cycled at the switch and the breaker. Followed all the steps I found searching. I have the Gardiner fan. I bought a zigbee switch as a repeater as I thought the distance from the hub was the issue. Moved the hub into the room with the fan and still doesn’t see it.


(Greg) #455

I have two of these in rooms next to each other. I have a repeater in each room and things work great.


(Allen Ratcliff) #456

Greg,

When you initially paired them, did you have to bring your hub closer to the fans, or were the repeaters enough that you could leave everything in place? I’m a little ignorant about how the zigbee network “mesh” is created. In my case, I added a 50ft ethernet cable to my hub, and had to take it into each room near the fan in order to get it to pair. I’m wondering if, when I put the hub back in its central location, the network gets hosed somehow. That doesn’t happen for door sensors, etc, when I pair them before installing them, but just trying everything at the moment to make sense of why they pair and work, then stop responding.

And to clarify, once I’ve taken the hub back to it’s central spot after pairing, it easily communicates with one fan or the other.Just not both. Seems more like a protocol issue than a range issue … but I’m just guessing.


(Allen Ratcliff) #457

Which repeaters are you using?


(Greg) #458

I left my hub where it was when I paired. After putting the fan cowl up in it’s final place - that’s when my communication was lost.

I then added the Lowe’s Iris Plugs which are zigbee and everything works great. My fans were not installed at the same time. But when I added the second one, I skipped the troubleshooting and just started with a repeater.

My advice for your zigbee mesh would be to power off all zigbee smart bulbs, unplug your hub for 20 minutes, plug the hub back in, wait two hours, test your fans to be sure they work, then power back on any smart bulbs. If you want to try to get away with not adding a repeater, try this rebuild first. If you still have issues - I would recommend adding the plug below then rebuilding the mesh.

https://www.lowes.com/pd/Iris-120-Volt-White-Smart-Plug/999925330


#459

Am having trouble getting this to work. I’ve installed the controller hardware and the fan works as expected with the handheld remote. It also paired with Smartthings first time, appearing as a “Thing” with status “Please Wait”. I renamed it “Living Room Ceiling Fan”.

I’ve installed the three device handlers from Github (subscribed rather than copy/pasted) and all three show “published”. KOF Zigbee Fan Controller is in blue, the others are in black (not sure what that means).

I edited Living Room Ceiling Fan to the custom device handler.No matter what I do, the fan status is stuck on HIGH. I noticed that at some point a second device Living Room Ceiling Fan Light was created. If I push the on-off button on my Smartthings app on my home, I can see the event state change on the web interface between “off” and “on”. My fan doesn’t have a light so the blue wire isn’t connected, so I can’t see if it works, but if I control the fan with the handheld remote the motor turns, so I guess maybe the remote’s light button also works, and when I push that I see nothing change in Smartthings.

I’m finding the parent/child devices particularly confusing. In the main device list I see:

Living Room Ceiling Fan
Living Room Ceiling Fan Light

If I click on Living Room Ceiling Fan Light, I see Parent Device - Living Room Ceiling Fan
If I click on Living Room Ceiling Fan, I see the following Child Devices:
Living Room Ceiling Fan Comfort Breeze™
Living Room Ceiling Fan High
Living Room Ceiling Fan Light
Living Room Ceiling Fan Low
Living Room Ceiling Fan Med
Living Room Ceiling Fan Med-Hi
but I do NOT see Living Room Ceiling Fan Light.

Does anyone have any ideas how to troubleshoot this further?

Thanks


(MarkTr) #460

It doesn’t sound like the fan is communicating consistently with the hub. Try putting a repeater (Zigbee outlet) close to the fan or in a room above. You may need to reset and re-pair with the hub in the same room as the fan.

“Living Room Ceiling Fan Light” is third in your list of child devices above (the list is alphabetical). The child devices are there to allow voice control through an Echo or Google Home. Otherwise you’d have to say “Set Living Room Ceiling Fan to 50%” or similar, this allows for more natural communication. Anyway, they’re nothing to do with your current issues - you just need to fix your Zigbee mesh.


(Tony B.) #461

I’m not sure if people know this but, Home Depot seems to have a bit of stock of these items now.


#462

Thanks MarkTr for the help and pointing out my oversight. I’ll try re-pairing, but the fan is not really far from the hub already and there are 7 rock-solid Zigbee lights in the same room, though I couldn’t guarantee whether they’re acting as repeaters or not.


(MarkTr) #463

Assume that Zigbee bulbs are not repeating:

The range on these controllers is awful and you really need to have something right there to have a reliable connection. There are several other threads in the forum about these controllers and adding a repeater is the answer to 90% of the issues people have.


#464

Great info. Totally missed the point that I have two Zigbee networks - Hue and Smartthings being separate.

Well, with the cowl off and the hub right nearby, props to MarkTr who hit the nail on the head. It’s working fine after deleting and re-pairing. Thank you!


(Ryan) #465

Once you have it paired and your hub is in it’s final location, unplug your hub for about 30 minutes or so and then plug it back in. This is the only way to do a z-wave network heal like function for your zigbee devices. Once they go into abandoned or lost most they’ll try to look for the hub in the most efficient way possible. if you’re getting intermittent connectivity with the hub, it may not lose it long enough to look for a better “route”.


(Megan) #466

Don’t forget to take the batteries out too :smiley:


(Brock) #467

I’ve got 2 switches that used to control power to my fan so I tied their wires together and capped the traveler wire in each gang box, and I popped a wireless wall switch in place of one of the switches. Works great. I assume it’s possible to have multiple wireless wall switches control the same fan?

Now that I have tied the previous wall switch wires tied together and have one wireless wall switch installed, when I use the handheld remote that came w/ the fan controller and come around to #4 speed for the fan there’s a loud audible click in the controller stowed up in the fan base and the light goes off. Click to #3 speed for the fan and the light comes back on. I’m pretty sure it wasn’t doing that when I just had the handheld remote controlling the fan/light. Makes me think it has something to do with the wiring up in the canopy where the power comes in…or maybe I’m wrong and it has been doing it with the handheld remote all along and I just have a 3 speed fan…

Can someone verify 2 wall switches controlling the same fan/light will work? Don’t see why it wouldn’t.

And has anyone experienced my weird issue when selecting fan speed 4 on the handheld remote?


(Mark) #468

As long as the dip switches are set the same way, the receiver in the canopy doesn’t know how many handheld or in-wall remotes it’s being controlled by.


(MarkTr) #469

I was seeing similar symptoms with one of mine - I wondered if maybe the remote was sending its last known status for both the fan speed and the light, and conflicting with what ST had set in the meantime, but it may have been specifically on top speed. Now speed #4 doesn’t work, from either the remote or ST - I hear the relay in the controller click on but nothing happens at the fan. Seems like a faulty controller but I haven’t gotten around to digging into it more yet.