[BETA v0515] Hampton Bay Zigbee Ceiling Fan/Light Controller

fan
dth_hvac

(bionicDan) #490

I’ve done a bit more digging into the speed 4 / light issues some of us including @baboss and @MarkTr and I have been experiencing. Curious to hear if others have experienced similar symptoms as well…

First, I tried taking my SmartThings hub offline by unplugging it and found I still get the click, light goes off behavior when I switch to speed 4 with the remote. I think this indicates the cause is unrelated to Zigbee control, right?

Then I tracked what was happening in the logs when using the remote only to switch speeds (see screenshot below). Not sure it’s useful to anyone, but check out how there are switch events when the light goes off with level 4, and when it comes on again with level 3, but no level event when it goes off – only when it comes back on.


(Brian Scheller) #491

Great work on this device handler. I purchased a Gardinier fan and installed it in the master bedroom and have enjoyed setting it up using your handler.

Using WebCore, I am trying to add manual override logic to my piston but have not been able to figure out how to determine when the fan has been controlled from the remote. I setup a testing piston that monitored the fan for events and changes to the fan speed via the Smartthings app on my phone trigger a programmatic change but turning the fan on from the remote does not trigger anything within WebCore. I have logic that monitors both physical and programmatic changes. In the Smartthings IDE logging, I do see events there that the switch value goes on and off.

What have I missed in being able to detect when the remote has been used to turn on or off the fan or light?

Thanks.

Brian Scheller


(Steve Jackson) #492

It appears, based on many posts since webcore’s inception, that very few devices actually differentiate between physical and programmatic. I doubt you are going to get this to work. Sorry…


(Ryan) #493

For all those that have to reset their controller periodically because it gets “lost” by ST. I have done a little testing and for the small dataset that I have I have had the best success resetting the fan by first turning on the light with the remote. So, if your fan can’t be controlled by ST anymore, these are the steps I take and it usually works on the first try. Also since using this method I have had fewer disconnects.

  1. Turn on the light via the RF remote control.
  2. Turn the light on in the ST app.
  3. Turn power off and back on by the breaker (or reset wall switch if you’re like me and don’t wanna have to flip your breaker all the time)
  4. Try turning the light off with the ST app. If it doesn’t immediately go off. Turn it on then off again by the ST app.

Every time I’ve done it this way it has resynced the first time.


(Steve Jackson) #494

Thanks. I’ll give it a shot next time my bedroom fan gets confused after a power failure.


(Jim) #495

Thank you, Mark. That was exactly the problem. I spent hours trying to get it to work and it turns out it was a 10 second fix. Derp.


(Mark) #497

What’s the model of the fan you have now? Does it have a light kit? How is it wired?


#498

Does anyone know if there is a way to purchase the Hampton Bay Universal Ceiling Fan Thermostatic Remote (or even the non-thermostatic version of the remote) or the Hampton Bay Universal Ceiling Fan Wireless Wall Control without the receiver if you plan to purchase one of each (a remote and wall control) for a single fan?


(David Wright) #499

Well I have done it. I installed all the handlers and ordered my first controller. I am supposed to get it Wed. Wish me luck.


(J.W.) #500

OK so i was having some issues. My fan had fallen off of the network and wouldn’t work. I got it working again by doing the remote and switch method and toggling the switch and trying to refresh the app. But now I see 2 active items and one inactive item. I added this to smart things in NOV/17. Is there new code? Should I update anything?


(Mark) #501

If you look back at the OP, there is a link to another thread that explains how to order replacement parts from the manufacturer.

That’s what we were doing before the zigbee-enabled receiver was actually in-stock at Home Depot on a regular basis.

Not sure about the thermostatic remote or wall control, but it was possible to order the non-thermostatic remote direct from them.

Even if you can confirm that you can order the parts you want, it’s not super likely you’ll save much (or any) money by going that route, though.


(Michael Ward) #502

I’m having an issue with both of my fans. they used to work fine but they have been very hit or miss for a while now, and do not turn on low, med or high when asked to through Alexa. I can ask “alexa turn on bedroom fan high” and it will just turn on the speed last selected in my smartthings mobile app, like “low” I have read through this thread again and modified lines 363 and 370 with the // and republished but this didnt help either. I also looked in my hub and the device handlers and they appear up to date. my versions are celing fan parent 0.2.170515 fan child 0.2.175015 light child 0.2.175015a. Do i have the latest versions? why wont the speed change commands work? can someone post up either here at the end or in the frst page of this thread all in the updated info and installation instructions? It has been more than a year since i installed all of this and i dont remember all the instructions. thanks or can someone point me to the page or link to what im asking for? Also here is a pic of what versions I’m running. Also there are no child devices showing up in smart things. Just the fan and the light, no speeds and in the past it showed speeds. Thanks


(Michael Ward) #503


#504

I don’t believe the child will show in smartthings app. I had to go to the ide and find them. I then renamed them to something easier, so that I could use voice commands for google to recognize it. Ie. Instead of “KOF fan control med-hi” —-> I renamed to “living room fan medium hi”

Much more intuitive to say “ok google turn on living room fan to medium hi” than the other way


(Michael Ward) #505

Thanks the childs used to show up. Also I do have what you’re saying now as far as renaming, but they only turn the fan on in the last speed setting the fan was set at. For example if it was set on low manually from a button press in smart things, and I then ask to “turn on fan high” it will only turn on the fan on low and visa versa. This didn’t used to be the case. I used to have full voice control over both of my fans and all settings. Something has changed and I’m not sure what to do to fix them. I have also completely removed and re installed the fan/child/scenes from everything and re installed/discovered them and still won’t control speeds.


(Joe) #506

So I have 2 fans with receivers and the single remote works both of them fine. Of course, they do the same thing if a button is pressed, which is fine. I was able to pair one of the fans using the DH and can control it completely on my phone, which is great. But I can’t seem to get the other fan to go into pairing mode. When I did it the first time only one went into pairing, which is the one that is correctly on my phone the the ST app. So how do I get the second fan to also be controlled via the app? Is it a pairing issue? Is this even possible? Perhaps if I physically disconnect the fan that was successfully paired (just disconnect the power), then try and force the second one into pairing?

Has anyone else had any experience with this?


(MarkTr) #507

Try turning the power (to one or both) off and back on and see if the second fan shows up in ST. They will time out of pairing mode, and if they haven’t connected to a network, flipping the switch to reset won’t work because there’s nothing to reset. Cycling power off and back on once will restart pairing.


(Michael Ward) #508

I have removed and re installed all 3 DH and all associated instances in St and Alexa. I have re installed and re discovered everything. The pic is what I’m currently running. I continue to have issues with voice commands through Alexa where when I say “turn on bedroom Fan high” it only turns the fan on low. None of the fan speed voice commands are working. The remote and ST app buttons work fine. I just cannot fix the voice controls. Please help


(Ryan) #509

Hi, what is the “remote and switch method”? I was able to pair this right away easily, but it somehow lost the connection and I have been trying to re-pair and reset the fan without success for the past couple of days.


(Ryan) #510

Just wanted to update, I was looking at the controller last night and saw that the zigbee antenna was somehow sheared off. This may explain the reason for not connecting in my case :frowning: Looks like a return is in my future.