[BETA v0515] Hampton Bay Zigbee Ceiling Fan/Light Controller

fan
dth_hvac

(Steve Jackson) #368

Thanks to everyone involved for all the work in putting this DTH together, it is great. I have it working in our bedroom using a https://www.amazon.com/Securifi-Peanut-Smart-Minute-Setup/dp/B00TC9NC82 as a Zigbee repeater and it seems to be holding a connection. It’s only been 24 hours so time will tell if the connection stays solid.

My question has to do to with the dimming function of the light and Google Home. I can control all of the fan functions using Google Home (though I had to rename Med to Medium and Med-Hi to Medium High in the Home app for it to work). I can also turn the light on/off from Google Home. What I can’t do is dim the light using Google Home. It says that device has not been added. I can dim the light from the ST app and the included RF remote, just not Google Home. I have the Fan kit #722-493 from Home Depot and not the replacement parts from KOF if that makes any difference. Any ideas?

Thank you.

UPDATE: It seems that when ST found my fan that it “garbaged up” the child app for the light. I still haven’t fixed it yet on this fan but I installed a second fan today and Google home is able to dim the light just fine. On the other hand, even though they are shared, Google Home doesn’t seem to want to control the speed of the second fan though. Go figure. :exploding_head:

UPDATE 2: Google Home sees the fan speeds on the 2nd fan now. I guess it just took some time for them to get picked up? IDK but at least it works now.


5 speed fan: what to do?
(Stephan H.) #369

You should have a device with “Light” suffix. Make sure that child device is also shared with Google Home. The voice command should then be something like “Set Bedroom Fan Light to 50”


(Steve Jackson) #370

Thank You for the quick response @stephack . I just double checked and the device is shared with Google Home. I am able to turn the light on/off using Google Home but when I try to set the dim percentage the Google Home says that “It looks like those lights haven’t been set-up yet.” I have no problem dimming other lights in the house so I know that I can do it using the Google Home.

I am using ver 0.2.170515a of the lighting child. It appears that all of the DTH code is ver 0.2.1750515 which I pulled directly in the IDE from dcoffing, KOF-CeilingFan, master

It’s not a deal breaker, I was just curious if it was something on my end or if other Google Home users were seeing the same thing and maybe had a solution. I didn’t see any reference to it in the thread but it’s easy to miss something in a thread this size.

Thank you,


(Stephan H.) #371

I know others with Ghome have this working. Unfortunately I use Alexa and I have migrated to Hubitat so I am unable to test on ST anymore. Hopefully someone with Goolge Home setup can help.

If I think of anything else I’ll let you know.


(Mathieu Gariepy) #372

Hi guys, complete newbie to ST i installed the fan control, i linked it to ST, i copied the code and created a device handler, now what? I dont know how to link the device handler to the device in IDE. I’m at a lost. Thanks for anyone than can help me and educate me.


(Greg) #373

Try this, on the devices page of the IDE


(Mathieu Gariepy) #374

ok did that but now it just has the fan on/off option no lights no other buttons, and when i actually click to turn on the fan it doesnt do anything.


(Mathieu Gariepy) #375

Ok got it now but it only worked for 5 minutes now the buttons do anything. I adjusted the speed to low and all it does is show the icon adjusting forever and nothing happens. Right now I turned it off with the remote and still shows the same that’s it’s on in high.


(Stephan H.) #376

Hit refresh. If that does not help you probably have the same issue pretty much everyone has. You will likely need to install a zigbee repeating outlet in the same room as your fan. Search through the posts above. It’s a reoccurring theme.


(Eric) #377

Help

Finally installed my controller. Fan works with hand remote and wall remote. Disconnected the switch, reconnected, and ST found it (though it says “Tiles Missing”, but when I click on that, the next screen says “Fan”)

I tried inputting the first code at the top of this page into ST

Here’s the page I’m at: graph-na04-useast2.api.smartthings.com/ide/app/saveFromCode

But I get this warning:

No signature of method: script_app_metadata_453aa887_6ec1_4c25_ba49_8dd136d1c030.metadata() is applicable for argument types: (script_app_metadata_453aa887_6ec1_4c25_ba49_8dd136d1c030$_run_closure1) values: [script_app_metadata_453aa887_6ec1_4c25_ba49_8dd136d1c030$_run_closure1@6e5d6a27] Possible solutions: getMetadata(), getState(), setState(java.lang.Object), metaClass(groovy.lang.Closure)

What am I doing wrong?

[EDIT] Since there’s three codes, does that mean I create 3 smartapps, and connect them all to the Fan controller?

[EDIT] Strange question: I wish the top Power switch would control the light instead of the fan. Can the controls be reversed in software? [EDIT] Just realized…that wire would be connected to the fan, so I guess not :frowning: )


(Mark) #378

These are device handlers, not smartapps. Install them in the device handler page of your IDE.


(Eric) #379

Cool…that worked. Thanks!

Can we do that per device? I thought it was only a global setting. Or do I have to uninstall the Alexa app from those particular devices in ST?


(Eric) #380

I use Alexa, not Google. Different settings.

As for Alexa, it shows all the Fan buttons as Lights. Anyway to change the Alexa icons, or is that a limitation?


(Eric) #381

Ok. Got two controllers working so far. Couple of questions.

The ST controller shows buttons for Fan High, Med-Hi, Medium, and Low, All these transfer over to Alexa as well. Do I have to keep all these levels in Alexa, each to be activated individually? When I was trying to turn the fan off, I realized I had to say, “Alexa, turn master fan high off”, which I wasn’t sure would work since it was on MEDIUM (It did).

Secondly, there’s also a standalone “Fan” button that turns the fan on and off. Is this one necessary? Just trying to cut down on the clutter.

Third, how do I dim the light? I tried percentages, but that didn’t work.

Fourth, all the Fan levels are listed as “lights” in Alexa. Is there no way to change the light icon to a fan? It’s not a biggie, but it would make it easier to differentiate in the DEVICES list.

Sorry for all the questions… Just wanna know what this thing can do… I’m very grateful for what you guys have done so far! :slight_smile:

[EDIT] Apparently the standalone “Fan” button is the master control that turns on both the fan and light.


(Steve Jackson) #382

Following…I couldn’t get the lights to dim using Google Home either but will dim with the app and the remote.

As for the Fan on/off switch that will turn on the fan with the last speed used. That switch will also turn off the fan regardless of the speed that it is on. I had to activate each fan speed in Google Home to make them all available for voice control.


(Eric) #383

Yeah, I have all the speeds set up, too. Tedious, but not unbearable… at least it works.

Except for the dimming. Not a huge deal, but my wife’s eyes have been getting more sensitive to bright light over the years, so that might be an issue.


(Steve Jackson) #384

I am going to try and figure out the dimming this week. I agree that it’s not a deal breaker but would be a nice feature to have. I’ll post if I come up with something. So far my fan has been rock solid. No drops. Hopefully, it will stay that way.

I have another Zigbee fan controller in a box that I purchase for the living room fan. I was waiting to make sure that the bedroom fan would stay on the network before I purchased a fan for the living room. Maybe I’ll try and get that fan done this week and see if the dimming issue occurs with that one too.

UPDATE: Dimming is an issue on my end. ST didn’t install the DTH right. Google Home can see and dim the light just fine with this DTH on my second fan.


(Eric) #385

Ok, just figured out dimming. There’s a separate, smaller switch on the hand and wall remote labeled O and D. The D stands for Dimming. If that is on when you press the power button, it turns on the dimming function. Good news, once the dimming function is turned on from the remote, it continues to work with ST, and percentages work with Alexa. Good times!


(Eric) #386

FWIW, I got two fans going (two more to go.) The lights in my living room fan weren’t turning on, and I was hoping it was my old Hampton Bay controller. Nope, lights didn’t work with the new Zigbee controller. Did some research…turns out ceiling fans with lights have a power limiter which prevents you from running 100w bulbs in a 60w fixture (and apparently it also messes with LED bulbs.) Did some Youtube research, turns out these limiters can go bad (We’ve been burning out light bulbs quite often in this fan), and you can remove the limiter and wire the bulbs directly. Since I only have candelabras in there, I decided to try it out and VOILA! I have lights again!

Also, I changed the FAN MEDIUM label on both fans to just FAN. That way, saying “TURN ON FAN” automatically defaults to medium, and more importantly, saying “TURN OFF FAN” easily turns it off without having to say, “TURN OFF FAN MEDIUM/FAN LOW/FAN HIGH”.

All in all, a day well spent. My wife will be very happy to have her fan lights working again. :smiley:


(MarkTr) #387

Did you also rename the existing “Fan” label?