SmartThings Community

[BETA v0515] Hampton Bay Zigbee Ceiling Fan/Light Controller

fan
dth_hvac

(Omari Bogle) #581

It is…most annoying!


(Cole Calistra) #582

Update: I bought a Wink hub and the Hampton Bay controller worked perfectly with all three fans I have. Paired, operate, run all 4 speeds, lights, etc. I even got Alexa working with it, but it has to be done through IFTTT for the fan controls. So I can definitely rule out any issues with the fan controller, or how I wired the controller into the fan, etc.

I’m new to all the Smart Home stuff, and I was surprised at how much more powerful SmartThings was compared with Wink. I’d still love to try and get ST to work with this controller and sell the Wink on eBay. My ideal would be to be able to do the “Goodbye” routine and have all the lights in my apt shut off including the fans, etc.


#583

I seem to be stuck from the start on how to detect my fan/remote. The Hampton bay/wink remote is not showing up on my app. I just purchased my first hub (v3) and downloaded app. In fact, the app isn’t detecting anything. I had to hand select from menu a new out of box smarthings water leak sensor. I don’t know if this is something to do with the fan/wink remote, the newer hub/app, or where to start. I can only seem to do things with the drop down menus in the app and scanning bar codes. Thanks!


#584

I don’t believe this DTH is supported on the new app yet. Have to download the classic app.


#585

I have now downloaded the classic app. It detects the WINK fan. Thanka for that tip! Can you please point me to what i need to “publish the dth” or the parent and 2 children, as you write. I am new to smartthings. The threads are long and I haven’t found the basics.


#586

I’ll do you one better, this is a write-up by @JDRoberts. If there’s a question about custom DTHs and code that isn’t answered here, then it doesn’t deserve an answer. :stuck_out_tongue:


#587

This is great…it seems to have worked to a degree…the Smarthings website is in this weird Twilight Zone stage where it shows the device handlers i have now published but says I have no devices when I come at it from the developer side, but if i click over to look at my “home” I can see the devices and then the device handlers disappear. From other threads, I am going to assume some sort of time lapse issue that will resolve for the moment and come back later. [UPDATE: I found a very bizarre worked around that fixed this. I re-published by starting from the “home” side of the Smartthings webpage that had my devices, and that worked. It seems as though 2 separate accounts were co-existing in the same webpage but not actually commucating…very odd. this is the old developer page, which may explain it].

However, as a true newbie who doesn’t do code at all, there is one thing I had to figure out for myself by a little trial and error that is not handled in the FAQ nor the instruction thread here: you have to copy the code starting at the “def” line. This apparently is known to everyone who gets this far. Not me. Perhaps useful to others as this becomes more mainstream?

Thank you for all the help!


(Lorne Cohen) #588

I just picked up 4 of these for all my upstairs fans.

Pairing and all other pitfalls from above were all addressed and taken care of with no issues.

I did purchase the Sylvania Zigbee Plug (-A) as I didn’t even think it would be an issue. It was garbage. Ordered up a Peanut and now all fans are responding perfectly.

Now to think of some good WebCore’s for them

Thank you for this


(Roy) #589

I bought two of these fan controllers from Home Depot and had them installed.
One is in a bedroom upstairs and the other is in a bedroom just across the hall.
The ST hub is downstairs almost directly beneath the fan (but a floor below).

The second controller was able to be reset and paired with little coaxing. The first fan controller was very difficult to get to reset in order to pair, but eventually it did.

I’m having issues where sometimes one fan controller will accept commands from ST and not the other or vice versa. It’s hard for me to believe it’s a distance issue because the ST hub is literally just one floor beneath – and also sometimes bedroom 2 (slightly further) works while bedroom 1 doesn’t.

Do I have faulty controllers? Are these controllers just really unreliable?


(Steve Jackson, USA, Shard 1) #590

Based on the description of your problem, you more than likely you need to add a repeater or two. The radios in these are really that bad. I have been told that the fan blades themselves will also affect the signal if the hub is a floor below.

I have 2 of these controllers. The one in my living room is about 10 feet from the hub and works well. The one in our bedroom is about 20 feet and a couple of walls away and uses a repeater, a peanut plug I bought off of Amazon for less than $20.


#591

I had a similar issue. My hub is literally less than 10 feet away from my fan but a floor away. And until I added a zigbee repeater FURTHER away from the hub than the fan is but on the other side of the fan, it kept losing connection. Now that I have a repeater on the opposite side it never loses connection. Used to have to reset it every 4th of 5th day to get it to connect. Haven’t had to reset it in weeks now. I also didn’t modify the fan cowl so the wifi antenna could stick out…that’s prolly why my signal is having issues too. But it’s working now, so I’m not going to question it.


(Greg) #592

I recently returned one of these to HD because I couldn’t get it to reset/pair - and largely due to the this thread determined I had a faulty unit. What is up with the production quality of these units that so many are faulty?

Also, is there one zigbee repeater people are favoring?

Thanks


(Dan) #593

I use the Lowes Iris 3210-L outlet, as it repeats both Zigbee and Z-Wave. It is a Centralite OEM device, which I have found to be very reliable over the years. Note: The on/off functionality is Zigbee. Z-Wave is just a repeater.


(Roy) #594

Which repeater did you get?


#595

I too got the Iris outlet. They were on sale at Lowes for $9.50 a few weeks ago. Upset that I only bought 2 but when I went back the next day the 15 others that were there were totally gone. :frowning:


#596

Hello everyone, has anyone ran into issues getting this into pairing mode? Have tried to reset it over 15 time now with no luck. I leave it off then after some time (one min +) I turn it on for 3 and off for 3, five times but the lights never blink and it never shows up in the smartthings app. The fan is closer then the other one I have so I hope is not a distance issue.

Thanks for the help.


#597

Mine don’t blink either but it still resets. Delete it from ST first and then reset it and it should reset. If you leave it in ST it resets and then repairs I think.

My two are very odd. One is only 5 feet away from the hub but the antenna is on the over side of the motor and I had to have a repeater to keep it paired with ST.


#598

Thanks I will give it another try. This is a brand new install too so maybe I do need an extender for this one. Maybe I’ll try moving the hub into the same room as the fan as a test.

Thanks again.


#599

I will need the extender to be able to put the Hub back where it was. moved it to the same room and it reset and was found by ST. Cannot wait for a z-wave one to be developed… Thanks again.


#600

There is also a wifi one made by Sonoff…the iFan02. But it requires some modification to work with some US fans. Up side…it only costs $15. Until I finally figured out why mine kept disconnecting I was considering it.