[BETA] Edge Drivers for Homeseer Devices

that fixed it…
i had to down load smartthings.msi tool from Releases · SmartThingsCommunity/smartthings-cli · GitHub
and then run from command prompt what you quoted…

1 Like


I just migrated one of my HS-WD200 to your driver to specifically test the individual LED colour control.

I found a couple problems that I would like to understand. Things have changed from the previous DTH and there are some things that don’t seem possible anymore.

First, I used to be able to switch from the “Normal Mode (Load)” to “Status Mode” from a scene, routine or SL. Now, the parameter is not exposed externally. That makes it impossible, for example, to display a special status temporarily, like and open door, and come back to the “Load display” once the door is closed. The way the Switch Operating Mode is built in the driver as it is now, is like if the dimmer should be used in a way or another definitely. Whether I think this mode should be dynamic, like display the load under normal circumstances, but switch to status to show something temporarily and come back to load after that is resolved.

Another problem I found is if you want to create a routine to activate or change the color of an LED, the main relay “has” to be activated or disactivated. I have so use cases where I would like to only alter the LEDs and not the light relay itself. That is not possible right now. I also tried in SL but as you mentionned ealier, I noticed many things are not working properly.

FYI, I am using version 2023-02-20 of the driver.


1 Like

Homeseer has released a manufacturer’s edge driver for that specific model which is out of beta and is supposed to have full functionality. They’ve only done a couple of models so far, so the community-created driver in this thread does have many more models, but is still in beta, and may not have quite as much functionality for some models. So you might want to give the other one a try and see how it works for you.

Also, there is a discussion in that thread of a bug in the app which is causing the turn on issue you reported.

[ST EDGE] [RELEASE] Homeseer Devices, manufacturer-provided edge drivers

I’ll give it a try.

Thanks for the quick response.

1 Like

@KrankyFranky @JDRoberts

I am somewhat optimistic that the release I have provide most recently is in parity with the “Official” capability, and thus the request to provide any feedback and/or performance issues which may exist.

From what I can see, I believe that this release has additional functionality both in terms of included device, but also in terms of how to interact with the LEDs.

With that being said, I am interested in potentially exploring some of the ideas that @KrankyFranky has mentioned.

One of the on-going debates is the use of a Device+Component vs. Parent Device + Child Devices.

Up until this point, I have been focused of extending this driver set into using the components (despite the limitations related to voice assistants for not using child devices).

One of the nuances of this approach, is that the driver “profile” definition is essentially static. A shift from Normal to Status requires a change in profiles to build out the components. One of the concepts I have considered exploring is to extend to additional “Operating Modes”. This could include the native modes of Normal/Status to something like:

  • Normal
  • Status (+ 7 LEDs)
  • Normal + Color Control?
  • Status + an All LED component?
  • TBD??

I have a rule in place today, which I have used for testing, and it Will turn 2 LEDs Red if a door is unlocked and Green if the door is locked. This is not dependent upon the load being “on” to control the individual LEDs, so I would be interested in more feedback here.

1 Like

So just to follow up on this, I have been able to test the official Homeseer driver. It’s behaving exactly like the previous one I had before from krlaframboise. I’m able to togle the LED mode from load to status from a routine or a scene. I haven’t tested with Smart Light.

So I can only say that this new driver works perfectly for my needs. I only migrated 1 dimmer so far, with 11 more to go, but I tested all the LED controls that I currently use and it’s working.

With regards to the main relay, I found another thread mentionning this limitation but apparently it is fixed now. If you don’t want to activate the main relay, you simply have to click on it to remove it from the action. The togle shows a radio button to activate or deactivate but apparently they are independent, not acting like a real toggle would.

@jshessen, your question about the profile. I think there should not be 2 different profiles. Just one that exposes all the LED all the time. You should have a look at how the official HS driver is implemented and you will see that every single LED is exposed all the time in the device screen. If you set an LED to go a certain color, I guess it will still send the command to the dimmer but I will only start showing on the dimmer itself once you togle the status mode on.

I hope my explanation is clear as it’s kind of difficult to explain without a screenshot which I can’t do at the moment.


@KrankyFranky – This is positive feedback, and I would always recommend the “Official” if it meets your needs. Glad it works for you and I would run to get the other 11 swapped over :wink:

One thing I will note is that the original profile separation, is that depending upon the firmware some functionality does not exist (extended with later firmware) however the status segmentation is certainly not anything more than the initial path.

I tried to enroll a fc200+ fan switch, fan didn’t completely enroll properly and locked up verifying key. Had to kill ST app. Add device doesn’t work properly.
Had same problem with 200 series switch four weeks ago or so. Can you please make the same corrections to the fan controller.

@RottenMutt I’ve sent you a PM/DM to help gather some logs.

I recently downloaded and installed the latest official HomeSeer edge driver. I also did a round of testing with my HSM200 multi-sensor, and I am happy to report that the driver capabilities are working as expected for my use cases.

Setting LED color, LUX/Illumination reporting, Motion Sensor, Motion clear, and Temperature reporting, all are working.

A big thank you to @jshessen @JDRoberts @krlaframboise and others for all your help to keep the community up and running on the new platform.

The latest homeseer driver is located here:
posted here:


I can not get mine to switch to this driver. It’s listed as EZ MultiPli on my app and uses the ZWave sensor from smartthings. I downloaded the driver from Homeseer to my hub but it won’t let me switch it. I figure my fingerprint is wrong so it won’t work. The ZWave sensor driver works except the color control. I can’t change the color it only comes on as white.
Any ideas how I can switch it to the Homeseer driver.

@Gavin things continue to move pretty quickly. Based upon the work in the HomeSeer channel, my recommendation is to use their drivers for all of the supported models. Neither the beta drivers mentioned in this thread, nor the HomeSeer Official drivers were tackling the EZ MultiPli fingerprints by default.

However, I can share that the SmartThingsCommunity/SmartThingsEdgeDrivers does have a matching profile for the EZ MultPli

I would recommend setting up the channel referenced in this post see if it meets your needs:

1 Like

HomeSeer driver channel

For WS-100 driver. Can you add mfg 0184 for hs/hd100 switch. I have three generations of the ws-100 switches.

zw:L type:1001 mfr:0184 prod:4447 model:3033 ver:5.15 zwv:4.24 lib:03 cc:5E,86,72,5A,85,59,73,25,27,70,2C,2B,5B,7A ccOut:5B


I have gone radio silent on this thread since the corporate drivers were released. With that being said, I did make a quick set of changes to add these fingerprints and push to prod. Hopefully it helps with the DragonTech manufactured devices.


Thank you. Your drivers are the only ones for the 100 series drivers.

1 Like

Happy to help where I can.

1 Like

Hi All,

I have a gen1 HS-FLS100+ that has lost all functionality within smartthings over the last couple of weeks. The device is now listed as a z-wave switch and only has on/off capability. No motion, lux displayed anymore. Is there a beta driver available that can be shared?

@aai92209 ,

I believe this is addressed in the manufacturer provided beta drivers located here:
Screenshot from 2023-07-19 14-24-28

Unfortunately that driver only supports the Gen2 model. I reached out to Homeseer and they confirmed the Gen1 model is no longer supported and referred me to the community for a beta driver.