BE469 Schlage Connect - lock/unlock not working

BE469 Schlage Connect with Alarm
hub v2, US customer Rev E
Firmware 000.029.00008
Rboy Lock User management “07.10.04”
Classic Smarthings App on android

So I have my lock installed and it was working now for about 2 years. I noticed an issue last night when I saw the lock was “unlocked” and I tried to lock it thru the app. It did not lock the door. Battery level shows 100% and the notifications work correctly. The status also shows correctly when we manually use the codes to lock and unlock. History shows correct.

I also tried to use the new smarthings app and it also did not work to lock/unlock the lock thru the app.

I also tried to z-wave network repair and it showed as repair finished but same result when trying to lock/unlock thru the app.

Any help on this?

I also installed the device handler A “future proof” Universal Enhanced Z-Wave Lock by @RBoy ? and setup the device with the new handler

I’m going to ask the obvious question, is there a buffering device within about 15ft of the lock? That’s a good way to cover your bases to start with since most mesh/timing issues can be resolved with this :slight_smile:

Apart from that other things to try:

  1. Check battery, on this model 60% is a good time replace it below which we start seeing trouble with lost packets/communication. Anything below 50% and it can suddenly shut off due to load voltage drops. Always helps just to test with new batteries.
  2. Try to power it down and power it back up
  3. If that doesn’t work maybe try to factory reset the lock, this mean you’ll need to exclude and pair it again with SmartThings. Since you’re getting notifications it’s unlikely you need to do this far but as a last option

Since everything else is working I’d wager a timing issue. Maybe try to reboot the hub and internet router if that’s causing latency related timeouts (unlikely but never hurts).

One good thing to check it the routing. Open the IDE, click on My Devices, click on your lock and see if the lock is connecting directly to the hub or through other devices? If it’s directly then I’d back to the first line. If there are other device, check if any of them are malfunctioning, maybe take them offline and do a network repair and see if that helps.

So no buffer so that might be a problem. I will look at adding one. I will also replace the batteries first. That might be a problem even though it shows as 100% on the app.