Basic ST Lighting

Hi All,

Brand new to ST – just got the V2 Hub last week. I wanted to start off as simply as possible so I could familiarize myself with how the system functions by merely installing some GE bulbs in various rooms of my house (these to be specific: Before setting these up into any sort of Routines, SmartApps, etc – I just wanted to ensure that these would actually work. Basic stuff – ON & OFF when I pressed the ON or OFF buttons next to each light in the iOS app. After that, I’d start messing around with getting them on SmartApp schedules w/trigger actions from sensors, etc…

Well, I used this little article to set them up ( - they paired immediately & worked great. I shut them all off (manually with the buttons next to each light in the app) when I went to bed, then woke up to none being responsive at all. I used one room specifically as a test (where I installed the light bulb into a ceiling fixture) - I deleted the light from ST, reset the bulb (the 3 seconds on/off 5 times in a row thingy), and it worked great again. Next morning, same thing. No responsiveness.

Any thoughts here? Again I wanted to start off as basic as possible as I’ve read that Routines & SmartApps can confuse things and that some users have issues ‘overriding’ these commands with wanting to simply turn things ON/OFF ‘manually’ via the buttons next to each light in the app. I hope this isn’t the case, or this system is really a much better concept than product…

And FYI:
My network is solid. I pay through the nose to Comcast for a ‘premium’ Wifi connection, and consistently get at least 40-50 mbps. Usually north of 65.
The lights aren’t ‘too far’ from my router/ST hub. Again, they work great upon initial install
Does ST ‘reset’ itself on some sort of schedule? Am I missing a setting in the hub? What could be causing this? Needless to say, if this simple execution is a tough job for ST, what’s the real value? This is the most rudimentary of processes that this should execute…

Thank you in advance…

This might be a known issue with the GE Link bulbs. If you were to pair them to a Wink hub, they would get a firmware update that SmartThings currenlty doesn’t support. I know @bamarayne has GE Links and he might be able to provide more insight on this.

Thanks for the input - would love to hear from anyone that has these, has experienced something similar & hopefully found out how to stabilize these things!

That’s really discouraging to read. I read in multiple posts that they were good to go… Just ordered 5 yesterday. Hope I don’t have to send them back

They do work at initial install, and seem to for a while afterward (I wasn’t hanging around checking them each hour or anything), but as mentioned when I tried to engage the lights the following morning (3 mornings in a row), they were unresponsive. Resetting the light that I tested each morning brings it back to its out-of-the-box state, but I doubt anyone is interested in that sort of maintenance…

I have about 6 GE Link Bulbs on my setup with no issues whatsoever. However, there are known issues with the bulbs losing connectivity after losing power. Smartthings does not officially support this device, but it does work.
Make sure you don’t manually turn off these lights (either with a switch or unplug).
I found that deleting and resetting the GE Link bulb fixes most issues.
First, remove the device from SmartThings, then reset the bulb by manually turning it off and on every 3 or so seconds until it gently dims and turns bright again. (Turn off… wait 3 seconds, turn on… wait 3 seconds, and repeat).
Re-add the bulb to SmartThings.
I have not had problems with any of my bulbs for months (I even moved some around the other day without issue).

EDIT: If you are searching for alternatives, look at the Cree connected or Osram lightify bulbs.

Very helpful input, thank you Brian. I’ll go ahead & remove/reset mine across the board (I bought 8 at once) & see if they maintain…just very strange that they’re fully operational for a while, then after time passes, they’re seemingly dead. This is why I initially asked if I was missing some sort of setting on the Hub that could be somehow disconnecting them, etc…because it’s not 1, it’s all of them.

Thanks again

Because it’s all of them it’s most likely an issue with your zigbee network connection to the bulbs. As Brian mentioned, there is a known issue with the GE links disconnecting themselves, but I’ve never seen or heard it happening so fast, consistent and widespread.

18 bulbs myself, with rare issues. Maybe one bulb a month needs a reset.

It could be interference with you or your neighbor’s wifi, so it might be good to check channels. Also take a look at this thread/post about power company meters that operate on zigbee and cause problems.

1 Like

Thanks, everyone, for the input. Interesting stuff. Well, since I’m not too deep with devices & configurations yet, I’m going to start from scratch & reset the Hub & Bulbs to their out-of-the-box state & see if it’s just one of those things where there was a snag in the setup. Not sure how that could be, but I have enough experience with these types of things whereby sometimes, IFM (illogical f’ing magic!) just makes things work…

I’m also going to buy 1 ‘supported’ bulb & see if it works as these GE Links should.

Will report back on any other oddities – or hopefully, success!

1 Like

One more quick tip. It can be a good idea to pair the bulbs close to the hub, then move them to their final location. Lots of info goes back and forth during the pair process, so being close to the hub reduces the risk of messages being missed. Might help some.

Good luck!

1 Like

So, you’re saying (for example) I should pair all of the bulbs in a lamp sitting next to the hub + router 1 after the other, then afterward remove & screw them in to their actual locations?

1 Like

That’s what I usually do when I get a new bulb. I have a lamp about 5 feet from the hub area that I use. More work when you have so many, but it might be good to do the first couple that way at least. It might help you troubleshoot too if the bulbs paired close continue working and the others drop-off.

Sidenote: Zigbee devices are pretty good at updating their routing tables, but to do a “heal” you would unplug the hub for 10-15 minutes, which would allow the bulbs to discover their neighbors.


Great tip - I’ll do that. Thank you!

This sort of issue with the GEs tends to be very intermittent, I’ve got 10 GE’s in my setup and I’ve needed to remove and re-add 2 of them, generally it happens once, soon after initial install, and have been rock solid since.

Mine came in 2 days ago and I did this. No issues yet. 3/6 installed