Automations suddently stopped working


I have configured a Meross 3-way wall switch to automatically turn on my TPLink LED strips and TPLink wall socket.

It works in this way: 3 automations each of which detects if the one of the switch of wall switch is turned on or off and automatically turns on or off the strips/wall socket.

It worked until a couple of days ago. Now it doesn’t automatically start the automation if I press the wall switch manually (with my finger) but it does when I enable the trigger from SmartThins app.

Could you please help with this problem?

1 Like

I also tried removing and recreating routine but it didn’t work.

Let’s back up… when you press the button on the switch, does the status properly get reflected in the app… i.e. if you turn it on at the switch… does it show on in the app?

If not, try going to Menu > Settings > Linked Services and click on Meross then click Done on the screen. No need to tap Edit at any point since you will not be deleting. After Done, check if the status gets updated properly in the app. If it does, your Routines should start working.


Every one of my Meross devices (three Wi-Fi outlets and an air purifier) is not updating SmartThings if I initiate from the device or the Meross app. Everything works as expected when initiating from SmartThings. This started about a week ago and I thought it may be related to the big SmartThings deletion screw-up. The Meross devices were actually among the few for me that ST did not blast away.

I have refreshed the link already. I’ve also tried deleting the devices in ST and discovering again. Neither has fixed it. My next step when I have time is to delete the devices in ST again, kill the link then set up again. Not ideal of course and still no guarantee it’ll work.

Yes, pressing the physical switch reflects in the app.

I thought the same thing, but it looks like the routines are still working on cloud and not locally (can’t see the house icon next to them).

Would a smart hub fix this issue?

Not at this time. It may after full matter support is operational, but we aren’t there yet.

That’s because the current integration is cloud to cloud and does not use edge drivers. So it wasn’t part of the “cleanup“ that went awry.

Yeah I get that. That comment of mine was sort of throwaway.

Anyway, it looks like my Meross issue is different from the OPs so apologies for the unintended hijack.

1 Like

in the US or outside of US?

I’m in Europe

I’m having issues with all of my Meross devices too. I’ve had an automation that when my garage doors open (controlled by Meross) to turn on the notification LED on my Inovelli switches. This hasn’t been happening. I deleted the cloud 2 cloud link. Set up the automation again and it worked for about 24 hours and now it is down again. It is like the two clouds are not talking.


I sent in error report to Smartthings via the app. Hopefully this will fix the issue.


That worked for me for 24 hours or so and then back to not updating.

1 Like

Thanks for letting me know.

what region are you in?

USA-Florida to be exact

Same here. I use a Meross smartplug to bridge an automation from HomeKit → HomeBridge → Meross → Smartthings. Worked fine ever since I set it up, but stopped working reliably within the last week or so. I can see events trigger in Homebridge to flip the plug’s switches on/off, but looking in the Smartthings IDE I only see some events occur for the same switch (and none since yesterday, coinciding with re-setting the Meross integration in SmartThings over the weekend).

I’ve submitted an Error Report with logs to Samsung. The error is quite simple. It seems like the SmartThings cloud is not accepting information from Meross, but if the SmartThings cloud asks Meross for information, everything is working fine.

1 Like

Similar issue here. If I turn on/off my Meross devices in iOS Home app, physically at the switch or in the Meross app, the status does not update automatically in the SmartThings app. If I go to the device in ST app and pull/swipe down, the status will update. If the device is controlled via Alexa, the device’s status DOES update automatically in ST.

If I go to Linked Services and click Done, it does not fix it. If I remove and re-add it again, it’ll work but only for a day or so.

1 Like