$5 off NEW Meross outdoor WiFi double socket plug that works with both HomeKit and SmartThings

$29.99 with the coupon. This is the new model MSS620 which also works with HomeKit. Each socket can be controlled independently, which helps make the price look better.

These are also ETL certified, unusual for a Wi-Fi plug that isn’t HomeKit compatible.

I have two of the original model which work with smartthings and echo and really like them. I have one of the new ones on order.

As with the older model, note that these are designed to be placed outdoors pointing down so that water doesn’t get into them.

If you don’t need HomeKit, the original model, which looks identical, should cost about $10 less:

1 Like

this weekend, the coupon is $6 off for a total price of $28.99

so thanks @JDRoberts - I ordered one to replace my iDevices plug that failed this weekend

1 Like

How does it work with SmartThings?

Haven’t tested the specific model yet, but the previous model worked fine. It shows up as three devices, the parent device and then one for each individual socket. There’s an official integration in the new V3 app from Meross. :sunglasses:

I don’t think it will work in the classic app, though, most of the new Wi-Fi integrations don’t.

Thanks. That’s what was confusing me cuz it made no mention of Zigbee or Zwave and I haven’t integrated a WiFi only device into ST yet.

1 Like

I’ll let everyone know on wednesday if they work in the classic app after I add it in the new app :slight_smile:

1 Like

OK, I received my new meross outdoor switch and I must admit I am having a heck of time trying to get it connected. Still working on it!

This is a nightmare… plain and simple! You are forced to add it to homekit first which took 3 attempts before it connected. Then you add it to the Meross app which took another few minutes before it would add it. Then I went into the new ST app and tried connecting to the meross integration and that was not fun! When you click on Login - nothing happens… nada…nothing…no indication of anything happening, it just sits there. But I found if I click Done on the keyboard and then click login, it starts the connection. Then you are prompted to authorize your devices. I click and it finishes. I go to the dashboard and no devices are shown. I go to devices and there are none there either. I open the Classic app and the devices show there. 3 devices for a two outlet switch - one switch and two outlets. The switch and one outlet are turned on but I can not turn them off. Nor can I turn on the outlet that is off.

Homekit shows one device which you can open to see two switches. Ugh! I would prefer there be two devices - one for each switch like the idevices outlet did before it died. I can control the switches individually from Homekit. Just discovered Homekit allows me to separate the two outlets - so figured that out.

So, as it stands - I don’t believe I would recommend anyone purchase this device at this time since I can not manage it from ST. But I will keep playing with it.

Update - removed the integration and added it back. Devices still not showing in the new app. But they appear and I can manage them in the Classic app now… Some progress. There must be a delayed callback with the meross integration. If I turn them on/off in the meross app, the status does not update in the Classic app.

2 Likes

Multiple people reporting that the Meross integration is taking up to a day to show new devices even for the non-HomeKit versions. So that may be what you’ve run into on that point.

Follow up on my story from above. Not sure what is going on. I added the meross outdoor plug yesterday but it still has not shown up in the new app. It shows in the Classic app but the status in the Classic app does not update if changed in the meross app.

Now I discovered all my kasa outdoor plugs that were added in the new app weeks ago, have disappeared from both the new app and the Classic app.

sigh

I have contacted support from all three companies to try and determine where the issue is originating.

1 Like

OK, sorry for stealing this thread. It appears I am experiencing an issue from the latest version of the new app that was released 6 days ago. I have lost all integrations that were initiated in the new app (for me that is kasa and meross devices). Everything displays and works in the Classic app. I have contacted all three companies and been asked to perform a few hundred tasks trying to figure this out. Everything from removing/reinstalling ST app, removing devices/integrations, reset this and reset that, send in logs, send in screenshots of devices showing in the Classic and not showing in the new app.

2 Likes

OK, I am conflicted on how I feel about his device. So I will just offer some observations.

First set up was slightly off. I opened the meross app and started the process to add it. I use iOS devices. In the meross app, I clicked add a product and selected the meross outdoor smart switch. It presented me with instructions to open iOS settings and connect to the wifi of the device. I go into settings but the meross device is not listed in the wifi list but I do see it listed waiting to be connected it as a Homekit device. No problem, I go back to the meross app to look at the instructions again. Yep, I read the instructions correctly. Go back to settings but still the meross device is not listed as an available wifi device. No problem,I’ll try to add it as a Homekit device. I start that process and scan the code. A minute later I am informed the device failed to connect. No problem, I’ll restart the meross device. Go back into settings. The device still does not list as wifi but it does prompt me to add as a Homekit device. It fails to connect again. Ok, I unplug the meross device again, plug it back in. Start again with the meross app and read the instructions yet again. Please note: I have been adding devices for many years so know the process, not like I have never done this. Go back to settings and try to add as Homekit device for third time and this time it works. Check the meross app and the device shows there. So first observation is the meross installation guide should be updated.

I go into the new ST app to add the meross integration. I had read the installion guide in the meross app. Note: the screenshots they provided did not match up exactly with what I saw in ST when authenticating. Finish setting up and notice no meross device in the New ST app. Delete the integration and try installing again. No device in the new ST app. So I figured it could be one of those wait and see if it shows up the next day. (It didn’t). I check IDE and the Classic app and the device is in both of those. So, there is an issue currently with the new app (also discovered later that all my kasa devices are not showing in the new app but do in the Classic and IDE). So I can’t blame meross for this.

Ok, now where I have the conflicts. If I open the meross app and manage the device (turn on/off), it does reflect the status in Homekit/ST (sometimes quickly, sometimes with a delay up to a minute). Managing the device from Homekit/ST works and a majority of the time is reflected in the meross app but not all the time. Now the part I hate, controlling the device in Homekit/ST does not seem to transfer to Homekit/ST. If manage the device in Homekit, it shows in meross but not ST. If I manage the device in ST, it is not changed in Homekit. Makes no sense because the meross app reflects the change (most of the time but not all the time).

I know this is a new product and I am hoping it is something that will be resolved with future updates.

Thanks for this. I was going to get one of these but it doesn’t seem worth it. Too much frustration.

Just to note: it has a 5 star rating from 12 users on Amazon.

I want it to work out because I want the Homekit and ST integrations.

1 Like

FWIW, I have the previous WiFi only version and it has been super solid for 2 years outside in the elements and the integration into ST has been spot on. Wish I had some experience with the new model but I’m also on Android so I’ve never used homekit. Wish you all of the best and hope you can get it straight!

1 Like

good news! looks like ST resolved my issue with Kasa and Meross devices not showing in the new app. They’re back! I removed the devices tonight, reinstalled and they are showing again. And yes, I deleted and tried many, many times over the past week. At last count, I think I had reached 8 attempts by deleting/reinstalling :slight_smile:

1 Like

© 2019 SmartThings, Inc. All Rights Reserved. Terms of Use | Privacy Policy

SmartThings; SmartApps®; Physical Graph; Hello, Home; and Hello, Smart Home are all trademarks of the SmartThings, Inc.