Arlo Pro not detecting motion or recording video when turned on from SmartThings routine

Good evening. I’m writing in regards to a defect that’s been going on for over six months now. I was going to write a very long defect write-up, but starting simple below and hopefully Arlo and/or SmartThings can run a debug to see what is going on. I can provide more detail as well.

I have my Arlo Pro cameras connected in SmartThings
I simply turn Arlo Pro cameras ON or OFF based on SmartThings routines
I only use SmartThings to turn the cameras on or off based on two SmartThings routines

Routine 1

  • Whenever one of us arrives home (based on SmartThings phone location), SmartThings routine runs to disarm and turn Arlo cameras OFF
  • Whenever both of us leave home (based on SmartThings phone location), SmartThings routine runs to arm and turn Arlo cameras ON

Routine 2

  • At 11pm at night, SmartThings routine runs to arm and turn Arlo cameras ON
  • At 6am, SmartThings routine runs to disarm and turn Arlo cameras OFF

Arlo Pros always stay in ARMED mode (do not do ST mode in Arlo). Therefore if cameras are on, they should detect motion and record video. If cameras are off, they obviously they’re not detecting motion or recording video

This worked fine for a few years, but then after a few firmware updates (I believe Arlo), it has stopped working correctly.

Current Defect

In either routine mentioned above, when the cameras are turned OFF from the SmartThings routine, they turn OFF as desired. But when the are turned ON from a SmartThings routine, the cameras DO turn on (I can see that in the Arlo app), but only one of seven cameras actually detects motion and records. I’ve checked all Arlo settings and all looks fine. This is a scenario that should actually never happen (Arlo cameras are ON, armed, but not detecting motion or recording video).

Attempts to Fix

I’ve tried about everything, and have tested this extensively. Deleted routines, removed Arlo from SmartThings, re-added, have taken batteries out, reset, etc. The only thing I haven’t tried is nuking Arlo back to factory settings. Have been in ST IDE as well and checked everything. Both Arlo and SmartThings are updated to latest firmware and software versions.

What DOES temporarily work is if I do a reboot of Arlo. So then all motion/recording works. But as soon as one of those routines from SmartThings triggers Arlo cameras ON, then it gets back in that cycle of not detecting motion or recording (even though they’re ON and armed).

Would LOVE some help on this, it’s super frustrating, and basically makes the cameras useless if they can’t detect or record.

Note: I do NOT want to use Arlo’s geolocation in this case, because the camera is always ON killing battery life.


Arlo firmware

Arlo hardware VMB4000r3

Cameras firmware

Six cameras have H8 hardware, one has H11 hardware

Arlo app 2.12.3 (1927)

SmartThings hub firmware 000.028.00012

Are you sure that you’re a Arlo mode isn’t automatically changing to disarmed? Because I had that problem. I found that integrating Arlo with Smartthings for some reason automatically changed the Arlo mode to disarmed.

I too had the ‘disarmed’ bug when SmartThings integration would randomly change the Arlo Base Station to ‘disarmed’. However, I found a workaround that seems to make Arlo stay in the mode I select on the Arlo website. What I did was log into the Arlo website and changed the Base Station from ‘disarmed’ which the SmartThings integration randomly sets it to, to ‘Armed’ mode. I then power cycled my Arlo Base Station. I guess I could have just rebooted it, but power cycling it was what I did. Anyway, now the Arlo Base Station stays in ‘Armed’ mode and the ‘disarmed’ bug is gone. That is until I reset or change the Arlo connected service again in SmartThings then I’ll have to do it all over again.

Update: I am now able to use the Arlo app to set the base station armed mode instead of the Arlo website before I power cycle the base station to get it to stick.

Thanks. Unfortunately not the “unarmed” bug. Always stays in Armed in Arlo. And oddly, 2 out of 7 cameras work correctly. All settings the same. I do t have smartthings doing anything but turning on/off cameras (don’t mess with modes because that was finicky years before.

Another update…I thought I’d go ahead and factory reset Arlo just to start completely over, assuming that would fix it (unfortunately didn’t). Took these steps…
1 - Removed Arlo from SmartThings routines
2 - Removed wife in Arlo access
3 - Removed Arlo cameras from SmartThings
4 - Removed Arlo hub from SmartThings
5 - Removed batteries from cameras (about 10 minutes)
6 - Factory reset Arlo hub
7 - Set up each camera one by one
8 - Added wife back to Arlo access
9 - Added Arlo to SmartThings
10 - Added Arlo back to routines
11 - Tested routines, still same issue (turns on cameras, but only 2 actually defect motion and record, even though they’re ON and definitely in ARMED mode in Arlo

One thing that I found odd was when adding the cameras back to Arlo individually (step 7 above), after finding a camera and asking me to name it, it detected motion in my hand and sent the push notification with the old camera name. In theory, after a factory reset, you would think it wouldn’t know what the name of the camera was (so leads me to believe the cameras are still holding on to some setting).

Very frustrating to do a full factory reset of base and find out cameras are holding onto settings.

1 Like