Arlo Cameras Infecting Routines


(Shane) #1

Arlo cameras been working great only as a switch on or off, not total integration but I am okay with that for months. Was told today the reason my routines stopped working is Arlo cameras are effecting them and other devices in those routines.
Any ideas on how to turn them on and off in sequence with routines maybe utilizing iftt.
They say they are working on it that I am not the only one.


Unexpected Error in Routine when turning on multiple Arlo cameras
Issue with Arlo
Unexpected Error in Routine when turning on multiple Arlo cameras
(Shane Schwarzman) #2

I’m using Core to turn these on and off based on mode change currently. That’s good to know the failure isn’t just me.


(Shane) #3

How long have you been using Core to do this. Is it still reliable? How could I do that?


(Brad) #4

Please contact support so they can notify you when this issue is resolved. A workaround in the meantime is to remove Arlo from automations which turn them on/off.


(S Çağlar Onur) #5

Same happening here without core, created a support ticket already. Following snippet is what log shows when I trigger the automation manually.

f6a36bc2-9655-4afa-bc10-e898155d3f2d 12:25:00 AM: error groovy.lang.MissingMethodException: No signature of method: physicalgraph.device.CommandService.executeAction() is applicable for argument types: (physicalgraph.device.cache.DeviceDTO, java.util.LinkedHashMap) values: [Front Door Cam, [status:200, data:null, …]]
Possible solutions: executeAction(physicalgraph.device.IDevice, java.lang.String), executeAction(physicalgraph.device.IDevice, java.util.List), executeAction(physicalgraph.device.IDevice, physicalgraph.device.HubAction), executeAction(physicalgraph.device.IDevice, physicalgraph.device.HubMultiAction), executeAction(physicalgraph.device.IDevice, physicalgraph.device.ParallelAction), executeAction(physicalgraph.device.IDevice, physicalgraph.device.RestAction) @ line 562
f6a36bc2-9655-4afa-bc10-e898155d3f2d 12:24:58 AM: trace prefix():
f6a36bc2-9655-4afa-bc10-e898155d3f2d 12:24:58 AM: info HH execute(true, null, null), newMode: Night


(S Çağlar Onur) #6

I also just realized my cams were off while I was away from the house because of this issue. This is a major problem because lots of people use automations (and presence modes) to toggle their cams :disappointed:

IMHO the other major problem is SmartThings app itself. It doesn’t show any errors or warnings etc. even though triggered routines didn’t able to complete their runs successfully.

This is really disheartening…


(Shane Schwarzman) #8

I just setup Core yesterday to fix the issue. My core rule turns the cameras on and off based on the mode.


(Shane) #9

I like that maybe thats what they will have to do. I just need them for night, and away. I use to use the motion sensors as triggers for somethings and open close triggers to turn them on but I would be happy to just turn on and off with modes and rely on Arlo notifications.


(Todd Wackford) #10

Cause of issue has been found and the fix is in review. Deployment should be this week.


(Todd Wackford) #11

Early present.
Fix is rolling out today. Enjoy! :slight_smile:


(Shane) #12

Will they still be contacting us? Is there something we need to do on our end? Can we put them back into the routines right now?


(Brad) #13

You should still get a follow-up but the issue is fixed and you can put the camera(s) back in your Routines/SmartApps.


#14

Brad - I am still having this issue with Arlo screwing up the rest of my routines. Was this actually fixed or still an issue?


Routines not running
(Brad) #15

The issue that this thread originally reference was resolved but a new issue has occurred in the past few weeks. As discussed here, Routines not running, we are working to address the current Arlo/Routine failures. Please contact support so we can capture the data point and follow up with you via email once the issue is resolved.


(Hassan) #16

Also posted the following at Routines not running and Unexpected Error in Routine when turning on multiple Arlo cameras

I got a response from support that they do not have an ETA on when this issue will be fixed:

Currently, we are suggesting users create duplicate Routines and placing only 2 Arlo Cameras in each Routine.

You can also try using Smart Lights to trigger based off of a Mode Change.

I tried the Smart Lights suggestion, which appears to have resolved the problem.


(Shane) #17

I have been using the smart lighting app to turn them on and off with modes since I started noticing the second issues stated in this thread and it is work fine for about 2 months.


(Shane) #18

Nope it’s back today I noticed cameras not responding to the lighting app. On with modes away home and night.
Anyone else experiencing this?


(Robert K) #19

As mentioned in today’s update, I was given the “Re-Authorize Connection to Arlo” prompt in the app. My rules / routines for when to turn off/on cameras are working again! Hope its back to normal for others, this was frustrating!

https://status.smartthings.com/