Arizona and time based automations

I have recently migrated from Wink to SmartThings. I am using Automations in the newer SmartThings App and since the time change (for the majority of the US but not Arizona), my time based automations are occurring 1 hour earlier.
For example, prior to March 14th I had outside lights turning off at 10:30pm, now they are turning off at 9:30pm even though it still shows me as set to occur at 10:30pm in Automations. I’m guessing this is a simple fix somewhere. Thanks for any advice.

Have you checked your location setup to ensure it has you in the correct timezone?

In the SmartThings App “Get your location from this phone” is turned on.
At, Time Zone is set as Arizona/Phoenix

Go into the app, click the 3 dashes (burger icon), click the cog and the your name under Samsung account and you should see home. Check thats setup correctly as well.

There is also a concept of your phone’s time zone when the Automation was created. We had a gentleman contact support recently having troubles with Automations he created while traveling, as an example. The Hub’s timezone is not considered when creating or executing the Automations (for now while things are still mostly cloud-based).

Your phone’s reported time and timezone get utilized to create the Automation → Cloud Service conversion to UTC → Automation exists in the cloud in the UTC equivalent of the time your phone originally reported. As UTC is not subject to DST, this should always be the same as far as the cloud service is concerned, but will change as your region does (or does not) experience DST.

Eek. I am rather hoping that it is possible for the legacy and new environments to have a different idea of the timezone. If your ST Location is working on MDT instead of MST it would make sense, but the IDE certainly seems to be correct (or isn’t reporting what it seems to be). You do probably want to use ‘Manage Location’ in the app to make sure your geolocation is set up sensibly.

Otherwise, despite doing weird things like setting Automations using the phone’s current timezone instead of the Location’s timezone, ST should get the sums right.

Thats a nightmare scenario!! That needs sorting rather soon. Why would you create it that way? The hub never moves and has a fixed timezone, I could create an automation anywhere at anytime that isn’t relevant to my home state.

Mikeyf, I follow you up until seeing “home”. When I click on the cog, under Samsung account I see my email address. I can click on that section (right arrow) and then it says “Account” and it lists my email address. Below that I have the option to “Sign out”.
After clicking on the cog, I see “SmartThings Settings” below that it has Samsung Account, Notifications, Widget, Get your location from this phone, Get Suggestions, Linked Services, Ask to add new devices, etc. I don’t see “Home” here either. Any other ideas?

I created this automation while at home and it was working fine until the rest of the country went onto Daylight Savings Time. I did happen to be in Colorado on that weekend with my phone but even once I returned home, it has been happening an hour early (lines up as if AZ was on DST).

On the Android app this is found in the three vertical dot menu on the app home screen/dashboard. Not sure if it looks the same on iOS.

Neither did it have any relation to your problem. I discovered, by chance, that in IDE I have two smartthings locations created that correspond to the same geographic location, different floors. At each location it had very different sunrise and sunset times for the same coordinates.
In the end, I discovered that the difference between the two locations is that the correct time has the Smart ligthing app installed and the one with the wrong time does not have that app installed. This app includes the connection to the weather station.
I installed the app in the location that had the wrong sunrise and sunset time and in the next synchronization with weather station it was fixed and the two locations already have it right