Aqara Contact sensor

I’ve a Aqara contact sensor which is stuck on closed. I’m using the YG Edge driver for the sensor. The sensor is near my hub and used to work normally.

I’ve tried to delete and reconnect the device and changed to another driver. The problem stays the same.

I’ve another aqara contact sensor which is just working fine.
Log from the one which is not working.

The device is also not responding to a get request.

Device “Voordeur” is not working.


Ik vermoed dat ik in het Nederlands kan antwoorden… :wink:
But I’ll stick to English as it is a international community!

My guess would be that the sensor is just broken. In the sensor is a little strip that get’s pulled when the magnet is close enough and then it says closed. When you open the door the contact should close, but if the strip is broken it won’t.
Try tapping it a bit with the door open, maybe it’s just stuck?

Roy gave me some tips but the problem is still there. The contact sensor stays closed. When I keep the door for a amount of time open, it changes to open. After that, de sensor respons as how it should be. Open/close changes direct in the app. When the door is closed for a amount of time, the problem just comes back and the sensor stays closed…

It also updates states

What could be te problem?

Have you tried a different magnet segment ?
What about moving it away from current location?
Ignoring the battery settings have you tried swapping battery?

Thanks for the advice, I’ll try this.

I didn’t try another magnet but replaced it and also deleted the device and add it again.

When I removed the battery, the device just stayed online. Even after refreshing and changing driver.

The device worked right for a moment. Open and Closing. But right now, on the old location. It takes like 15 seconds to change it to open but closed is like instant…

The current location is really close to my hub.