App shows "Turning on" and "Turning Off" way after device has turned on or off

This happens with both the new app and the classic app. I have tried resetting the V2 hub and even deleting the device and re-pairing it (a Leviton Z-wave wall switch).
I have another identical wall switch 8 foot and away and the app always syncs immediately with the device status.

Interestingly, my Smartthings button and Amazon Echo immediately turn the device on/off as expected.
After a longggggg delay, the app finally show the correct status.

Does anyone have a clue why this delay occurs. The problem seems to disappear for days or weeks then crops up again.

Have you tried running the z-wave repair to see if it has any effect?

1 Like

Thanks –
Yes I did try that and it did not help. I think this has occurred on other devices in the past.
BTW I have six Z-wave dimmers (2 wall switches) and one Z-wave plug and two zigbee plugs.

Edit: I have a Samsung S8 phone and both Smartthings apps are setup as unmonitored so they can use as much power as needed and won’t sleep.

I think I found a solution.
I noticed that in the Groovy IDE that the manufacturer and MSR did not appear unlike the other identical dimmer.
So I excluded the device and cut power at the circuit breaker panel.
I restored power and re-discovered the device.

Now the MSR and Manufacturer info appear as:
MSR: 001D-3201-0001
manufacturer: Leviton
and the “Raw description” shows as:
zw:L type:1101 mfr:001D prod:3201 model:0001 ver:1.17 zwv:4.33 lib:03 cc:5E,85,59,86,72,70,5A,73,26,20,27,2C,2B,7A ccOut:82 role:05 ff:8600 ui:8600

The version in this device shows as 1.17 and networkSecurityLevel: ZWAVE_LEGACY_NON_SECURE
The other(older) dimmer shows as 1.13 and NO networkSecurityLevel specified.

At least, now it behaves as it should.
What a pain in the a**!

Found an article about Leviton firmware issues.

Apparently Smartthings does support OTA updates to Z-Wave device firmware.

That is a serious issue in my mind!

I opened a support ticket asking for the OTA firmware updates for Z-wave capability to be supported.

I contacted Levition support about connectivity issues with their Z-wave devices since apparently firmware version 1.2 addresses the problem and I have six devices that could benefit from a firmware upgrade. I was issued a ticket number by level 2 support and await their response.

I looked into the Homeseer Z-Flash Z-Wave Firmware Update Kit but there is some question if my two wall switches use the firmware they include in their kit. They told me to contact Levition to find out.