APP Android version 1.7.85.25 issues

@nayelyz,
I have installed the new Android version 1.7.85.25 and when entering a negative values in an automation condition, which admits negative values, the app crashes and goes back

Someone else happens?

video:

Hi! :smiley:
Are you using a custom capability? Can you provide the ID, please?

Nothing capability with negative values works and it worked perfectly.

I realized when creating a new one and when giving the error I thought that I had created it wrong and after a lot of changing, I realized that none of the ones that worked a long time ago did not work

legendabsolute60149.levelSteps

Hi, @SamsungZell. Have you heard of issues setting negative values in the ST app?
This is in the part of Routines > Custom > IF

@nayelyz,

I tried in other phone with version 1.7.84.21 and I can write negative values

I still don’t get the update, so I have that version. Either way, I already saved the evidence in case it gets lost in the new one.

2 Likes

I have another minor issue. This new Android version of the SmartThings app added audible ‘tick’ sounds when I tap the device’s control to turn the device On/Off in the app, and I don’t see anywhere in the app to disable these ‘tick’ sounds as the Tap View, Tap Sound toggle is Off. There should be a setting to disable these audible ‘tick’ sounds because I don’t want to annoy others around me when I’m using the SmartThings app to control my smart home devices.

4 Likes

This couldnt be put on an elongated tile ? Or give the user the option of a tile size !!! I mean that is alot of screen real estate just for a device, it no longer fits where i want it on the (favorites) should be Home page…‘sigh’

Hi @nayelyz,

I have observed another problem in the new version of the android app.

The buttons that previously had many more actions on each button than those that the device supported now with the new version of the app only the button and the status field appear and no action for any button.

Previous app version:

New app version:

Ok, so, the team is aware of this issue and they have been able to reproduce it so, they will report it accordingly.

Ok, the team confirmed there’s a sound for those actions but the option of Tap View, Tap Sound is not related to it. That setting is to enable the tap view and sound features which is where you can tap your phone up against your TV or soundbar and it will start casting the video/audio to the device.

Does your mobile phone have active the “touch sound” option? I just checked and when I deactivate mine, I can no longer hear it in the ST app.

This is a feature request, I will create a report for that but remember it can take a while to be reviewed and implemented (if it’s accepted). It’ll depend on the team’s workload.

Ok, we’ll try to replicate this one.

In Android settings on my S8+ (v9) Touch Sounds and on my Tab S6 (v12) Touch Interactions is toggled to Off/Disabled, but I hear the ‘Tick’ sounds. I toggled the setting On/Off, but still hear the ‘Tick’ sounds in this new SmartThings app on both devices. I rebooted both devices and I still hear the ‘Tick’ sounds.

On my Tab A7 Lite (v11) however, the Touch Interactions Android setting does work to Enable/Disable the ‘Tick’ sounds in this new SmartThings app.

1 Like

Was this happening on all buttons previously? I only have one type of device displaying buttons at the moment and it is working correctly.

‘Touch Interactions’ does not affect this unacceptable sound on my Samsung phone either (Android 11/OneUI 3.1).

However, it when in ‘Do Not Disturb’ mode it is affected by the ‘Touch Sounds’ exemption.

Update: ‘Touch Sounds’ is not respected on a Nokia.

1 Like

I only have the fibaro key fob with 6 buttons, but it happened to other users in other models as well.

I don’t know now in other models if the same thing happens or it has been fixed

1 Like

I am envious that the click noise for the buttons is a significant issue for the Android folks. Us iOS folks wait, and wait, and wait, sometimes up to 30 seconds, for the app to warm up to allow device control. Not to mention the constant re-ordering of rooms, missing history, and general quirky behavior.

1 Like

That isn’t just an iOS thing, it happens on Android too and it isn’t just sometimes 30 seconds, it is more often than not. It only really irritates me because there isn’t any useful feedback on its progress so you have to work out when it is ready.

I don’t get the re-ordering of rooms (though having a Samsung probably helps), but missing history has been a thing for years, that and the fact that even if the history is there you don’t get to read it because the page refreshes.

If the iOS version gets the big change that the Android app just did you are going to love it. It is so big that they announced it in the Play Store. Yes, you can now change the order your Locations are displayed. OK, in the process they removed all the information being displayed in the Location tiles, and there isn’t the slightest hint in the UI that the new tiles can be moved, but, never mind, the locations can be sorted.

For those that are unsure, yes that is irony.

They seemed pretty excited about an improvement in the handling of Location invitations too, and there was something about QR codes. There are very few interactions that can be improved by the use of QR codes, and plenty that can be improved by not using them.

2 Likes

I can’t understand why they refuse to acknowledge the performance issues in the app, yet continue to add nonsense features as if they are meaningful?

My use case is so simple… I want to quickly open the app to turn a light, or series of lights, on. I want to be able to quickly arm and disarm STHM. I want to be able to quickly get device data so I can check on things while I’m away. I need to do the occasional programming of routines, but this is infrequent once set. One needs an app that doesn’t take forever to update information in order to perform these basic tasks.

3 Likes

Dang it @nayelyz and @SamsungZell ! This has stopped becoming frustrating and has started to become infuriating… Another app update failing to fix the constant and ongoing bug with the mobile app not allowing temperature set points to be entered in Fahrenheit even though my Location temp scale is set correctly.

I am NOT using any custom Edge driver or DTH, just the SmartThings default “Zigbee Thermostat” DTH.

I’m really getting tired of the runaround provided by support, and the noncommittal by ST. Right now I have to use a Groovy SmartApp to adjust temperature setpoints because it’s impossible to do that in Scenes or Routines. If this is not fixed in the mobile app soon, and Groovy gets retired, my thermostats are pretty much useless in ST for performing any automations.

Requests :
#1360278 (latest)
#1334103 (March)
#1321798 (February)
#1305616 (January)
#1295409 (December)
#1283760 (November),

image

1 Like

I have iOS as well and I’ll say that the SmartThings app experience on Android is better since I’d rather use my Tab S6 when configuring SmartThings instead of my iPad. However, with this latest Android update, it’s starting to catch up with the startup delay that iOS has because this version is the first time I’ve seen the twirling ‘Getting everything ready’ message at app startup.

Yep, I gave up re-ordering things on iOS. It’s too bad that they can’t use the same ‘sync’ feature that the Favorites dashboard has across devices, but that would probably add more time to the app startup delay.

Without doing anything it seems that it has returned to work as before, with more actions per button than it really has