Setting Hub(V2) but stuck at 'invalid code'

First I am in South Korea
Bought from ebay USA (Smartthings product like hub is not still release in Korea!)

  1. Tried by my Korea samsung account for setting. ( On Smartthings Classic app)
  2. Enter the code but it says it is ‘INVALID CODE’
    (I could not use the Korea account on Smartthings app because I could not found the hubV2 so I used Smartthings classic app at the first time.)
  3. I changed my account to USA samsung account.
  4. Tried to set the hub on Smartthings Classic app
  6. I tried it on Smartthings app (I could find the hub by using USA account)
  7. There was a new massage that the code has been used.

So I tried to reset the WELCOME code
My hub is V2 but the firmware is below 17.11
I delete my location and did all the thing again but still it does not work.

Is they any way to solve this problem?
Contact to Smartthing staff is the only solution?

If it is a used hub, you will need to contact ST support. They will likely require a photo taken of the base of the hub showing all the hub info.

I bought a new one from the ebay seller.
This problem really makes me upset.