Android 2.2.2 - Release Notes

@groovin28 Where got you back the last version (2.2.1). Would be very interested in moving back. Actually have 2.2.1 on my tablet but updated (how dump) my phone.

Seriously? The update breaks CoRE? W.T. F., SmartThings???

Q: Why is it that the only company’s updates that I fear are (1) your updates to the Hub and (2) your updates to the mobile apps?

A: Its a rhetorical question, because we all know why: SmartThings is the only company I know of that consistently releases updates that, like this one, break more than it fixes.

So now instead of having access to the single most useful application, I get meaningless UI changes. Wow!


I’ve rolled back to 2.2.1 and core works fine.

Just search on Google for smartthings 2.2.1 all, until they fix this


Hi, I’ve created the usual thread to report our UI issues with Android V2.2.2

Please report all UI issues there.


I’m running Android 7.1.1(beta) and am seeing the same issues with CoRE. At least if it’s across multiple Apps ST will be motivated to fix it. Hopefully before it causes to many issues.

1 Like

Brilliant…but I can’t use it!
I no longer uses Android as this is too much of a security mess! (my network router kept capturing and alerting me of dodgy IP packets with Trojan, Private Data Leaks and other Malicious Code sent to and from China/Russia/US (and other countries) to a recent Android tablet!).

I use Windows 10 Mobile at home and the Smartthings Windows Phone app, which hasn’t been updated for a long time! Any update on a Windows 10 (UWP) version ???

It would be excellent if your mobile app software team could create a windows app as a UWP app (Universal Windows Platform) app. This way the same Smartthings UWP app could run on:

  • Windows 10 Mobile
  • Windows 10 Desktop PC
  • Windows 10 2in1 tablets and laptop (Surface, HP, Samsung, Dell, etc)
  • Xbox (in your living room?)
  • Hololens (that would be cool technologies and a solid (marketing) demonstrator, even though I can’t afford an hololens!)
  • upcoming Windows 10 VR headsets ( a similar experience to Hololens but in VR and far more affordable! starting price $299.00 for a Windows 10 headset).

All this with one single code baseline to maintain…

Event better, Microsoft provide a “bridge” to reuse most of the iOS app code and create a UWP app from it (ie reuse the Objective-C code and compile in UWP app)! Many have done that already (Facebook, Instagram, candy crush (was first), etc)
iOS bridge:
Also, with Xamarin you can develop one code base and distribute on all OS (iOS, Android and UWP Windows 10)!

Please Smartthings DO invest in the Windows 10 ecosystem with a UWP app!

I hope you will consider this, as I am sure many of your users would also love to be able to access Smartthings from their Windows devices, be it a PC, tablet, VR headset, Xbox or Mobile!


OK. Now this latest release has broken the only SmartApp that makes this platform truly flexible and usable.
Two questions:-

  1. Who tested this with all the available SmartApps and somehow managed to miss that it doesn’t work anymore with CoRE.
  2. When is this going to be either fixed or rolled back to a usable version. i.e. V2.2.1.



CoRE is just one of the apps affected. Even official apps are suffering. @Aaron

1 Like

Just an FYI if you haven’t noticed… before coming here and realizing there was an issue I spent about 30 minutes troubleshooting. Opening pistons, rebuilding, etc… when I finally jumped back in with an iPhone I noticed a good number of my pistons had all of their rules missing. They were essentially blank and had to be rebuilt by hand. Chances are if you’re here you’ve already opened a number of pistons but if not probably best just to leave them alone for now or grab an iOS device. Not sure if this was a direct result of the update or the update AND a result of me opening and poking at the pistons but wanted to mention it.

Do you mind telling the model and make of your android tablet, so that I can avoid buying from that company in the future?

Is there a way to disable autoupdate on the hub?

I don’t get it either. This is one of the best home automation platforms around and that’s INSPITE of the company itself. If it were not for the community it would NOT be worth it and I just don’t get how the unpaid community can do so much right, and carry the platform on its shoulders but those being paid and making money can get so much of it so wrong.

This is unacceptable.


Daaaamn straight!

I hereby raise the amount that SmartThings pays the unpaid ST community by 150%.


I saw the same on Wednesday night with Android 2.2.1 before any updates rolled out.


Sure, this is an Acer B1 770.
I went for Acer as I believed, and still believe, they are a reputable company.

I believe that the security issues are more at the Android OS and Android Apps level rather than the hardware itself! Google barely control or clean their Play Store. Anything can be found on the play store (boosting the number of apps), including dodgy apps which look genuine… If you look at the play store, there are tonnes of apps which are identical in their functions (“you tube” and other media players for instance) but under different names, etc… Simply look at what the app can access, most of it is not required for the sole purpose of the app. Hence this is a way to collect data and even perhaps install malicious code as part of the app install process…

Therefore, my data breach could be from any app on the Android tablet!. I tried to monitor my network and use the tablet a the same time to see what actions/app on tablet trigger the security alert on my router.
Again a few days ago, my router block IP packets from the tablet. It was sending details about the tablet, my location, my local wifi networks, storage, the app installed on my device, etc, etc. to “” in China.
Previously, with the same device, my router blocked IP packets containing trojan code and targeted to the Android tablet… once again, the source IP was located in China and Russia…
Another time, a TOR server (“Dark web” entry/exit point) also tried to connect with my Android device, once again blocked by the IP Deep Packet Inspection on the router.

Anyway, I have no such issues of targeted attack on any of my Windows devices, be it my desktop, laptop or mobile.

So, although there was an article online, a few weeks ago, claiming that some budget Android tablets shipped with a “built-in” backdoor to China, etc., The guilty one is most likely Android OS and the Play Store.

Good luck :wink:


Thanks for reporting these issues so far. Our Android team is investigating.


Hopefully they will provide a fix very soon

There is an older version back on the CoRe site. You need to uninstall this version and reinstall the old version and select do not update in the settings. Everything is working fine again

Thanks for these steps Bobby.

We are able to reproduce internally and are actively investigating. Right now we don’t think it is related to the mobile release but instead related to a cloud release that occurred yesterday. If you are experiencing this, please contact support or PM me your ST username so we can gather that info.


the problems are the mobile release. I have no issue on the 2.2.1 mobile release

1 Like