Amazon Smart Life scenes changed to SmartThings's

I had routines in Amazon that activated Smart Life scenes. Then I linked the Smart Life service to SmartThings. After that, all the Smart Life scenes in Amazon, that previously said "Connected via Smart_life, now said “Connected via SmartThings” and they all stopped working. The scenes were not deleted in the Smart Life app, but they were shown in the SmartThings app, although empty. I would need either to tell Amazon to continue using the scenes via Smart Life or to tell SmartThings not to import the scenes from Smart Life. I don’t know how to do either.

When you connected Smart Life to SmartThings did you disconnect Smart Life from Alexa?

If not, you should find duplicate Smart Life scenes (one for Smart Life and one for SmartThings)

You cannot pick what is exposed to Alexa from SmartThings or Smart Life to SmartThings. It is all or nothing.
You can disable them (the ones t by going into Alexa → Devices → Scenes. Select the scene and at the bottom toggle Enabled off.

Maybe someone else can offer a suggestion to get the scenes working in SmartThings.

Your reply is logical. However, if I disconnect Smart Life from Amazon, then I would lose most of the Smart Life devices since most of then did not migrate to SmartThings. I have seen that the scenes can be disabled in Amazon, but the funny thing is that they are not duplicated, as you said, but only the “Connected via Smart_life” was changed to “Connected via SmartThings” and since not all devices migrated from Smart Life to SmartThings, these scenes were empty in SmartThings, as I said in my original post.
Anyway, seems to me that the integration of Smart Life into SmartThings is not for me. Too many problems and on top of that, not a single switch migrated to SmartThings, only outlets, so I cannot use switches in the “IF” part of a routine in SmartThings, but only outlets in the “THEN” part.
Thanks for your suggestions.

The problem with Smart Life (SL) Scenes that get imported the Smartthings (ST) is that they show as off line. This keeps you from using them in the ST mobile app, and MAY also prevent there use with Alexa. I am not sure.

To use the SL Scenes in ST you need to wake them up. This can be done by toggling each SL scene in the ST web application my.smartthings.com . Maybe this same procedure will solve you Alexa problem.

I noticed that the imported scenes from Smart Life appeared offline, but with the SmartThings app I did not know how to put them inline. To tell you the truth, I had forgotten about my.smartthings.com so I never went there to try to fix the offline problem. However, I don’t think that would have worked anyway because most of my scenes involve switches and outlets, whereas no switches were migrated to SmartThings. Considering all these problems, I have abandoned the Smart Life/SmartThings integration.
I appreciate your suggestions.