Amazon Echo weird issues


(Rey Rios) #1

I have an Amazon Echo and I have a few weird issues.

When I tell Alexa to “Open my Windows” it never does it the first time. It doesn’t say there is an error. It says “OK” but nothing happens. Then if I tell it again (same command) it works. This only happens with my Somfy windows.

I have tried “Turn on” and it does the same thing. Only the second time I use the command works. I also created a group in Alexa to call it “Living Room Windows”. Same thing.

Another weird behavior is with the Logitech. Sometimes I say “turn on/off TV” and it does what I said but I get a message from Alexa saying “There was a problem with Smartthings”. But regardless, it did turn on/off the TV.

I wonder if anyone else is having this type of behavior.


(Ryan) #2

The “The is a problem with SmartThings” or “Hmm…SmartThings is not responding” is a known issue with harmony. There are a couple of posts on here about it. To my knowledge, the best explanation is that the response back to the Echo is timing out and that’s the canned response, even though the actions when through. No idea if that’s the actual reason, but it sounds good!..and no one knows how to fix it. Happens to me every time I use Alexa to turn on my TV through harmony, but not when I have her turn it off.


(Jason) #3

Not really enough info. Have you looked in the alexa app to see what it thinks you’re saying? Have you tried linking the open and close to a virtual device then using that device in Alexa?

Others have reported this same phenomenon, I have seen it as well with various commands, but again I would check the app to make sure it understood you if it doesn’t happen at all.


(Rey Rios) #4

Yes, Alexa understands my command. There is not confusion or a reply from Alexa about not understanding the device name. I have not tried the virtual switch, I might give that a try with the Alexa helper app.

At least I know the Logitech Harmony is a normal bug.