Allow smartthings to run in the background (Windows 11)

The Windows app asks to “Allow SmarThings to run in the background”. It gives only two choices… “Background apps” and “Try again”.

When I select Background apps, it opens Windows system settings. I go to Apps → Installed apps, then select the three menu dots to the left of Smartthings and select Advanced options. The selection for Let this app run in background is already set to “Always”.

I can never get past the notice to “Allow Smartthings to run in the background”.

The Smartthings app will not run. Is there a fix?

1 Like

I am having the exact same thing happening, even though Windows 11 shows permissions granted.

This was working fine on Windows 10, but is totally dead in the water on Windows 11.

Ive never tried it in Windows 10 but am having the exact same problem, tried enabaling via the app section in Windows settings and making sure the computer is in high power mode, rather than power saver mode. Tried restarting as well.

Same problem here, also tried enabling background execution in settings, reboot, etc. -
did anyone find a solution/workaround yet?

I’ve found a solution, it isn’t perfect as it turns on Background Tasks for all apps, but this article, Option 1 contains a script that turns on the background tasks. Then SmartThings works.

https://www.elevenforum.com/t/enable-or-disable-background-apps-in-windows-11.923/

And for the ones that have windows 11 home ? I dont have the local group policy editor. HEEEELPPPP

I have the same issue in Windows 11. I repaired and reset the app from Windows Settings, and after I started the app I got the popup to allow it to run in background, clicked yes, and still doesn’t work.

image
image

The Windows app suddenly started working on Windows 11. I gave up on it, but gave it a try and it loaded right up. I guess the devs where working on this in the background, but I never had an acknowledgement that they were aware of a problem.

2 Likes

I’ve been having this issue. Recently I’ve updated my Windows 11 Home version to Windows 11 Pro, which seems to have solved itself. Maybe a problem with the Windows 11 Home edition specifically?