All Z-Wave devices offline

If I’m posting this to the wrong location you have my apologies.

As noted by the title, All my z-wave devices are offline. I don’t know when this happened but I first noticed it this past Saturday. I was gone for the week before that so it may have been this way for a while.

Each device keeps adding an unknown device into its route. I’m now up to my third one. Following directions I’ve found I added trash fake devices to my system that share the network ID. That changes the route to show a valid route. I’ve tried to repair the zwave network several times and it has never changed anything other than maybe creating a new unknown device (unclear on timing) I’ve rebooted the hub, turned zwave off and back on, stood on my head and uttered unprintable words.

My hub is about 10 feet from both a door lock and a light switch, both of which are z-wave. While I’d expect each to go directly to the hub I think the meshing means that one would hit the other and then on to the hub. I’m unclear on that and I’ve spent too much time doing ethernet to find mesh networks easy to think through. The hub has not moved.

If it matters, I did add Zooz Z-Wave Plus S2 Power Strip that I have now removed. It was on the fringe of having adequate service so it would not work reliably. I just removed that today from the graph ui online.

Any ideas on this? These failures are making my wife question the value.


Read this thread: FAQ: Zwave repair not working (how to fix error messages)

Sounds like you have what are called ghost devices, you’ll need to correct them before repairs or routing work correctly. In short, create a generic ZWave device in the IDE with the same network ID as the unknown ‘ghost’ device, then go into newapp and Force Remove the new ghost device. It will clear the bad/ghost ZWave id from the hub’s registry THEN you can run a repair to fix your routes. Repeat until good.

Force delete? Is that something special?

FWIW, this is exactly what I’ve already done a couple of times. Should I expect it to take several more?

When you try to delete the phantom it will most likely will and actually should fail because its not a real ZWave device. When it fails you should then be offered the opportunity to ‘force delete’ the device and should do so.

Just found that. Thanks for the response.

Just spoke to ST - tech said I’d need to delete and rea-add all my devices. Does this sound right?

It sounds typical. Note I didn’t say right.

I’d ask them - why. It sounds like bringing a shotgun to bear on a mosquito.

I’ve never had a situation where I couldn’t fix phantom devices and repair the mesh even if that meant rejoining a few strategic devices. I’ve not had to nuke it all.

1 Like

There is a satisfaction that comes with using a sledgehammer to kill a mosquito.

The thing I just get past is that it KEEPS creating new ghost devices. I have that zooz power strip plugged in but not joined to the network. Could that be what’s creating these new items?

Does every new unknown device get the same device ID? (screenshot?)

Thanks for the direction.

It turned out to be the power strip that was causing the problem. Even though it had been removed, I don’t think I had properly excluded it so it kept trying to jump back into the mesh. I removed it because I couldn’t get a good connection (under my desk, near far point on the network). Lesson learned, if you have a device that you want off the network make sure that there is no way it can connect - unplug the power.

I had to run the rebuild several times but gradually each item came back up.

1 Like

Zooz power strip by any chance? I have two of them and have often suspected them causing some of my zwave related havocs. Recently I excluded and included, supposedly successfully, a Zen20 power strip and not all of the devices it created are offline… so I have close to 40 offline devices right now. GRRRRR

Yes, Zooz. Once I unplugged it I was able to rebuild the network. The ghost nodes were all individual switches (outlets) on the strip. I’m puzzled by the behavior of the power strip. I added it close to my hub and all the devices showed up. I moved it to its final location and it lost connectivity - despite that there was one item further away from the hub. This makes me question the strength of the radio in the strip. I tried to re-add it to the network and it only shows one device now. I’m going to add a couple of devices between the strip and the hub to see if that changes any behavior. If it doesn’t, the strip is going back. It’s a nice idea but if it doesn’t work… Well, a power strip is a power strip and there’s no way that one is worth 4-5 times the cost of a dumb one.


1 Like

Every time I’ve read this as a troubleshooting step, it bothers me. Because the ZWave devices determine their nearest neighbors to join the mesh, keeping it close to the hub to get a device set up, especially if not centrally located in your home, seems like just a bad idea.

In your case, if it is so far away that it can’t join the mesh to re-connect when it was near the hub, maybe do an interim move try half way from the hub, rebuild the mesh, then a final move, and rebuild. (All this is in theory.)

1 Like

I agree on the fundamental problem of connecting near the hub but if I don’t get the device properly setup nothing else really matters. So, compromises are sometimes needed. If it gets me the proper end point, I’m good with the process.

Before this adventure I had no idea what the rebuild did. Now that I do, I can see that if I add a device, especially if it is in between one that works and the hub that I should rebuild the network as part of the overall process. I’ve also learned that I should pay more attention to the routes, distances, and neighbors to better understand the topology.

If I’m learning I’m moving forward. Four devices to add to the system this weekend. Two should improve connectivity to the strip. We’ll see. Learning continues!

1 Like