ALL Automated Functions Have Mysteriously Ceased Functioning. Why?


#1

ALL Automated Functions Have Mysteriously Ceased Functioning. Why ?

I have few simple automated functions under Smart Apps > Smart Lighting. These have mysteriously quit working. I can still control switches manually, but no more automated functions.

Suggestions appreciated.


(ecksomperudenlign) #2

Smart Lighting is notorious unreliable. Give Lighting Director a try.


#3

If Smart Lighting is known not to work, why is it still on the app?

I can’t find “Lighting Director” on my Smart (random) Things app.


(ecksomperudenlign) #4

Beats me.

You can find Lighting Director in Market place>>Smartapps>> Lights and Switches

What is Market Place? https://support.smartthings.com/hc/en-us/articles/205379924-Marketplace


(Bob) #5

SmartApps are not the cause of unreliability; the underlying SmartThings platform is. Your problem is more than likely due to a failure of the ST scheduler. To check, in the IDE, goto My Locations > List SmartApps. Your Smart Lighting entries will be near the bottom. Click/tap on the name of each automation that isn’t working. Near the bottom of the resultant popup page, there will be an entry for Scheduled Jobs. If the date/time shown is in the past, that’s your problem. To “fix,” click/tap Update on the line in the main screen where your automation names appear. Do this for each one that isn’t working.

The scheduler has actually improved lately, so this may indeed resolve your issue. if not, depending on your ambition level, you can either try deleting and recreating the failed automation, or just open a ticket with Support.


#6

Mr Lucky,

Thank you for helping.

Your instructions worked as described until I got to, “Scheduled Jobs. If the date/time shown is in the past, that’s your problem.”

Under, “Scheduled Jobs” I have, “None”, ( I don’t mean none, I mean the actual word “None” and a long series of letters and numbers just below, “None”.

Also, I don’t see, “Update”, I do see, “Refresh”.


(Kevin) #7

SmartLight isn’t that smart TOO many misfires I switched all my smart light settings to rule machine. The only app I have now is rule machine & of course I’m still using my ST routines for local lock control & duplicate light control for when ST goes down this allows me to still do basic lighting controls. But I wouldn’t recommend this for the faint of heart because there’s a lot of backend config that you have to do in RM to get everything to work correctly.


(Bob) #8

The only way “none” could be valid is if you are indeed not using scheduled events. What event triggers your lights on/off? If it’s anything other than sunrise, sunset, or specific time, then it’s not a scheduler issue

The Update link(s) I referred to are on the main page, like so:


If you have scheduled events, you want to click/tap the specific automation, not the parent (Smart Lighting).

And @K03045 is right… Rule Machine is the better way to go, though it won’t be any more (or less) reliable. For example, each of the pair of Smart Lighting automations in my screenshot that use sunrise/sunset for one state and specific time for the other, can be accomplished in a single rule using Rule Machine.


#9

The only way “none” could be valid is if you are indeed not using scheduled events. <<

I did, “My Home” > SmartApps > Smart Lighting > New Lighting Automation.

I then got a window with fairly simple setup instructions. When I first did this a few months ago I tested everything and it worked PERFECTLY. It continued to work until a couple of days ago.

All of the devices I am controlling are Aeon Labs DSC24-ZWUS Smart Switch Z-Wave Appliance Modules or the Aeon Labs DSC06106-ZWUS - Z-Wave Smart Energy Switch. I am not trying to control thermostats, sensors, alarm systems, or the Curiosity Mars rover. Just these Z-Wave switches.

What event triggers your lights on/off? If it’s anything other than
sunrise, sunset, or specific time, then it’s not a scheduler issue <<

In most cases a specific time, in other cases sunrise or sunset. ALL of this has been working perfectly for about two months. Then, a couple of days ago all of the automation stopped. Manually, I can still control everything with no problems.


(Bob) #10

Ok, then it sounds like you are using scheduled events (that failed). Just click/tap Update as shown above, on each failing automation. Wait a bit, then access the automation link again and see if it still says “none.”


#11

I have done as you requested.

I clicked on all, “Updates”. Under, “Scheduled Jobs” it still reads, “None”.

Because these procedures did not appear to have any affect. I went into the iPhone app and reprogrammed a couple of my OFF-times, (just two minutes into the future for testing purposes).

In my testing, the two switches turned off as programmed. I will wait to hear from you, but perhaps my best course of action is to “simply” re-do all of my programming.

To further add to the confusion, the website under, “Smart Lighting” still shows my OLD programmed OFF time. When I hover my mouse above the words, there is a small pop-up that also shows the old wrong programmed OFF time. When I click on these words, I get a large pop-up that does show the correct programmed OFF time. I have clicked every “update” I can find, but it still shows the wrong OFF times on the main webpage.

Well, after typing the above paragraph I navigated around on the website some more. Eventually, I came back to, “smart lighting” all the times appear to be updated.

It’s too bad that one cannot edit events on the website, that would be a little easier than using the iPhone app.


#12

I am using SmartLighting for simple automation of my house and one Automation is, all of sudden, running sporadically. There are two Automations for each device: One to turn the lights on at Sunset -60 and another to turn them off at 1:00 AM. Gotta do it this way since you can’t mix on and off modes in a single automation. Anyways, all of a sudden, one of the ‘turn on’ automations doesn’t run anymore. I’ve checked it in the IDE logs and sure enough, it’s not firing. I can control the light as a Thing just fine. I’ve deleted the automation and put it back in again and it still seems sporadic (although it seems to turn off fine if I turn it on manually through the ST interface). Nothing has been moved or changed on my end and I’ve tried many of the suggestions here but am at wit’s end. I have gone so far as to create a second automation that turns on the device thinking that if the first one isn’t working, maybe the second one will fire.

Thanks