SmartThings Community

Alexa works but she thinks she doesn't (November 2017)

alexa
echo
harmony

#61

Just keep hammering support so they know that the issue for that piece is ongoing. It seems like there are 3 or 4 different issues with Alexa all tied into one. :slight_smile:


(Mike Coscia) #62

Noticed this issue the other day. Originally I was getting the “can’t communicate with SmartThings” error message, but the activity would turn on anyway. Now I am getting, “Living Room TV does not support that” when I ask it to be turned on. It still turns the activity on, but it won’t turn it off. It seems like the issue may be due to the Alexa app listing all the harmony routines as scenes now instead of devices.


(Andrew Taylor) #63

I had this issue for a few days, but it seems to be resolved now. No more false error messages. I’m in the UK if that makes a difference? Perhaps the skill on the UK servers has been fixed.


(Galen ) #64

Mine seems resolved as well. Thanks, Samsung!


(Shawn) #65

I am having all the same issues as above, Alexa saying it worked but it doesn’t, Alexa saying it didn’t work but it does, etc. Basically Alexa and Smarthings $h1% the bed a few weeks ago. Wife is getting pretty fed up with my smart home dream…


(Stephen Hill) #66

I’m getting ‘The SmartThings Hub that the INSERT DEVICE NAME is connected to - isn’t responding. Please check on the hub.’ The device in question is an Osram bulb. My Hue bulbs all work fine.

Just vindicated my decision to replace 99% of my Osrams with Hue bulbs. Having the Hue Bulbs not having to go through SmartThings is a god send.


UK NOOB, basic questions, OSRAM etc
#67

Not sure if anyone experience this, Alexa trigger the switch twice and resulting in duplicate command being sent?

Any suggestion how this can be overcome?


(Kalel) #68

OK, so mine was getting better for a few days, but now, it has gotten worse. For example, I have a harmony hub routine called TV. SmartThings recognizes the routine, and I can can control it through the SmarThings app. I can turn on the TV routine or turn off the TV routine in SmartThings. Now, if I go to Alexa, it allows me to “turn on TV”, and it works. When I ask Alexa to “turn off TV”, alexa reports that the “Device is disabled”, even though the Alexa app displays the TV “scene” and indicates it’s “connected via SmartThings.”

So… I tried the same with another working harmony hub routine that turns on another device, etc. Again, I can turn it on via Alexa, but turning it off yields Alexa saying it couldn’t find the device in my profile, when it clearly turned it on via voice command, and where the Alexa app recognizes it being controlled via SmartThings. (And SmartThings can turn it on and off via its app.)

This is a problem, of course. And, I suspect the following… When Alexa turns on the TV via SmartThings, it tries to turn off the TV using the harmony hub directly (which fails), because there was a 2nd Alexa scene entry for TV (via the harmony hub), which I removed, since it should only go through SmartThings (and I do not have the Harmony skill activated in Alexa.) Why Alexa can turn on via SmartThings but wants to turn off via Harmony is completely beyond me. Especially since it was working just a few days ago. This is no doubt due to continued issues with the new Alexa API and its integration with SmartThings. I’ve updated my trouble ticket with SmartThings to include the latest symptoms. -Kal


(Kalel) #69

And now, I think I found a solution, and yes, it looks like it’s an Alexa-related issue with its integration again. As I mentioned in my prior post a few minutes ago, I could use Alexa to turn on SmartThings-based scenes (that originate through Harmony Hub), but could not turn them off with Alexa. I verified that the only scenes listed in the Alexa app were the SmarthThings-based scenes. However… if I go onto the alexa.amazon.com website and take a look at the Smart Home settings there, there were indeed differences! Multiple definitions of scenes (including those that are listed “via SmartThings” and those listed via Logitech Harmony Hub.) Several of these duplicates on the site were not listed in the Alexa app. So, back on the Alexa website, I chose to “Forget” these duplicates (the Logitech ones), and was now left with only the SmartThings ones. Immediately, I could use Alexa to turn on and off the SmartThings routines that were causing issues before. In other words, the Alexa app and the Alexa website have two different set of data applied to them and are controlled differently. At least in my case, that’s what was going on. I used the Alexa website as the main place to make configuration changes, in this case, "Forget"ting the duplicate routines, since that didn’t work in the app.

I really don’t know why this all changed over the past few days (the usual Alexa integration mystery), but I’m going to try out these routines again over the next few days and see how things go. --Kal


(Steve B) #70

I worked on this for hours a month ago with SmartThings, I resolved the issue by installing WebCore and creating a piston that goes out and refreshes all the devices that are not working properly, Alexa has not failed ONCE since I did the WebCore thing. I am uncertain what the real problem is but I am happy I figured a workaround.

Steve


(Alex) #71

Hi @sblinder - Would you mind sharing the backup code I can use to import the piston? I am still having awful trouble with Alexa and devices going offline randomly. I am curious to see whether your piston will help my case…

Thanks!


(Steve B) #72

Best I can do is this picture.


(Alex) #73

@sblinder - Thanks, that is what I needed. The back up code was 5r60 but it is simple enough for me to try to create my own. I am wondering whether this will prevent devices I rarely use from being reported as “Offline” by ST. I am going to refresh them once a day to see if that helps. Thanks!


(Steve B) #74

It should, its been flawless since I put it into action


(Dan Shipman) #75

Mine randomly does the same. I have v1 hub, alexa and harmony elite hub. It also affects my living room, kitchen, and dining room intermittently. Since april I have had slow response through alexa voice commands. I added harmony elite in september and started having random issues in november. Over 3 years without a problem, and now this. Any fix ideas?