Alexa stopped running my routines if they have an exclamation point in the name


(Phil) #1

I am using routines in smartthings… good night, good morning, late night. Good night and good morning where the default routines in the smartthings app and they where named Good Morning! and Good Night! by default. When I created late night I wanted to keep things consistent so I named it Late Night!. I activate these routines by voice using Alexa (echo).

This morning I ran the Good Morning! routine via Alexa no problem and have been running all three routines no problem for about 6 months. Tonight I tried running Late Night! and Alexa said I have several devices with that name which one did I want. I do not have any other devices with that name, so I just tried again. Same thing. I then tried running the other routines and Alexa said the same thing for each routine.

I logged into the Alexa app and the web interface, checked every thing, has Alexa discover my devices again, tried changing the names of the routines (but left the ! in the new names). Nothing helped. Becoming ever so close to throwing the echo against the wall, I decided to try one more thing. I renamed my routines back to the original names, but this time I left the exclamation point ( ! ) off of the name. All of a sudden all the routines started working normally via Alexa.

To test I added a ! back to one of the names and it stopped working again. Take the ! off the name and it works fine. So today at some point either smartthings or amazon changed something in the skill that stops it from running if it has a ! in the name of the routine.

Anyone else see this or know what going on?

Thanks.


(Cristofer Johnson) #2

I have the same problem starting last night.


(Alex Christensen) #3

Huh. I had to take the !s off last year sometime.


(Cristofer Johnson) #4

Started working again


(Phil) #5

Thanks for the replies. I guess I’ll just leave them off. Good to know it wasn’t just me.