Alexa + SmartThings + IFTTT + Harmony to turn TV on and off by voice (2015 version)

I’m hoping the same thing. I’ll keep messing around with it as well. In the meantime I am using IFTTT.

JDRoberts…

My Wife is a C5 Quad 18 years post injury.
Over the years I have implemented a number of solutions to help my Wife control Her environment.

It appears Alexia may be the first “Always Listening” voice control device that may actually work for my Wife.

I would be pleased to share with you what is working for Her and if you would be willing to share what works for you, many things are possible.

Maybe we could start a thread focused on SmartThings for people with limited mobility?

I have a bunch of ideas.
Most of our new hardware will be home by the end of the week.

Thanks for your consideration.

-BB and NB

Done! Continue the discussion in the following thread ( this is a clickable link):

As requested, here are the screenshots of my Harmony activity that does nothing except increase volume. This is just a step in the Start sequence.

This is The method that uses two activities and then swaps between them. I haven’t been able to get Tony’s method to work, but maybe he can post the screenshots of his harmony activity.

Here’s one of the volume control activities. I do not change the HDMI input, just the volume.



To add steps, edit the activity, then choose Entertainment Devices, and Add a Step.


1 Like

After working perfectly for weeks, I am suddenly experiencing long delays (up to 10minutes at a time) between giving Alexa a command and IFTTT actually executing the action. That makes it sort of useless for controlling my TV.

Anybody else having this problem? I appreciate any ideas on how to fix it.

Same here! I actually just came on to ask the same question. Seems like it started yesterday. I tried reconnecting the accounts, but it didn’t work. I think it might be on Amazon’s side not IFTTT, if I check the recipes on IFTTT they work fine. It happens with any IFTTT Alexa recipe, not just harmony. Alexa is just not sending the commands out or they are delayed for an extremely long time.

I suspect it is an IFTTT side issue because all other commands going through Alexa work fine for me. I know many IFTTT triggers have a delay because the IFTTT servers manage load by polling for triggers every 15 minutes or so. I just assumed the Harmony channel was an exception.

Mine was slow for about 10 hours, then came back to my typical 8 seconds. I didn’t do anything to fix it. My guess is IFTTT or Harmony got temporarily overloaded with Christmas customers. We’ll see how it goes for the next week.

Yeah, everything is working fine for me now. I only get a 3-5 second delay.

1 Like

Anyone have an issue where the commands only work when the soft key screen is on? I have an Ultimate and if the remote is “asleep” the command doesn’t work. If I shake the remote so that it is “awake” it works perfectly…

First, thanks for all who offer support /advice. Awesome community.

I’m having an issue I just cannot work through for both using the Logitech Harmony (Connect) SmartApp and then a completely different issue using IFTTT…

Smartthings issues discovering Harmony Hubs

I’d much rather add both Harmony Hubs via the Smartthings app to control the hubs via Echo but no matter what I’ve done, I can’t even get the Smartthings Logitech Harmony SmartApp to discover my 2 Harmony Hubs (or either of the 2 Hubs). I receive an immediate ‘Connection to the hub timed out’, Please restart the hub and try again’ message appears after clicking on the SmartApp. Regardless of deleting the SmartApp and adding it back in, I can’t get around this issue.

Following is for IFTTT issues I’m seeing

Hardware: I have an Echo, Smartthings (v2) and 2 Harmony Hubs (Smart Control).

Goal: Control upstairs and (separate) basement Harmony Hub via Echo (Power On, Power Off, Change Channels, etc)

Issue: Using IFTTT, only one Harmony Hub is detected (basement). Upstairs Hub is nowhere to be found although works as appropriate through Logitech remote/ Logitech app to control TV, Roku, (it’s not dead).

Note: Using Echo to control the basement Harmony Hub works with no issue.

Troubleshooting efforts:
-Unplugged basement Harmony Hub, yet IFTTT doesn’t see the Harmony Hub that is online (upstairs). Nothing appears in IFTTT.
-Attempted to delete recipe in IFTTT and re-add. Only basement appears
-Renamed activities so they are different
-Renamed Hubs in Logitech so they are different
-Renamed Hubs in my router so they have different names
-Saw a response (albeit dated) from Logitech suggesting I cannot give Static IP addresses. Apparently, I cannot.

I’m out of ideas. Any thoughts?
End of day, I’d like to control both upstairs and basement via Echo. We mainly sit upstairs so it’s unfortunate the basement appears /works and upstairs does not.

I’m sure that’s very frustrating. :disappointed_relieved:

  1. there is a recent issue for many members which prevents adding a second hub using the official smartthings integration. More discussion in the following topic. Report it to support@smartthungs.com

The issue is being tracked in the community-created wiki

http://thingsthataresmart.wiki/index.php?title=Bug:_Cannot_add_second_Harmony_hub

  1. from the IFTTT side, first see if you can get the harmony channel to show you more than one hub, independent of anything from SmartThings. Just create a recipe where you use anything for the if, and when you go to select harmony for the That, see if it shows you both hubs. If it does not, you would need to contact logitech support to see if there is a way to get access to the second hub.

No one is having this problem?

Don’t have the ultimate myself. Just the Logitech Hub. Figured I would use the tablet as the controller. Never had that problem

I only have the hub. Quite honestly, because I can’t convince the wife that using a remote will increase the WAF, it basically gets used to turn on and off the various AV systems…but not much else. Sorry, can’t help.

I could solve the problem by not letting it go to sleep but then I’d be charging that remote constantly…

For what it’s worth, I don’t need IFTTT to do all of this:

  1. Connect SmartThings to Harmony with the Logitech Harmony (Connect) SmartApp. During install, include the proper Harmony Activities. In this example, I have two activites: Apple TV and Xbox.
  2. Connect SmartThings to Amazon Echo with the Amazon Echo SmartApp + “Alexa, discover my devices.”
  3. Now, simply tell Alexa what you want:
    “Alexa, turn on the Apple TV”
    “Alexa, flip on the Xbox”
    “Alexa, kick the Xbox off”

No triggers needed, response is instantaneous, and on/off work appropriately.

But not today…seriously, all the external system integrations that control SmartThings devices broke today, including IFTTT, Harmony, and Echo.

Mine can do that as well but when you turn on devices does Alexa tell you it cannot do that command? For some reason the command works but it’s irritating to hear her say that every time. She has no objection when turning off however…

Interesting. Mine has been responding fine all day. On those days, I just resort to the switches in the house. Part of the price to pay for cloud-connected, evergreen services, I suppose, but it still works I guess.

And no, Alexa just responds with “OK.” To on/off requests for Harmony. Maybe I got lucky?