Alexa + SmartThings + IFTTT + Harmony to turn TV on and off by voice (2015 version)

Mine does the exact same thing. Something about that device does not support that command…but it all works. Only happens with turning on… I’d like to stop it as well, as it’s annoying, but the commands function, so…

The exact setup was working fine until about 24 hours ago (“Alexa, turn on TV”). Suddenly NONE of my IFTTT recipes are firing. Confirmed that Harmony, WEMO and IFTTT is working fine on their own (and other recipes).

@Todd_Whitehead asked how to set up a Harmony activity that will shift to a desired channel such as ESPN TV. This will apply no matter which integration method you’re using, because the first step is always to create a Harmony activity that does what you want.

As long as you have a home entertainment device controlled by the Harmony that has Channel selection, you should be able to enter that channel number as a step in the starting sequence for the activity. Here are my screenshots for the ESPN TV channel, which is 724 in my area. The channel control device is the Xfinity set top box (STB) not the television itself. So that’s the device I’m going to select for the activity step.

( Harmony also has a field that let you set the starting channel for the activity and not use the step set up, but as the others have discussed above, that doesn’t seem to always work. I’m not sure why. You can try and see if it does work, but if it doesn’t, try putting the channel in a step instead as shown in the screenshot below.)

This is a screenshot of my ESPN TV harmony activity. Noticed that I have not used the “starting channel” option. Instead channel selection will be part of my start sequence.

So I would edit the start sequence, and choose the set-top box (STB) as the device I want to work with. So I’m going to start by selecting “edit entertainment devices.”

Now I can choose add a step, and then choose the STB.

Now I have two choices for the step. If I click on “command” it will show me a list of the possible commands for this device and I can pick one for the step.

Or I can just enter the channel number I want into the second box. That’s what i’m going to do. In this case, it’s channel 724.

Save all the updates by using the icons in the top right corner of each screen until you have completely save the activity. Then save your settings, and when you come back to your harmony app, synch as usual.

So that’s how I do it, by using the channel option in a step of the activity start sequence. :sunglasses:

1 Like

Mine does this also. Turning on works, but Alexa still gives the error message. Turning off works with no error message.

I followed @JDRoberts excellent advice several weeks ago to set up a dozen channels that can be changed by the Amazon Echo (“Alexa, turn on HGTV”, “Alexa, turn on ESPN”, etc.) and I can confirm his process works perfectly!

Kudos on the clean walk-through!

1 Like

THANK YOU! THANK YOU! THANK YOU!

I could not figure out where people were adding the channel command in the Harmony app. Works perfectly now.

1 Like

I might have missed something because I have my volume commands screwed up somehow. Overtime I add a routine for volume up or down it powers off the TV! Unlike the routine to change to a new channel that works just fine… Did anyone else have the volume up/down power issue and manage to resolve it? I’m screwing something up lol…

Post the screenshots of your Harmony activity and someone can probably help. :sunglasses:

I have over 15 harmony activities integrated into Smartthings. Can somebody tell me why I can only view 5 of them under “things”? But if I go in my harmony smart app, I can see them all and piggyback virtual buttons to them.

In this picture, there are only four shown, but…in this next picture, there are 14 in the harmony smart app.

I can’t get the other 10 activities to show under “things.”

Very cool! @JDRoberts Whats the best way to use natural language for this? Are you naming the activity as simply the channel name ; i.e. “ESPN” “IFC” etc? Or creating Alexa groups? something else?

I tie a virtual button to the harmony activity. Then I name it for example ESPN so I say “Alexa turn on ESPN”.

Only issue I have is only 4 of my 14 harmony activities show up under “things”, but yet I can link all 14 to their own virtual button. I don’t know why all 14 don’t list under things.

I started out just using the channel name, but that can sometimes conflict with built-in echo options. For example if I say “turn on ESPN” it would often try to start the ESPN radio station. So I changed the name to “ESPN TV” and then it worked fine. But you may just have to experiment to see what feels natural to you. See the naming quirks thread for more discussion.

1 Like

OK, I think I know what’s going on here but I don’t currently use the official Harmony/smart things integration smart app, so I can’t test it. But here’s what I think.

The official Harmony Connect smartapp now creates its own virtual switches
The current version of the official harmony connect smart app already creates a virtual switch for each of the activities. At least it’s supposed to. Those new virtual switches get a really strange name where [harmony] is appended to the end of the activity name. (Obviously whoever wrote this doesn’t have an echo.) those switches then show up in your things list. Not the activities, just the virtual switches. The activities only show up under the harmony.

You can see in your screenshots that those are switches because of the icon that they have which is an on button.

your own virtual switches

If you are creating your own virtual switches through the IDE or through one of the smart apps that create virtual switches, they should also show up in the things list under whatever name you gave them, although they may have a different icon depending on the device type you selected.

your missing activities

My guess, although again it’s only a guess because I haven’t tested it, is that you may have added harmony activities after you initially connected the hub to SmartThings. If so, you haven’t gone through the official process to create the virtual switches for those activities.

If those activities did exist at the time you connected the hub, maybe it only makes switches for the first four. That would be a bug, though.

Ordinarily you could try removing the harmony hub and then re-adding it, but I can’t recommend that at this time because people have had problems with re-adding hubs recently.

So I would suggest either just making your own virtual switches for the missing activities and associating them individually, or waiting until you contact support@smartthings.com to see what they suggest. I just don’t want you to lose any functionality you currently have which is why am not suggesting changing names or anything.

But the main thing to understand right now is that what you are seeing in the things list are the virtual switches which have been associated with Harmony activities. Not the harmony activities themselves. So you have 14 harmony activities, but only four Virtual switches to go with them. It’s the virtual switches that are missing, not the activities.

Good luck, let us know what you find out.

Those icons that look like harmony hubs are activities. Those were created prior to syncing harmony to Smartthings.

The other 10 harmony activities were created after Smartthings integration.

Whenever I create new activities now they show in the harmony smartapp, and I am able to create virtual buttons in the IDE and link to newly created activities to them.

I just don’t know why there are only 4 harmony activities visible in my things list, but I can see all 14 virtual buttons that operate my 14 activities just fine.

I’m afraid to unlink and re link my harmony hub to Smartthings at this time like you already stated.

I believe the ones with the harmony icon on the left are in fact virtual switches that were created by the harmony connect smart app at the time that the hub was added to SmartThings. You can see their button icon on the right. The "[Harmony] at the end of the activity mean on these devices is what identifies them as a device created by that Smartapp. If you look in the activities list itself, you’ll see there’s no similar bracket text for the activity itself. The virtual switch created by the Harmony Connect smartapphas the same name as the activity plus the bracket text.

So the question is how can you use the official smart app to create the same virtual switches for activities that are added after the initial hub discovery. I don’t know. My guess is that you’re supposed to remove the hub and then re-add it but that’s the part that’s that’s been breaking recently, so I wouldn’t suggest you try it without checking with support first.

So you’re saying those little icons that look like harmony hubs are the virtual switches are were automatically created when activities were added?

They do present with [harmony] in the name.

If so, then where are my other 10? I added those activities the same day as the first 4.

1 Like

Gotcha. Ok thanks. I’ll sit tight until the dust clears b 4 I delete and re add my hub.

I meant to say those were added in the same WAY as the first four, not “day”.