Alexa + SmartThings + IFTTT + Harmony to turn TV on and off by voice (2015 version)

I have a smartthings hub coming tomorrow to help integrate my echo and harmony hub. With new triggers will you be able to change the channel, volume, play pause, record etc. Or s this just basic start/end activities.

Harmony does everything based on activities. SmartThings doesn’t change that. So the first step is to set up a harmony activity that does what you want to do.

That’s quite simple for a “favorites” channel so it’s easy to, say, switch from the Disney Channel to ESPN TV… So the first step is to set up a harmony activity that does what you want to do.

You can also do pause and record. You just have to set each one up as its own activity and use a harmony activity “step” to map to the right button.

Where it gets ugly is when you have something you want to do you twice in a row, like channel up, or volume up. Harmony does not allow you to do the same activity if it’s already active. So you end up needing two channel up activities or two volume up activities and keep switching back-and-forth between them. It can be done, but it’s not graceful.

With the new IFTTT triggers for the echo channel (added 12 November 2015), SmartThings doesn’t really add any feature capabilities to an echo/harmony integration. What it does do is let you set various rule parameters around the harmony execution. So for example you could make echo activation of the television only work at specific hours of the day, or only work for a certain amount of time, or not work at all unless the parent was also home, so that your kids will be encouraged to get their homework done.

Hello!

All my devices on Alexa have suddenly stopped working…:cold_sweat: even just an ‘on’ ‘off’ She "That command does’t work for that device.I have been using all my ST devices all this time.I have upgraded my firmware on my ISP router.

Could it be because of that?

Please help

Suddenly everything is back on track.Not sure what happened.

1 Like

JD -

With regard to being able to run the same “single-action” activity twice in a row:

Where it gets ugly is when you have something you want to do you twice in a row, like channel up, or volume up. Harmony does not allow you to do the same activity if it’s already active. So you end up needing two channel up activities or two volume up activities and keep switching back-and-forth between them. It can be done, but it’s not graceful.

I’m assuming that you have been running into the same problem that I had – that the first call to such a single-action activity (such as “Volume Up”) would work fine, but that the second call to the same activity would end up turning the device off instead of running the action again.


I found a really nice solution to this problem!!!

In sum, all you need is a device that DOES NOT have a “power off” command. Here are the steps to create a single-action activity that you can run over & over:

  1. For the device you want to control (e.g., volume for a TV), create a 2nd instance of that device. Call this one something like “TV No OFF”, so that you can tell the difference between this instance of the device and the original instance.
  2. Use the “Add/Fix Commands” option on the 2nd instance of the device. Choose the “Power Off” command. Teach the Hub to use the “Power On” command when calling “Power Off”. If your device only has a “Power Toggle” command, teach it some other command that will not affect your set up (either using the device remote or a remote from another device).
  3. Go to “Power Settings” for the device and choose “KEEP DEVICE ALWAYS ON” (I’m not sure if this is necessary, but I’ve set it up this way just in case).
  4. Create a new activity using that device (e.g., “Volume Up”). If the set-up asks for any input, choose none.
  5. Edit both the “Start Sequence” and the “End Sequence” of that activity to include the action(s) you want to run.

You will now be able to call this new activity as many times as you want. I can call it via Alexa, through IFTTT, by ST virtual switch, etc.

-T

Tried this method as described, but it don’t work for me, probably because my television is my master device. When it goes off all of my devices go off.

It’s possible that this method would work if, say, the sound bar was the master device. I can’t try that because I don’t have a different set up. But I do know that different activity combination to do work for different people depending on which, if any, device is the master.

It’s possible that if I include both versions of the television in the activity it will work, I will try that later. edited to add: that didn’t work, either.

Hmmm. I’ve been able to use this method on both my TV and my receiver (my master device).

Just include the NoOff device for any single-action activity. By changing the IR Off Command of your TV NoOff device to some other, harmless, IR command (like either the Power On IR command or a harmless IR command from another device), you should be able to call any single-action activity over and over.

Are you able to determine what step is turning your TV off?

Not yet, but I’ll take a look later.

JD,

Any tips on how you’d write the “Pause” or Play" or skip activities or even favorite channel. I can’t seem to get them to work.

I am using Alexa with IFTTT to control my Logitech Elite and the first few days tv activity would trigger with minimal delay. The past few days, I’ve seen considerable delays before the activity initiates, if It even starts. Today has been better and haven’t seen any delay turning on or off

I also set up a a trigger for the upstairs tv but that has never worked and seems to confuse another Logitech hub. Has anyone experienced this and is there a fix?

Anyone able to control more than one hub without any issues?

Would controlling this through my SmartThings and using virtual devices work better?

I have two hubs and noticed the same thing. Activating triggers was almost instant when I first set it up. Now there is a 5+ second delay. It usually always works though, just takes longer than it used too. Controlling through smartthings is faster, but I am having issues with Echo’s response to turning on the logitech devices in smartthings. If I say, “Alexa, turn on the living room TV” it will turn on just fine. However, Alexa spins her blue light for awhile and finally says that the command does not work with that device. I imagine it’s because the harmony activities are listed as devices in smartthings and not switches as the old method used to be. I’m hoping a solution pops up quickly, as I would rather use smartthings than IFTTT.

Hi Mike,

Are you using virtual switches controlling your harmony through SmartThings? If you are not using virtual switches/devices, how did you set it up?

The new Harmon [Connect] smartapp creates devices for you. It’s a lot nicer than the original method, you no longer need a dedicated power off trigger. Every device is a switch which turns the activity on and powers all activities off. However the harmony activities are labeled as devices in smartthings and not switches, hence the issue with echo.

Mike,

Thanks for making me look for the app.

I had been trying use the Harmony Triggers app but I found the new Harmony Connect app and reauthorized my ST hub with the Echo. I renamed each of the activities first to make them different and the watch TV activities on my 3 hubs are now a “thing” in my ST app.

The Echo works well with the family room TV but still did not start the activity in the media room. Also, I get a message from Alexa saying that the device does not work on device activity but it turns everything on with no issue. The funny thing is get no “error” message when I ask Alexa to turn off the TV.

I still have the IFTTT trigger set up but will keep using the Echo>ST for now and see which works best. I find it cumbersome to have to say “trigger…” when using IFTTT.

1 Like

No problem and I believe I found the issue causing the error message from Alexa…

Open up the web interface for your smarttthings hub. Click on any of your harmony devices you just created with the new app. See if your devices are listed as “Harmony Activity” under the name and label category. If so delete harmony activity from label and rename the name category to whatever you want. This fixed the issue for me. Now Alexa says “okay” when asked to turn these devices on and off.

Looks like when I renamed the newly created harmony devices in the smartthings apps, it placed the name in the label category and not the name one. Looks like this might have been the issue. Try it out and let me know!

1 Like

I just tried this with no luck. The name was already renamed to “Family Room TV” when I did this in the app. I removed the “Harmony Activity” from the label field on the web interface and still get the same message. I only get “Okay” when I turn off the TV.

I also tried using the same “Family Room TV” for both the label and name field and still get the message.

Did you try unlinking from the echo app, forgetting all devices, then link everything back up. I initially tried that, didn’t work for me. But hey, you never know. Also, look at the Harmony [connect] smartapp again and make sure all your activities are checked off. None of mine or my hubs were, not sure how they got unchecked though. Maybe the recent update to the hub.

Okay, I spoke to soon. Just got the error message again. I need to do more testing and see if it only effects some devices…ugh.

Okay, just checked all my devices…this is what I found. I ONLY get the error message when I initially ask to turn an activity on. If I ask to switch to a different activity with a current activity running, I get no error message. That makes sense, since we are getting no error with off either. Now the question, what is causing it and how do we fix it. I’m out of ideas right now.

I’m hoping it’s just a glitch that can be fixed and even one day be able to control channel changes and volume control by voice. I’ll keep messing with it, if I find a fix, i’ll be sure to post back.