Alexa Routines & Simulated Contact Sensors stopped working (17 April 2020)

I created several new virtual switches tonight in Groovy and setup routines in Alexa. Everything worked as expected. I switched over several of my devices to use other integration methods but the ones still depending on the simulated switches seem to be working again. I’d say this is closed for me.

All,

I can confirm that this issue is still not resolved. I have 10 Virtual Switches (Simulated Alexa Switch) that worked flawlessly with the Smartthings Classic Skill. With the New Smartthings Skill they still seem to function but take 3-10 minutes to execute from the Trigger to the Action.

Hoping that this is resolved soon and working on my patience.

John

Official updates are being posted in another thread:

Hello. Did you ever get Alexa working with a simulated contact? I have the same issue where I have a simulated contact close and echo will chime based on contact closing. Worked great on old smartthings app but not on new one. The chime arrives minutes later. So strange. Can not figure it out.

John

It’s not just you and there’s nothing you can do to fix it. :disappointed_relieved: Smartthings engineering is aware of the problem and is working on it. See the following thread.

New SmartThings Alexa skill (2020)

1 Like

Hi. My alexa routines have stopped working. Specifically the alexa announcements triggered by ST contact sensors.

I have samsung hub and smartthings is installed in alexa via smartthings skills(out of sheer foolishness I deleted the smartthings classic skill and installed the new one thinking that was the problem).

The routine is as follows:

  1. if smartthings contact sensor opens
  2. alexa to announce on all devices: “front door opened”
  3. end of routine

This used to work till aug 2020. I moved to a new house installed the sensors and the hub back. But now the exact same routine has stopped working. On alexa itself, I can see the front door sensor show open or close when the contact sensor is opened or closed but it doesnt trigger the announcement routine.

Any help here is appreciated.

See the post just above yours. Follow the link in that post.

Hi @JDRoberts , Thanks for your reply.
I did read the post by ST engineer and I assumed that since it was 29 days old, something might have changed/fixed since there were no updates since.
In your post specifically, I see that you are albeit slow but receiving echo chime responses.

After my post: I saw this link: https://www.reddit.com/r/SmartThings/comments/i7v24t/echo_speaks_will_stop_working_after_sep_8/ It seems that from Sept 8 all “Echo speaks” implementation are no longer part of the new smartthings integration. Which is probably the reason my routines are not triggering the echo announcements.

1 Like

Yes, EchoSpeaks Will no longer work. :disappointed_relieved: If you have been using that, see the author’s thread for discussion of alternatives.

[Release] Echo Speaks v3 + Actions