Alexa routines now not working

I have routines in Alexa that were triggered by a virtual simulated alexa switch created in IDE and they worked wonderfully.
I also had an alexa routine triggered by a multipurpose sensor on my doors.

This was all done in the new app.

Now, they are not working. Either not at all or with much delay.
I have:
removed the simulated switch in alexa then rediscovered it.
Removed the simulated switch and recreated it in IDE then rediscovered in Alexa.
Recreated the alexa routine.

The delay is SO LONG its as if it never triggered.

1 Like

I have a similar issue with a routine triggered by a multipurpose sensor. This all started when I migrated to the new app a few days ago. I’ve timed it and it’s exactly a 5 minute delay. The SmartThings app will display the notification immediately, then 5 mins later, the routine gets triggered.

1 Like

I’ve heard about new app issues.
I’ve NEVER used the classic app.

Do you think this is a Samsung or Amazon issue?

This is a Samsung issue, but it is not related to the new app, it is related to the new SmartThings Alexa skill. :disappointed_relieved:

Smartthings is aware of it and is working on it. There is nothing you as a customer can do to fix it so don’t waste time on that.

Right now it is very erratic. It may work for a while, then work with a delay, then stop working… Sometimes the device status updates in the Alexa app, but the routine doesn’t trigger. Sometimes the status doesn’t update either. It will absolutely drive you bananas. But, again, all we can do is wait for it to get fixed.

You can follow all the details in the following thread:

New SmartThings Alexa skill (2020)

There will be an official announcement in that thread once it is fixed. Until then, expect erratic results.


I think it’s Amazon issue. I thought it was Samsung, so I have my devices on Home Assistant now but the door sensor triggered routine still doesn’t work on Alexa app.

Have you updated the Alexa app?
I did late last week and things have been working fine.
Three days ago.

It’s not an Amazon issue. I have sensors of about five different platforms, including a Wyze, hue, and ring, and only the smartthings ones failed. And again, smartthings engineering has confirmed that it’s a smartthings issue and that they are working on it. And that there’s nothing an individual customer can do to fix it. you can see some of their posts in the thread that I linked to above.

But it’s a very frustrating issue because it’s not affecting everyone, or even in the same way. :disappointed_relieved:

I got the updated alexa app (not skill) and my problems went away.

That’s great, it just didn’t fix it for everyone. I’m sure if it had been that simple there would’ve been a forum announcement by now, there are a lot of people who have this issue.

I updated. Still not working. Now Echo Speaks is dead, maybe it’s time to try Google Home.

I don’t know. In the Alexa app the status of my contact sensor changes instantly when I open and close the door. It’s just not triggering any routine.

Yes, that’s one of the scenarios that other community members have reported. There are actually about six different ones. Some people report seeing the status change. Some people don’t see the status change. Some people see the status change, but the routine triggers with the delay. Some people have the routine trigger but it repeats itself. And any or all of these can change from day to day. You can see the details of this discussion in the announcement thread:

New SmartThings Alexa skill (2020)

I’m sure all of this is one reason it’s been so hard for smartthings engineering to pin down a solution. But it’s very frustrating. :rage:

Maybe this has something to do with Echo Speaks. Amazon is restricting functions to those who used Echo Speaks.

1 Like

You might think so, but it turns out it’s a completely separate issue. People began reporting problems with Alexa not triggering routines back in May as soon as the new Alexa skill began to be deployed, and SmartThings hadn’t done anything one way or another with echo speaks at that time.

New SmartThings Alexa skill (2020)

And it’s not Amazon restricting the functions, it’s smartthings deciding that echospeaks takes too many resources in the cloud. (just as an example, you can still use the original echospeaks with Hubitat, as the author of echospeaks has confirmed in the author thread in this forum.)

Again, all of this is discussed in detail in the announcement thread about the new Alexa skill. You can see there the dates when people began reporting the problems. :face_with_monocle:

It’s just that Smartthings decided to force the change over to the new Alexa Skill about the same time they cut support for echospeaks. So suddenly a lot more people were affected.