New SmartThings Alexa skill (2020)

So I migrated to the new Alexa skill and the new smarthings app. Worked through the duplicates and setup my routines again. Routines triggered by sensors are still not working – but I’m being patient with that. However, today was a new pain. All of a sudden Alexa won’t discover any new smartthings devices. Has anyone else seen that? @Lars is something going on that would cause this?

1 Like

If no devices are discovered, it usually means there is an issue with your SmartThings account that needs to resolved. If you PM me your Samsung account I can check.

1 Like

Was playing around with Voice Monkey. Setup a “monkey” and I see it in Alexa. Setup a routine to run when the monkey is “pressed”. I went to the URL associated with the monkey in an attempt to trigger it, but nothing happened. What am I missing?

I wrote up instructions on how to use the new Voicemonkey skill here Alexa Voicemonkey Skill that may help. I posted about it a little while back but its much higher in the thread. The skill can be used as an alternative to a virtual contact sensor to trigger a routine, announcement, or get an Echo to speak.


So I’ve dug deeply into this thread. My issue is odd. I’ve done all the steps that are advised to correct problems. I converted over to new ST app. All my Alexa routines worked great under old ST app. Here’s the isssue…Alexa routines that have Alexa speak based on a simulated contact closing trigger still work but the response is literally multiple minutes later. What the heck is going on?? Any counsel?

1 Like

The weird delay has been discussed in at least 20 or 30 of the posts above. It’s definitely frustrating. :disappointed_relieved:

The new Alexa skill is broken for some people, but breaks in different ways at different times.

It’s totally unpredictable whether it will break for you and how it will break.

The following problems can occur with either virtual devices or physical sensors. The DTH that you are using does not matter. :disappointed_relieved:

  1. it might be that the device status will update in both the smartthings app and the Alexa app, but the routine will never trigger.

  2. it might be that the device status will update in both the smartthings app and the Alexa app, but the routine will process with a delay, sometimes a very prolonged delay.

  3. it might be that the device status will update in the smartthings app but not the Alexa app.

  4. it might be that it will be broken for a while, then it will start working again, and then it will break again. Whether you do anything or not.

  5. The routine may run multiple times, either whether with a delay or without. This is particularly noticeable with announcements.

  6. Separately, and for a different reason, EchoSpeaks no longer works. If you have been using that, see the author’s thread for discussion of alternatives.

It’s all very frustrating, it’s all very unpredictable. :rage: All that we know is that smartthings is aware of the problem and they are working on fixing it. And that there is nothing that we as customers can do to fix it. We just have to be patient until a fix is officially announced in this thread.

Or don’t be patient and move on to other methods such as using a sensor from a different platform or using the voice monkey skill described upthread.


Following this thread since it’s still happening to me

Almost moved to the new app this morning, I think I am going to stay on the classic for a while longer!

1 Like

Not sure if anyone has any ideas. I’ve converted to new skill. All my devices are discovered (I started from scratch to remove duplicates). I can turn devices on/off from alexa app (so I know connection is good) but if I ask echo to turn on / off anything I just get a “device no available” response. Not a single device works. Ideas on what I did wrong?

What are the brand/model numbers of the devices? And are you using custom DTHs or just stock?

This sounds like the typical case where you have duplicated devices that are only visible in Did you check for that?

I agree with @JDRoberts, but for me it’s not just the simulated devices, I’m having the same issue using physical devices, (visonic contact, Aeotec door sensor). For example, as a test, I have an Alexa routine that announces whenever the back door opens…response can vary from about 10 sec, to an hour, to never ever. Again that’s with a plain old door sensor.


Me too, rarely feedback on a door locking or unlocking either anymore, which used to work fine.

I came onto Smarthings back in May with the V3 hub, so at the time, I had to use the new Alexa skill and using the old one wasn’t an option for me. I was slightly underwhelmed by the duplicate device issue and not being able to select devices, but at least it worked, and I didn’t really know anything different because I never had access to the old skill. If feel since everyone was forced onto it now, it keeps progressively becoming more unreliable, and it can’t handle the load and has fallen apart. The post higher in the thread from @jdroberts here has been exactly what my experience has been with it.


For anyone having issues getting smartthings integration to get Alexa to speak, If you know webcore, check out voicemonkey.Io. It’s an external service that publishes itself as a doorbell to Alexa. You ‘press’ the doorbell by sending a web request to their server. The virtual doorbell (known as a monkey) can then trigger a routine to do anything. To speak an arbitrary sentence (ie the content of the sentence is sent in the web request) just make the Alexa routine run the voicemonkey skill.

So basically you can run any routine on Alexa circumventing the Alexa integration in smartthings, plus you can get it to say anything you want. You want it to speak from multiple echos? Set up one routine for each echo, triggered by the same monkey.

It’s not echo speaks by any stretch, but it will make a decent substitute while we wait for the lite version of echo speaks OR while we wait for Samsung to fix this issue.


Interesting… Just got this email from Amazon. I’ve refused to update to the new skill due to the device selection issue. I haven’t been home, but AFAIK the old skill is still working. Hopefully ST fixes the device selection issue before the 21st. Not hopeful, and if they don’t, 7 years with ST, it’s off to Hubitat I go.

1 Like

So the wording in the email is a bit ominous. Does it just mean that the old skill stops working on the 21st? Or is it warning us to upgrade before the 21st to avoid losing access to the devices indefinitely? I’m guessing it’s the former?

Former is my guess.

Don’t tell SmartThings. They’ll “fix” it. :frowning:


I’m still on the old skill, and things seem to have been working fine. Looks like that is going to end soon.

1 Like