Alexa routines not triggering

For some reason I have a alexa routine that won’t trigger automatically. I can manually trigger it though. I m currently using smarthings hub and hue hub, working with alexa and ring. Any ideas?

What is the routine supposed to trigger on?

When the ring contact sensor is opened its supposed to turn on a group of hue lights

You’re using Ring directly connected to Alexa for that, correct? (I hope? There’s no reason to round trip to SmartThings from Ring…)

That doesn’t - shouldn’t have anything to do with Smartthings - you’d have to ask Ring / Alexa what’s going on there.

The hue bulbs are connected to both the hue bulb and smartthings, is that what you were referring too?

Had the same issue. I disabled and the enabled the Alexa Ring skill, and also signed out and signed back into the Alexa app. After these steps everything worked again.

I’ll try that again, even my 2 ring chimes won’t play audio chimes when a contact sensor opens

What I’m saying here is that both Hue and Ring have working Alexa skills. If you are setup in Alexa properly (and by properly I mean least trips between clouds) and you are relying on an Alexa routine. Then you have both the Hue and Ring skills active.

That means, Ring would trigger its contact sensor and communicate to Alexa directly through the Ring skill. The Alexa routine fires which should turn on the He bulb, which signal gets sent over the communications channel created by the Hue Alexa skill. - SmartThings does not come into play unless you’re misconfigured.

By misconfigured - I mean you’re suing the SmartThings exposed copy of the Ring sensor OR The SmartThings exposed copy of your Hue Lamp in that Alexa routine. (You can look at the properties of the devices in Alexa and determine which skill provides a specific device. - you should have the SmartThings copies of these Hue and Ring devices disabled in Alexa to make sure the Hue and Ring versions are used by Alexa.)

If you’re misconfigured - fix it.
If you’re not and have the SmartThings versions of the devices disabled, then SmartThings has nothing to do with this - it’s one of the other three components.

1 Like

Same problem in Italy since yesterday …

I can’t believe I’m the only one with this problem …
All the alexa’s routines triggered by smartthings’s device don’t work …

Mine started about a day ago. What’s odd is there was a ring update just before that

For some customers, that would be because of the Amazon Web services outage during that time:

OK, but they haven’t solved the problem yet ?
I have just disconnect and reconnect the app but the problem is the same …

I’m not sure whether anyone is still having problems or not. It would probably be best to contact Amazon support on that issue if it’s still not working for you.

1 Like

My physical devices in ST trigger Amazon routines great but my one and only virtual switch does not work. Has been driving me crazy for weeks since the update and I finally gave up trying different DTH and apps yesterday.

1 Like

Yes, I’ve already contacted Amazon support (Italy) but It’s like talking to kids and they don’t know I’m talking about …

Ok, I, instead, since two days ago I was 12 virtual sensors with 12 alexa’s routine and everything was working fine, since two days ago …
Now, the virtual sensor are always in the alexa’s app, I can turn them on manually, but the routines don’t start (but if I start the routine manually they work fine).

OMG! Finally have my virtual switch triggering an Amazon routine every time for 2 days straight. I know I said I gave up, but after a day I wondered if I ever deleted and recreated the routine in Alexa. That was what it took. Who knew.

Sharing just in case it may help someone else.

I’m happy for you …
and yesterday my routine also start again and this is the reason:

The skill (SmartThings) import in app alexa all the devices and then I disabled the devices I don’t use in alexa’s routine …
Well, this operation was blocking the routine triggered by virtual sensor also (active of course).
Therefore I’ve enabled all the devices and magically all the routine work fine again, It’s crazy but that’s how that I solved …


I’m having this issue with physical devices linked via SmartThings. For example, I have a routine for Alexa to announce when a door is open. Alexa can see the device (door contact sensor) and is reporting the correct status but just doesn’t make the announcement. Furthermore, creating a new routine with same parameters also does not yield an announcement. So it seems the issue is strictly with the announcement portion of Alexa? I’ve tried power cycling Alexa.