Alexa no longer seeing ST items

I had been using the Alexa Helper to control ST for a long time, but decided to try the new Hue skill. That skill stunk. So I deleted it and went back to ST - reinstalling the Smartthings Skill, and then verifying the Alexa Helper smartapp is working and has everything exposed. All looks good but Alexa can’t find any ST devices.

I’ve rebooted everything in various orders, and tried reinstalling in various orders, with no luck.

The only thing I can think - when I was uninstalling the Hue skill, it was stuck and I had to go into the Hue Clip interface to delete the whitelist item for that skill. I also deleted a few Echo items I saw, to start everything fresh.

Hue works great with Alexa still, but ST doesn’t. Can’t figure it out!

Have you re-authorized the devices for use by echo?

See Step 10 in the setup FAQ:

1 Like

Hi there, yes. Both in the iOS app and also tried at
Seems like they get authorized but then still won’t be discovered.

Very frustrating. :persevere: Probably best to contact support, then.

They are saying talk to the skill developer :frowning:

Sorry, I completely missed that you were using Alexa helper.

Tagging @MichaelS

To be clear, Alexa Helper does NOT use a custom skill…it uses the SmartThings Skill (which SmartThings should support). Ask Alexa is a custom skill and I can provide support on that.

Just want to make sure we are all clear…It SOUNDS like you are indeed using Alexa Helper and having issues discovering the switches? That is all SmartThings…Let me know if I am mistaken.

1 Like

You are correct. I am talking about the SmartThings skill. Thanks!

And to be clear, I have a ticket working with ST support. But it sounds like they are telling me to go talk to Amazon. Amazon said go talk to Smartthings.

Of course…the classic help desk run around…sorry I can’t help more :frowning:

Exactly which devices are you trying to control through Amazon? (brand and model)

Can you forget about Alexa helper for a minute and just set up some smartthings lights to work with echo? Because then SmartThings support should be able to help you figure out what’s going on.

I think I’m being confusing. :slight_smile: I’m using the standard Alexa/ST
integration, not Ask Alexa.

It worked for many months, controlling all my items. Hues, Lightify strips,
GE Plugs, Aotech plugs, etc. I recently uninstalled the skill and
reinstalled it and now it sees nothing at all. I see the Alexa smartapp, I
have authorized all devices. But Alexa cannot discover any.

Go into the Smartthings mobile app. Tap on automations. Tap on smartapps. Find the Amazon echo smartapp. Tap on it. Check the box for all of the devices you want Alexa to see. Tap done.

Gold into the Amazon Alexa mobile app. Tap on smart home. Tap on discover devices. Wait 30 seconds. Smile.

Just making sure you did perform this very important step.

Make sure you haven’t somehow linked Alexa to more than one SmartThings Location.

If on the SmartThings OAuth page presented by Alexa when you link to SmartThings you get a Location drop down with more than one choice, it can definitely cause this problem.

1 Like

Support has nuked the Alexa app and it looks like dual locations was the problem. All better now!


I take gratuities in PayPal or Bitcoin… 17rRBigpFgNvckJapL99bouCVHtM7cTn7R