Alexa doesnt find scenes

I have created a scene in the smartthings app. It controls two leviton DW6HD dimmer switches and one ecobee 4 thermostat. I have had this scene for several days. I have alexa account and smartthings account linked. When i search for devices in alexa there are no scenes found. I have tried this each day just hoping it was taking the alexa app a long time to find the new scene.

Can anyone suggest another debugging step i can try to get this scene into alexa?

Thank you

Which Alexa skill are you using? The new skill for Alexa is essentially instantaneous with showing new devices/scenes from ST. You don’t even need to do any discovery. I actually created a scene just this morning in the new app and it popped right up over on Alexa.

Are you using the old skill, where you can choose which devices and scenes Alexa can access, or the new skill where all are available, like it or not? If the former, have you checked your settings?

The other thing you can try is testing a scene without one or more of those devices, just in case any are deemed ‘sensitive’ (rightly or wrongly) as that prevents access.

OMG. The skill was linked to my samsung account. I tried unlinking and relinking and everything showed up. Not great that alexa doesnt warn you that the linked account was having a problem but at least it sees my scenes now. Thank you for the assistance.