Alexa Connecting to Wrong Hub


#1

Overnight, it appears, my Amazon Echo integration got messed up:

My parents also use SmartThings and I have it setup so that I have access to both their hub and my own in the app. I rarely use this access - its mostly for helping them out when they have questions. They have an Amazon Echo connected to their account. I have an Echo connected to my own account (and only my own devices) and have been using this integration on a daily basis for a long time now.

Today, when I went to turn on the living room, Alexa claimed she didn’t know what living room was. Odd. I went in the Alexa app and found most of the devices were listed as “offline”. My direct-to-harmony integrations appear intact. I “discovered devices” assuming it would resolve it, but no change. I disable the Alexa skill and relink, confirming the correct devices were given access. No change. Then I notice the only devices not offline appear to be my parents… which have never been connected to MY Amazon account. I try to interact with them - Alexa complies. I call my parents and confirm I am turning their devices on and off.

As a nuclear option, I remove the Skill, SmartApp, forget all devices and groups, then relink and discover from scratch. Now my devices are no longer listed at all and only my parents devices are shown.

Now, the one wrench in this is that yesterday I decided to setup AskAlexa (following instructions listed here: http://thingsthataresmart.wiki/index.php?title=Ask_Alexa) but I don’t see how that could affect this. The app wasn’t installed on my parents hub nor were any of their devices involved. Just to be safe, I disabled the skill in the Alexa app, but didn’t make a difference.

This seems like a security issue - how am I controlling devices I haven’t granted access to Alexa to?


Alexa and Latest Update
Alexa and V2 Hub
PSA: If two locations/hubs both have Alexa + Smartthings integration - Alexa will only be able to control devices from one of them
Hub Firmware Upgrade 16.13 BROKE Functionality
#2

Playing around with this more:

  1. I disabled SmartThings skill
  2. Readded it, but selected parents hub and “granted” access to no devices (unchecked all)
  3. Discovered Devices -> now parents devices are “offline”
  4. Removed Skill again.
  5. Added it again, this time chose my own hub and checked appropriate devices.
  6. Discover Devices -> parents devices still “offline”, none of mine show up

Its almost like Alexa->SmartThings has become hub-unaware and has decided that my parents hub is the “default”. So if I uncheck their devices, its as if I took away access to all devices from the only available hub thus making everything “offline” and adding my own devices or attempting to discover them doesn’t work because Alexa only sees the one hub.


#3

Currently, your SmartThings account can only connect one location to Alexa, regardless of how many locations you have. That means only one hub. This is also true for some other third-party implementations, including IFTTT.

I’m not sure what happened when you added ask Alexa, but the timing does make it seem like you manage to shift which was your default location. I don’t know of any way to change that, but @MichaelS might. But you’ll still only be able to have one.


(Ryan Stefanski) #4

Similar issue here. When I ask Alexa to discover my devices from one specific hub of my three, it discovers devices from a hub that is different from what I selected. I tried selecting a different hub, but get the same devices no matter which of the three hubs that I select. It worked before, but doesn’t any longer…


#5

I am not expecting to control multiple locations from one Amazon account. I am expecting two SmartThings accounts/hubs to be controlled by two Amazon accounts, with the only extra being my SmartThings mobile app having both locations.

This has worked as expected for months if not more. I called my mom and she says they use Alexa every day to control their devices (just as we use ours to control our own).

So, here is more experimenting with my mom on the phone:

When I revoked access (to their devices on their hub) in my Echo app via my SmartThings account, it revoked access for their Echo (it stopped working). When I regranted access, it grants access to both my Echo in my home and their Echo in their home. We both can control my parents devices via our separate Echos on separate Amazon accounts at the same time.


#6

To add: when I setup AskAlexa, I made no changes to the official SmartThings integration on either end


#7

Here is another thread from today where someone is having trouble controlling and discovering devices as of today.


#8

I just saw that. My parents have a V2 hub. I have a V1. I doubt firmware update would affect this, but I am wondering if they made cloud/API changes at the same time?


#9

So far I have only seen this type of symptoms in these two posts but it does make one stop and think. It may be more than a simple coincidence.


(Ryan Stefanski) #10

I wonder if this has anything to do with the SmartThings firmware update that just took place:

"On Monday, January 30, between 11:00 am EST and 2:00 pm EST, we will automatically update your SmartThings Hub to the latest firmware (version 0.16.12). The update is expected to take less than 10 minutes, during which time your SmartThings Hub will temporarily go offline and events scheduled for this time will not be processed.

This update improves Hub connectivity with the SmartThings platform, fixes an issue causing Hub backup batteries to drain faster than expected, addresses a Hub crashing issue when certain SmartApps are used, and adds capability to provide over-the-air firmware updates to Osram and Hue bulbs."


(Jefferson Myers) #11

Thanks for linking in my issue to this thread. I’ve got mine working again, but I don’t think you’ll like the method…

Your thread got me thinking and I remembered that I had my old V1 hub still connected to the router (I converted to V2 over the holidays)…it was also set up under another location within my account. I first deleted the hub, went through all my previous settings and no change. I then removed the original location that had contained the V1 hub. A quick discovery and Alexa reported that all 38 devices were back on line.

Now I just have to set up all of my groupings again…


#12

So, I worked around the issue: I had parents revoke my access to their hub, then I forgot all devices and reconnected Alexa.


#13

The fact that you didn’t setup AskAlexa and had the same issue, and effectively the same solution (removed the 2nd location) suggests to me this was something other than just my AskAlexa addition yesterday…

It makes sense to me the limitation that the Echo can only control one location at a time – SmartApps instances can only exist within the context of a single hub and the SmartThings side of the integration is implemented as a SmartApp. I would assume when you go through the whole oAuth dance between SmartThings and Amazon, it creates a connection between that instance of the SmartApp and the Alexa skill. In order to connect multiple locations either they would either have to create something like account-bound SmartApps or they would need to make changes on the Amazon side.

What is weird is that at least as of now, this doesn’t seem to be how it works. It appears to connect to a (seemingly) random hub within your account irrespective of which hub has the SmartApp instance that was created during the linking. Perhaps it was always like this and as JDRoberts suggests somehow its choice in hub switched within the last day…


#14

@Jefferson_Myers did you have the Amazon Alexa SmartApp installed on both locations? Or had you uninstalled stuff from the old hub?


(Jason "The Enabler" as deemed so by @Smart) #15

Question… Did you try telling Alexa to change accounts? It may have changed somehow over to your parents account.


(Jefferson Myers) #16

I had removed the Smart App from the V1 hub in December, but both locations still showed up when choosing devices for Alexa access. Once the location was removed, it worked great. It was still working this morning with no issues.


(Kevin) #17

I am having the exact same problem. I have 2 houses, each with a hub. Everything was up and running Sunday night. Monday morning I told Alexa to turn on some lights and she (it?) couldn’t find them. I removed the skill and reinstalled it and when it asks for the ST login, you can give it access to one location. I pick my main house, and it gives a correct list of devices at this location. After I finished the install and do a device discovery via Alexa, she finds the items in my other house. To make it stranger Alexa finds the wifi switches here, but not the zwave and vice versa. I only have one Amazon account and only one ST account and only want Alexa to control devices at one location.


(Kevin) #18

Remove the Alexa Smartapp at the other location!

I just solved my issue. I had installed the Alexa SmartApp at both locations. Someone gave me an Echo for Xmas so I’d opened it and set it up at my other location and forgot to remove it. It didn’t matter before the update something changed. Anyhow, I removed the Alexa smartapp from the other location and forgot all the devices Alexa found. Did a device discovery and it found everything at my current location.


#19

No, my Alexa has no connection to my parents account in order to switch. They have their own completely separate Amazon account and we are not in any kind of “Amazon Household” share or anything like that.


#20

This is fairly consistent with my experience (difference being both locations are directly tied to your SmartThings and in my case one of them is tied to my parents with it shared over to me).