Alexa App Detects, but Echo can't see it!


(Jamie Duke) #1

The Alexa app detects my 2 Honeywell thermostats. However, the echo can’t see them or control them. I’ve tried detecting through the echo and that doesn’t work either. Tried forgetting and redetecting several times. Unplugged echo.

Any thoughts?


(Dan P Parker) #2

Did you nark the devices as authorized for use in the Alexa smart app in ST?


(Jamie Duke) #3

I had not, but now I have. The echo still can’t see them, but never the Alex app recognizestore each thermostat twice. Once as a honeywell device and once as ST device.


(Brad) #4

So you’re telling Alexa to “discover devices” and she finds two devices?


(Jamie Duke) #5

The Alexa app finds 4 (each thermostat twice) when you click “detect device”. When giving a voice commands to the Echo to detect devices, it finds nothing.


(Baloo247) #6

Mine does this with other devices that it wither supports natively but also sees via smartthings. Just delete one of them. Either the smartthings provided device or the native one.


(Jamie Duke) #7

I deleted 2 of the devices. But the Echo still says it can’t find the “thermostat” or either of the names I gave the devices.


(Zen) #8

I just have similar issue with my 3 yeelight bulbs I am not sure if has something to do with Amazon my harmony hub is working fine though


(Tyler Durden) #9

You may want to delete the two devices from the Alexa app and tell it to discover them again just in case the devices you removed earlier were the 'good ones and you kept the ‘ghosts’. Also, the name of your devices could matter. Make sure they aren’t using words Alexa may reserve for other functionality. Spelling is also important. If you misspelled the words in your names Alexa won’t likely recognize it when you say it.