Aeotec Temperature & Humidity Sensor

The pairing process with the custum data handler provided by Aeotec helpdesk is not clean right now. Here’s how I remember it worked for me:

  1. Log into Graph IDE, create new data handler, publish, this will show up later as “Z-Wave Temperature/Humidty Sensor”
  2. Factory reset your AerQ by holding it down for 10 seconds. First 5 seconds nothing, then it starts blink green for 5 seconds, and after 10 seconds total, the green light stays solid for a little while and then goes blank.
  3. This is unscientific, but wait for 30 seconds before the next step (I dont’ know how long factory reset takes)
  4. Start Inclusion Mode on Your phone > add device > scan
  5. Turn AerQ in pairing mode. This is kludgy. It says press it 3 times, but speed matters. So It seems you can’t press super quick, but if you press 1 per second, that’s too slow. So press 3 times then see if the light on AerQ flashes Red-Green which indicates its pairing. After this the lights will go blank.
  6. Z-Wave pairing is slow (compare to Zigbee), so give it up to 1 min to see your phone, and just wait.
  7. It’ll eventually say fail to connect Secure Mode - here I don’t remember exactly, but do not abort, but find whatever on the screen that sort of go forward or skip secure mode (I can’t remember exactly, but don’t click X and abort)
  8. Eventually AerQ will pair in non-secure mode. You’ll get a success message. At this point, it’ll show up as a device that’s unassociated with a room, but with the custom data handler type.
  9. Edit device and change room.

Hope this helps.

1 Like

Thanks again! Unfortunately, still no joy - it always joins initially as a darn Open/Closed Contact sensor no matter what I do.

I had previously been joining it securely, so I thought your idea of just doing an unsecure join might do the trick, but it made no difference for me… I’ve now tried every variation of factory reset, exclude, secure/insecure I can think of.

Well - on the plus side - it’s not as if the device doesn’t work at all - it does, so that’s cool.

I’m guessing Aeotec may work some magic soon (since holidays distraction is over) to address all of this - there’s clearly some confusion on their end with the documentation, published DH etc, so maybe they’ll get all this sorted out better in the next week or so.

Decided to try one more time with the 2018 DH (the “Temp/Humidity” one, not the"Water/Temp/Humidity" one), and it worked!

It joined with that desired DH, and now only shows Temp, Humidity, and Battery statuses, so much winning.

As an experiment, I tried joining both unsecurely and securely - it worked both ways. I’ve left it joined secured since I recall hearing that S2 is better for battery life.

But I can’t quite escape that darn Open/Closed gremlin… Now its sensor icon (in the app) displays as an open-closed sensor (???). But I can live with that since only the desired data fields are showing up finally.

Ack, just noticed my temp values in app say they’re in C, but are F values.

And the the time between polling updates is forever. That seemed better using the other DH (that had the not useful contact and water sensor attributes), but who knows.

So far, everything with this device seems to be one step forward, one step back… I’m gonna shelf this thing till Aeotec gets their act together.

1 Like

First, thanks to all who posted the DTHs in this thread, I was able to get the sensor working, but as others noted, the polling time seems long. Aeotec manual says that it defaults to 15 mins.

Apologies if this is a dumb question, but is there a parameter in the DTH that allows us to set the polling interval? I know it would drain the battery faster, but I’d like to set it to something shorter than 15 mins (or whatever it’s set to in the DTHs so far).

Any feedback appreciated.

  • Dan

Thanks to all who posted answers so far. I also got it to work but polling varies somewhere between 3 hours and a few days for all 3 of the devices I have. I hope there is a fix for this at some point.

Aeotec Field Engineer Chris has been good at following up via their helpdesk ticket. Looks like they are still working on it. The the device driver was posted on 2020-12-31, and subsequently on 2021-01-08. The 2nd update added settings to customize three things: (1) Temperature change update threshold, (2) Moisture change update Threshold, and (3) Regular update interval (will update at a fixed interval IN ADDITION to what’s set in 1 and 2).

The setting explanation is abit vague first time setting them, so heres what worked for me:

  1. Temperature Threshold - You can set value between 1 and 100. This value is then divided by 10 which equals degrees. So if you want temperature change update to be 2 degrees, you set value to 20 (20 / 10 = 2 degrees.
  2. Moisture Threshold - Set value between 1 and 20. This one is straight % change. So a value of 2 equals 2% moisture change will send an update.
  3. Regular Update Interval - value is in seconds. so 60 seconds * 60 minutes * 3 hours = 10800; update every 3 hours.

I copied the new version dated 2021-01-08 and and republished it through web graph ide.

Aeotec engineer confirmed the main tile value is still not yet work.

2 Likes