Aeotec Smart Switch 7 very slow, any way to speed this thing up? (z-wave)

In the smartthings options and info for the device, i see the device history always doing nothing for quite some minutes. manually refreshing helps, and then it can report quite a bit within a single minute. But if i stop manually refreshing, it stops reporting power for quite a while. At least 10 minutes. I installed a driver from aeotec themselfs i found online, which allows me to tweak a few settings, but no luck with this either. Reverting to the standard driver has no changable settings whatsoever.
I want to use this device with routines for “if power usage is this, then that”. So i need it to report at least a few times in a minute.

Any tips i can try would be welcomed.

EDIT: Waited 25 minutes, no update in history is showing.
See the screenshot, it shows a 25 minute difference in current time and last updated history.


When refreshing, it quickly shows the actual number, but there’s a gap in the history of 25 minutes…

What are the settings available from the Aeotec driver? If the power draw hasn’t changed over a certain threshold from last report then the device probably won’t send a message.

1 Like

Here:


I changed the watt value quite a few times, without luck. i have now a period of 45mins without any report. Manually swiping down to force a refresh makes it show up in history.

They are connected to solar panels, by the way, and those watt values therefore change quite often.

I assume that watt threshold means the wattage needs to change 30W in order to send a report. So has the reading changed by at least 30 W from the previous one when you do the manual refresh?

yes. i also had it on “4” and didn’t work. i put it on 30 because maybe there is a minimum you have to set it to, or else it default’s to some standard parameter.